Bug 309751 - "Disable swap file syncing" disables swap files completely
Summary: "Disable swap file syncing" disables swap files completely
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: 4.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 309753 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-08 15:50 UTC by Bram Vandoren
Modified: 2013-05-02 10:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bram Vandoren 2012-11-08 15:50:12 UTC
If I enable "Disable swap file syncing", kate disables the swap file is completely (it's not updated or created).

Reproducible: Always

Steps to Reproduce:
1. Enable "disable swap files syncing" in "Configure Kate" -> Editor Component -> Open/Save -> Advanced
Actual Results:  
Swap file is completely disabled.

Expected Results:  
Only disable the fsync call.

The option should be renamed to "disable swap file", fixed, or removed completely.
Comment 1 Christoph Cullmann 2012-11-09 18:08:05 UTC
Git commit f076a0de82a4534a42644c5f4aa8d914efad20cb by Christoph Cullmann.
Committed on 09/11/2012 at 19:07.
Pushed by cullmann into branch 'master'.

fix that disable swap file syncing caused no swap files at all
thanks for reporting this, stupid mistake

M  +2    -2    part/swapfile/kateswapfile.cpp

http://commits.kde.org/kate/f076a0de82a4534a42644c5f4aa8d914efad20cb
Comment 2 Dominik Haumann 2013-04-16 14:53:06 UTC
*** Bug 309753 has been marked as a duplicate of this bug. ***
Comment 3 przemek.kobel 2013-05-02 10:01:12 UTC
Actually, it was a quite useful 'mistake' if you edit in directory mounted via sshfs. Right now such edits are not practical, since Kate is way too slow for this.

And I WAS using sshfs (not anymore after the 'fix'), since it is the only way for Kate to remember folding state across sessions, since files opened in sftp/fish/ftp folders are always completely unfolded.

Now, if anyone could stop immediate auto-unfolding code after typing an opening quote...