Bug 309577 - crash signal 11 on forwarding mail
Summary: crash signal 11 on forwarding mail
Status: RESOLVED DUPLICATE of bug 312302
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.5
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 324492 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-05 10:29 UTC by Michael Monnerie
Modified: 2014-01-30 02:47 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.83 KB, text/plain)
2012-11-05 10:37 UTC, Michael Monnerie
Details
New crash information added by DrKonqi (8.46 KB, text/plain)
2013-01-24 17:30 UTC, Martin
Details
New crash information added by DrKonqi (8.65 KB, text/plain)
2013-05-06 09:16 UTC, Pavel Punegov
Details
New crash information added by DrKonqi (8.52 KB, text/plain)
2013-07-19 13:28 UTC, kdebugs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Monnerie 2012-11-05 10:29:46 UTC
Application: kontact (4.8.5)
KDE Platform Version: 4.8.5 (4.8.5) "release 2"
Qt Version: 4.8.1
Operating System: Linux 3.6.3-zmi x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I took an old message from my inbox, pressed "forward", and clicked on "send". When the message dissapeared, I immediately selected the next message (cursor keys), and wanted to forward that as well. Was I too quick?

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe68d3fc780 (LWP 16911))]

Thread 5 (Thread 0x7fe6748ef700 (LWP 16912)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe689c14177 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fe689c141a9 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fe685287e0e in start_thread (arg=0x7fe6748ef700) at pthread_create.c:305
#4  0x00007fe68a9242bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7fe673fce700 (LWP 16913)):
#0  0x00007fe68a9181dd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fe684d1582f in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe684cda209 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe684cda622 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fe684cda7a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007fe68b099956 in QEventDispatcherGlib::processEvents (this=0x7fe66c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fe68b06a73f in QEventLoop::processEvents (this=this@entry=0x7fe673fcde20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fe68b06a9c8 in QEventLoop::exec (this=0x7fe673fcde20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fe68af6ee40 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fe68af71ddb in QThreadPrivate::start (arg=0xa6dc10) at thread/qthread_unix.cpp:298
#10 0x00007fe685287e0e in start_thread (arg=0x7fe673fce700) at pthread_create.c:305
#11 0x00007fe68a9242bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fe624ddf700 (LWP 17758)):
#0  0x00007fe68a91c13f in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe684cda684 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe684cda7a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe68b099956 in QEventDispatcherGlib::processEvents (this=0x7fe620010480, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fe68b06a73f in QEventLoop::processEvents (this=this@entry=0x7fe624ddedf0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe68b06a9c8 in QEventLoop::exec (this=0x7fe624ddedf0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fe68af6ee40 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fe68b04b11f in QInotifyFileSystemWatcherEngine::run (this=0x3961d60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe68af71ddb in QThreadPrivate::start (arg=0x3961d60) at thread/qthread_unix.cpp:298
#9  0x00007fe685287e0e in start_thread (arg=0x7fe624ddf700) at pthread_create.c:305
#10 0x00007fe68a9242bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fe61b0af700 (LWP 2067)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007fe68af72237 in wait (time=30000, this=0x38e1ed0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x38e2558, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fe68af65adf in QThreadPoolThread::run (this=0x38e3f20) at concurrent/qthreadpool.cpp:141
#4  0x00007fe68af71ddb in QThreadPrivate::start (arg=0x38e3f20) at thread/qthread_unix.cpp:298
#5  0x00007fe685287e0e in start_thread (arg=0x7fe61b0af700) at pthread_create.c:305
#6  0x00007fe68a9242bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fe68d3fc780 (LWP 16911)):
[KCrash Handler]
#6  0x00007fe681497a14 in KMime::Content::parent (this=0xd17f070) at /usr/src/debug/kdepimlibs-4.8.5/kmime/kmime_content.cpp:928
#7  0x00007fe6814b2047 in KMime::Content::addContent (this=0x1353a7c0, c=0xd17f070, prepend=false) at /usr/src/debug/kdepimlibs-4.8.5/kmime/kmime_content.cpp:557
#8  0x00007fe6707d6ef6 in TemplateParser::TemplateParser::createMultipartMixed (this=this@entry=0x7fffcd4710e0, ac=..., textPart=textPart@entry=0xd1c3c50) at /usr/src/debug/kdepim-4.8.5/templateparser/templateparser.cpp:1250
#9  0x00007fe6707db1d0 in TemplateParser::TemplateParser::addProcessedBodyToMessage (this=this@entry=0x7fffcd4710e0, plainBody=..., htmlBody=...) at /usr/src/debug/kdepim-4.8.5/templateparser/templateparser.cpp:1228
#10 0x00007fe6707db5c4 in TemplateParser::TemplateParser::processWithTemplate (this=0x7fffcd4710e0, tmpl=...) at /usr/src/debug/kdepim-4.8.5/templateparser/templateparser.cpp:1151
#11 0x00007fe6707d689a in TemplateParser::TemplateParser::process (this=0x7fffcd4710e0, aorig_msg=..., afolder=...) at /usr/src/debug/kdepim-4.8.5/templateparser/templateparser.cpp:283
#12 0x00007fe670d49aec in MessageComposer::MessageFactory::createForward (this=0x7fffcd4712b0) at /usr/src/debug/kdepim-4.8.5/messagecomposer/messagefactory.cpp:390
#13 0x00007fe67189cbaf in KMForwardCommand::createComposer (this=this@entry=0xdd3a110, item=...) at /usr/src/debug/kdepim-4.8.5/kmail/kmcommands.cpp:865
#14 0x00007fe6718a256a in KMForwardCommand::execute (this=0xdd3a110) at /usr/src/debug/kdepim-4.8.5/kmail/kmcommands.cpp:921
#15 0x00007fe67189d671 in KMCommand::slotPostTransfer (this=0xdd3a110, result=KMCommand::OK) at /usr/src/debug/kdepim-4.8.5/kmail/kmcommands.cpp:268
#16 0x00007fe68b081f5f in QMetaObject::activate (sender=0xdd3a110, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffcd471720) at kernel/qobject.cpp:3556
#17 0x00007fe67189d47e in KMCommand::messagesTransfered (this=this@entry=0xdd3a110, _t1=_t1@entry=KMCommand::OK) at /usr/src/debug/kdepim-4.8.5/build/kmail/kmcommands.moc:117
#18 0x00007fe6718a1cea in KMCommand::slotJobFinished (this=0xdd3a110) at /usr/src/debug/kdepim-4.8.5/kmail/kmcommands.cpp:378
#19 0x00007fe68b081f5f in QMetaObject::activate (sender=0xd1ae0f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffcd4718d0) at kernel/qobject.cpp:3556
#20 0x00007fe68b4f6762 in KJob::result (this=this@entry=0xd1ae0f0, _t1=_t1@entry=0xd1ae0f0) at /usr/src/debug/kdelibs-4.8.5/build/kdecore/kjob.moc:208
#21 0x00007fe68b4f67a0 in KJob::emitResult (this=0xd1ae0f0) at /usr/src/debug/kdelibs-4.8.5/kdecore/jobs/kjob.cpp:318
#22 0x00007fe68b0800ae in QObject::event (this=0xd1ae0f0, e=<optimized out>) at kernel/qobject.cpp:1204
#23 0x00007fe68ba7674c in QApplicationPrivate::notify_helper (this=this@entry=0x885f50, receiver=receiver@entry=0xd1ae0f0, e=e@entry=0xfc10120) at kernel/qapplication.cpp:4554
#24 0x00007fe68ba7ac7a in QApplication::notify (this=0x7fffcd472370, receiver=0xd1ae0f0, e=0xfc10120) at kernel/qapplication.cpp:4415
#25 0x00007fe68c78b006 in KApplication::notify (this=0x7fffcd472370, receiver=0xd1ae0f0, event=0xfc10120) at /usr/src/debug/kdelibs-4.8.5/kdeui/kernel/kapplication.cpp:311
#26 0x00007fe68b06b73e in QCoreApplication::notifyInternal (this=0x7fffcd472370, receiver=receiver@entry=0xd1ae0f0, event=event@entry=0xfc10120) at kernel/qcoreapplication.cpp:876
#27 0x00007fe68b06f091 in sendEvent (event=0xfc10120, receiver=0xd1ae0f0) at kernel/qcoreapplication.h:231
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x852350) at kernel/qcoreapplication.cpp:1500
#29 0x00007fe68b0997a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#30 postEventSourceDispatch (s=0x885de0) at kernel/qeventdispatcher_glib.cpp:279
#31 0x00007fe684cda3b5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#32 0x00007fe684cda6e8 in ?? () from /usr/lib64/libglib-2.0.so.0
#33 0x00007fe684cda7a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#34 0x00007fe68b099936 in QEventDispatcherGlib::processEvents (this=0x857b80, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#35 0x00007fe68bb168ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007fe68b06a73f in QEventLoop::processEvents (this=this@entry=0x7fffcd4721e0, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007fe68b06a9c8 in QEventLoop::exec (this=0x7fffcd4721e0, flags=...) at kernel/qeventloop.cpp:204
#38 0x00007fe68b06f3a8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#39 0x0000000000403699 in main (argc=1, argv=0x7fffcd4724b8) at /usr/src/debug/kdepim-4.8.5/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Michael Monnerie 2012-11-05 10:37:54 UTC
Created attachment 75025 [details]
New crash information added by DrKonqi

kontact (4.8.5) on KDE Platform 4.8.5 (4.8.5) "release 2" using Qt 4.8.1

- What I was doing when the application crashed:

Now I restarted and tried to forward the 2nd message again, and kontact crashed again. So it seems to be a problem with that one message. It's on an IMAP server, so probably the local cache has been destroyed. But I'm not sure which cache dir I should clean up, as I have ~10 accounts, and they are numbered instead of named. So how do I find out what account is behind .814919031.directory/ and so on?

-- Backtrace (Reduced):
#6  0x00007f0ffb86fa14 in KMime::Content::parent (this=0x57995c0) at /usr/src/debug/kdepimlibs-4.8.5/kmime/kmime_content.cpp:928
#7  0x00007f0ffb88a047 in KMime::Content::addContent (this=0x20baae0, c=0x57995c0, prepend=false) at /usr/src/debug/kdepimlibs-4.8.5/kmime/kmime_content.cpp:557
#8  0x00007f0fa69eeef6 in TemplateParser::TemplateParser::createMultipartMixed (this=this@entry=0x7fff4de87bc0, ac=..., textPart=textPart@entry=0x20c0a10) at /usr/src/debug/kdepim-4.8.5/templateparser/templateparser.cpp:1250
#9  0x00007f0fa69f31d0 in TemplateParser::TemplateParser::addProcessedBodyToMessage (this=this@entry=0x7fff4de87bc0, plainBody=..., htmlBody=...) at /usr/src/debug/kdepim-4.8.5/templateparser/templateparser.cpp:1228
#10 0x00007f0fa69f35c4 in TemplateParser::TemplateParser::processWithTemplate (this=0x7fff4de87bc0, tmpl=...) at /usr/src/debug/kdepim-4.8.5/templateparser/templateparser.cpp:1151
Comment 2 Martin 2013-01-24 17:30:07 UTC
Created attachment 76690 [details]
New crash information added by DrKonqi

kontact (4.10 rc3) on KDE Platform 4.9.98 using Qt 4.8.3

- What I was doing when the application crashed:

I was reading an email with attachements. When I pressed f to forward the mail Kontact crashed.

-- Backtrace (Reduced):
#6  0x00007f68c60070b4 in KMime::Content::parent (this=0x5204e90) at ../../kmime/kmime_content.cpp:952
#7  0x00007f68c600a267 in KMime::Content::addContent (this=0x5636480, c=0x5204e90, prepend=<optimized out>) at ../../kmime/kmime_content.cpp:582
#8  0x00007f686abd4886 in TemplateParser::TemplateParser::createMultipartMixed (this=this@entry=0x7fff96771a80, ac=..., textPart=textPart@entry=0x5b209d0) at ../../templateparser/templateparser.cpp:1298
#9  0x00007f686abd8b90 in TemplateParser::TemplateParser::addProcessedBodyToMessage (this=this@entry=0x7fff96771a80, plainBody=..., htmlBody=...) at ../../templateparser/templateparser.cpp:1275
#10 0x00007f686abd8f84 in TemplateParser::TemplateParser::processWithTemplate (this=0x7fff96771a80, tmpl=...) at ../../templateparser/templateparser.cpp:1187
Comment 3 Martin 2013-01-24 17:35:57 UTC
This happens everytime. Using SHIFT+F (forward as attachment) Kontact does not crash and works fine.
Comment 4 Pavel Punegov 2013-05-06 09:16:46 UTC
Created attachment 79726 [details]
New crash information added by DrKonqi

kontact (4.10.2) on KDE Platform 4.10.2 using Qt 4.8.2

- What I was doing when the application crashed:

First, I forwarded to myself 2 mails as a digest. Kmail crashes  when I try to forward the email I had received. This reproduces every time.
And it crashes just when I press the "Forward" button.

-- Backtrace (Reduced):
#6  0x00007f96f1e984d4 in KMime::Content::parent() const () from /usr/lib/libkmime.so.4
#7  0x00007f96f1e9abaf in KMime::Content::addContent(KMime::Content*, bool) () from /usr/lib/libkmime.so.4
#8  0x00007f969657fc5c in TemplateParser::TemplateParser::createMultipartMixed(MessageCore::AttachmentCollector const&, KMime::Content*) const () from /usr/lib/libtemplateparser.so.4
#9  0x00007f9696583b18 in TemplateParser::TemplateParser::addProcessedBodyToMessage(QString const&, QString const&) const () from /usr/lib/libtemplateparser.so.4
#10 0x00007f96965844ce in TemplateParser::TemplateParser::processWithTemplate(QString const&) () from /usr/lib/libtemplateparser.so.4
Comment 5 Pavel Punegov 2013-05-06 09:22:26 UTC
It does not crash if I forward as an attachment. Only inline forwarding crashes
Comment 6 kdebugs 2013-07-19 13:28:49 UTC
Created attachment 81197 [details]
New crash information added by DrKonqi

kontact (4.10.5) on KDE Platform 4.10.5 using Qt 4.8.4

- What I was doing when the application crashed:

Forwarding an email with 3 pdfs as text crashes Kontact.

-- Backtrace (Reduced):
#6  0x00007f1567f1e0c4 in KMime::Content::parent (this=0x2d85f40) at ../../kmime/kmime_content.cpp:952
#7  0x00007f1567f20867 in KMime::Content::addContent (this=this@entry=0x2fb3850, c=c@entry=0x2d85f40, prepend=prepend@entry=false) at ../../kmime/kmime_content.cpp:582
#8  0x00007f150abca1d6 in TemplateParser::TemplateParser::createMultipartMixed (this=this@entry=0x7fffa8f71980, ac=..., textPart=textPart@entry=0x265d490) at ../../templateparser/templateparser.cpp:1298
#9  0x00007f150abcea30 in TemplateParser::TemplateParser::addProcessedBodyToMessage (this=this@entry=0x7fffa8f71980, plainBody=..., htmlBody=...) at ../../templateparser/templateparser.cpp:1275
#10 0x00007f150abcef74 in TemplateParser::TemplateParser::processWithTemplate (this=0x7fffa8f71980, tmpl=...) at ../../templateparser/templateparser.cpp:1187
Comment 7 Jekyll Wu 2013-09-04 13:12:32 UTC
*** Bug 324492 has been marked as a duplicate of this bug. ***
Comment 8 Jekyll Wu 2014-01-30 02:47:37 UTC

*** This bug has been marked as a duplicate of bug 312302 ***