Bug 287961 - Crash while face-tagging pictures and doing import
Summary: Crash while face-tagging pictures and doing import
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Faces-Engine (show other bugs)
Version: 2.3.0
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-01 07:31 UTC by Jeremy Fitzhardinge
Modified: 2019-12-23 06:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Fitzhardinge 2011-12-01 07:31:49 UTC
Application: digikam (2.3.0)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.2-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

I was importing pictures from an SD card, while concurrently going through and tagging unknown people in older photos.  I was doing this for a while until the whole app crashed.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f43e18d3a40 (LWP 15619))]

Thread 8 (Thread 0x7f43d3d6a700 (LWP 15620)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x000000321607c02b in wait (time=18446744073709551615, this=0x1e53030) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1e52f28, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005c5d30 in Digikam::ScanController::run (this=0x1e52d30) at /usr/src/debug/digikam-2.3.0/core/digikam/database/scancontroller.cpp:647
#4  0x000000321607bb1b in QThreadPrivate::start (arg=0x1e52d30) at thread/qthread_unix.cpp:298
#5  0x0000003205807d90 in start_thread (arg=0x7f43d3d6a700) at pthread_create.c:309
#6  0x00000032054eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 7 (Thread 0x7f43d3569700 (LWP 15621)):
#0  0x00000032054e6373 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003207444f88 in ?? () from /lib64/libglib-2.0.so.0
#2  0x000000320744544c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00000032161a6896 in QEventDispatcherGlib::processEvents (this=0x7f43c40008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x0000003216176c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x0000003216176ed7 in QEventLoop::exec (this=0x7f43d3568b10, flags=...) at kernel/qeventloop.cpp:204
#6  0x0000003216078ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x0000003216156a5f in QInotifyFileSystemWatcherEngine::run (this=0x1e1f270) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x000000321607bb1b in QThreadPrivate::start (arg=0x1e1f270) at thread/qthread_unix.cpp:298
#9  0x0000003205807d90 in start_thread (arg=0x7f43d3569700) at pthread_create.c:309
#10 0x00000032054eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 6 (Thread 0x7f43d2d68700 (LWP 15623)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x000000321607c02b in wait (time=18446744073709551615, this=0x219ec70) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x219e9d8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000032343416a9 in Digikam::ParkingThread::run (this=0x219e9c0) at /usr/src/debug/digikam-2.3.0/core/libs/threads/threadmanager.cpp:119
#4  0x000000321607bb1b in QThreadPrivate::start (arg=0x219e9c0) at thread/qthread_unix.cpp:298
#5  0x0000003205807d90 in start_thread (arg=0x7f43d2d68700) at pthread_create.c:309
#6  0x00000032054eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7f43a37fe700 (LWP 15671)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x000000321607c02b in wait (time=18446744073709551615, this=0x7f43959c8b90) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f43955eef00, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003216077e44 in QSemaphore::acquire (this=0x7f43a37fcaf0, n=1) at thread/qsemaphore.cpp:144
#4  0x000000321618bcb5 in QMetaObject::activate (sender=0x5893a60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f43a37fcb50) at kernel/qobject.cpp:3524
#5  0x0000000000775ce2 in Digikam::CameraController::signalInternalCheckRename (this=<optimized out>, _t1=<optimized out>, _t2=<optimized out>, _t3=<optimized out>, _t4=<optimized out>) at /usr/src/debug/digikam-2.3.0/x86_64-redhat-linux-gnu/core/utilities/cameragui/cameracontroller.moc:318
#6  0x000000000077b2ff in Digikam::CameraController::executeCommand (this=0x5893a60, cmd=<optimized out>) at /usr/src/debug/digikam-2.3.0/core/utilities/cameragui/controller/cameracontroller.cpp:659
#7  0x000000000077e876 in Digikam::CameraController::run (this=0x5893a60) at /usr/src/debug/digikam-2.3.0/core/utilities/cameragui/controller/cameracontroller.cpp:396
#8  0x000000321607bb1b in QThreadPrivate::start (arg=0x5893a60) at thread/qthread_unix.cpp:298
#9  0x0000003205807d90 in start_thread (arg=0x7f43a37fe700) at pthread_create.c:309
#10 0x00000032054eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f43a2ffd700 (LWP 15672)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x000000321607c02b in wait (time=18446744073709551615, this=0x646cb20) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x6469f08, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x0000000000785f02 in Digikam::CameraHistoryUpdater::run (this=0x5875580) at /usr/src/debug/digikam-2.3.0/core/utilities/cameragui/controller/camerahistoryupdater.cpp:118
#4  0x000000321607bb1b in QThreadPrivate::start (arg=0x5875580) at thread/qthread_unix.cpp:298
#5  0x0000003205807d90 in start_thread (arg=0x7f43a2ffd700) at pthread_create.c:309
#6  0x00000032054eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f43a3fff700 (LWP 16213)):
#0  syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:39
#1  0x000000321607a5eb in _q_futex (val2=0, addr2=0x0, timeout=0x0, val=2, op=0, addr=0x1bc1920) at thread/qmutex_unix.cpp:137
#2  QMutexPrivate::wait (this=0x1bc1920, timeout=<optimized out>) at thread/qmutex_unix.cpp:151
#3  0x00000032160764fd in QMutex::lock (this=<optimized out>) at thread/qmutex.cpp:164
#4  0x00000032342ed8a4 in Digikam::ThumbnailDatabaseAccess::ThumbnailDatabaseAccess (this=<optimized out>) at /usr/src/debug/digikam-2.3.0/core/libs/database/thumbnaildatabaseaccess.cpp:87
#5  0x000000323432494a in Digikam::ThumbnailCreator::storeInDatabase (this=<optimized out>, info=..., image=...) at /usr/src/debug/digikam-2.3.0/core/libs/threadimageio/thumbnailcreator.cpp:736
#6  0x000000323432a169 in Digikam::ThumbnailCreator::load (this=0x2202390, path=..., rect=..., pregenerate=true) at /usr/src/debug/digikam-2.3.0/core/libs/threadimageio/thumbnailcreator.cpp:264
#7  0x000000323432b0ed in Digikam::ThumbnailCreator::pregenerate (this=<optimized out>, path=<optimized out>) at /usr/src/debug/digikam-2.3.0/core/libs/threadimageio/thumbnailcreator.cpp:180
#8  0x0000003234339e10 in Digikam::ThumbnailLoadingTask::execute (this=0x73abf20) at /usr/src/debug/digikam-2.3.0/core/libs/threadimageio/thumbnailtask.cpp:79
#9  0x0000003234309efe in Digikam::LoadSaveThread::run (this=0x21f90e0) at /usr/src/debug/digikam-2.3.0/core/libs/threadimageio/loadsavethread.cpp:118
#10 0x000000323434357e in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x2202620) at /usr/src/debug/digikam-2.3.0/core/libs/threads/dynamicthread.cpp:328
#11 0x000000321606f492 in QThreadPoolThread::run (this=0x3edbdc0) at concurrent/qthreadpool.cpp:107
#12 0x000000321607bb1b in QThreadPrivate::start (arg=0x3edbdc0) at thread/qthread_unix.cpp:298
#13 0x0000003205807d90 in start_thread (arg=0x7f43a3fff700) at pthread_create.c:309
#14 0x00000032054eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f43b9498700 (LWP 16218)):
#0  QVariant::QVariant (this=0x7f43b9497410, val=-1) at kernel/qvariant.cpp:1680
#1  0x00000032342ef53f in Digikam::ThumbnailDB::insertThumbnail (this=0x1e8e5f0, info=<optimized out>, lastInsertId=0x7f43b9497490) at /usr/src/debug/digikam-2.3.0/core/libs/database/thumbnaildb.cpp:270
#2  0x0000003234324a88 in Digikam::ThumbnailCreator::storeInDatabase (this=<optimized out>, info=..., image=<optimized out>) at /usr/src/debug/digikam-2.3.0/core/libs/threadimageio/thumbnailcreator.cpp:753
#3  0x000000323432a169 in Digikam::ThumbnailCreator::load (this=0x2bbf5f0, path=..., rect=..., pregenerate=false) at /usr/src/debug/digikam-2.3.0/core/libs/threadimageio/thumbnailcreator.cpp:264
#4  0x000000323432abc2 in Digikam::ThumbnailCreator::load (this=<optimized out>, path=<optimized out>) at /usr/src/debug/digikam-2.3.0/core/libs/threadimageio/thumbnailcreator.cpp:196
#5  0x0000003234339d87 in Digikam::ThumbnailLoadingTask::execute (this=0x6321e50) at /usr/src/debug/digikam-2.3.0/core/libs/threadimageio/thumbnailtask.cpp:169
#6  0x0000003234309efe in Digikam::LoadSaveThread::run (this=0x2bbf2a0) at /usr/src/debug/digikam-2.3.0/core/libs/threadimageio/loadsavethread.cpp:118
#7  0x000000323434357e in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x2bbf3a0) at /usr/src/debug/digikam-2.3.0/core/libs/threads/dynamicthread.cpp:328
#8  0x000000321606f492 in QThreadPoolThread::run (this=0x4d50f60) at concurrent/qthreadpool.cpp:107
#9  0x000000321607bb1b in QThreadPrivate::start (arg=0x4d50f60) at thread/qthread_unix.cpp:298
#10 0x0000003205807d90 in start_thread (arg=0x7f43b9498700) at pthread_create.c:309
#11 0x00000032054eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f43e18d3a40 (LWP 15619)):
[KCrash Handler]
#6  0x000000000060334f in data (arole=37, this=0x4626fe0) at /usr/include/QtCore/qabstractitemmodel.h:402
#7  Digikam::AssignNameOverlay::checkIndex (this=<optimized out>, index=...) at /usr/src/debug/digikam-2.3.0/core/digikam/items/assignnameoverlay.cpp:241
#8  0x000000323438e65f in checkIndexOnEnter (index=..., this=0x21b5300) at /usr/src/debug/digikam-2.3.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:282
#9  Digikam::AbstractWidgetDelegateOverlay::checkIndexOnEnter (this=0x21b5300, index=...) at /usr/src/debug/digikam-2.3.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:270
#10 0x000000323438e6c7 in Digikam::PersistentWidgetDelegateOverlay::slotEntered (this=0x21b5300, index=...) at /usr/src/debug/digikam-2.3.0/core/libs/widgets/itemview/imagedelegateoverlay.cpp:577
#11 0x000000000060328b in Digikam::AssignNameOverlay::eventFilter (this=0x21b5300, o=<optimized out>, e=<optimized out>) at /usr/src/debug/digikam-2.3.0/core/digikam/items/assignnameoverlay.cpp:351
#12 0x0000003216177cd8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x21e98d0, event=0x7fffe4a30a20) at kernel/qcoreapplication.cpp:986
#13 0x0000003218fc96bf in notify_helper (e=0x7fffe4a30a20, receiver=0x21e98d0, this=0x1bad570) at kernel/qapplication.cpp:4514
#14 QApplicationPrivate::notify_helper (this=0x1bad570, receiver=0x21e98d0, e=0x7fffe4a30a20) at kernel/qapplication.cpp:4490
#15 0x0000003218fce573 in QApplication::notify (this=0x7fffe4a31ec0, receiver=0x21e98d0, e=0x7fffe4a30a20) at kernel/qapplication.cpp:4379
#16 0x0000003217c50396 in KApplication::notify (this=0x7fffe4a31ec0, receiver=0x21e98d0, event=0x7fffe4a30a20) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#17 0x0000003216177b4c in QCoreApplication::notifyInternal (this=0x7fffe4a31ec0, receiver=0x21e98d0, event=0x7fffe4a30a20) at kernel/qcoreapplication.cpp:876
#18 0x0000003218fc818e in sendEvent (event=0x7fffe4a30a20, receiver=0x21e98d0) at ../../src/corelib/kernel/qcoreapplication.h:231
#19 QApplicationPrivate::setFocusWidget (focus=0x21943a0, reason=Qt::MouseFocusReason) at kernel/qapplication.cpp:2247
#20 0x000000321900c5d1 in QWidget::setFocus (this=0x21943a0, reason=Qt::MouseFocusReason) at kernel/qwidget.cpp:6438
#21 0x0000003218fd011b in QApplication::notify (this=0x7fffe4a31ec0, receiver=0x2da28e0, e=0x7fffe4a310b0) at kernel/qapplication.cpp:4018
#22 0x0000003217c50396 in KApplication::notify (this=0x7fffe4a31ec0, receiver=0x2da28e0, event=0x7fffe4a310b0) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#23 0x0000003216177b4c in QCoreApplication::notifyInternal (this=0x7fffe4a31ec0, receiver=0x2da28e0, event=0x7fffe4a310b0) at kernel/qcoreapplication.cpp:876
#24 0x0000003218fca6c2 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:231
#25 QApplicationPrivate::sendMouseEvent (receiver=0x2da28e0, event=0x7fffe4a310b0, alienWidget=0x2da28e0, nativeWidget=0x21943a0, buttonDown=0x2da28e0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3157
#26 0x0000003219046045 in QETWidget::translateMouseEvent (this=0x21943a0, event=<optimized out>) at kernel/qapplication_x11.cpp:4515
#27 0x0000003219044f0a in QApplication::x11ProcessEvent (this=0x7fffe4a31ec0, event=0x7fffe4a31970) at kernel/qapplication_x11.cpp:3641
#28 0x000000321906c74c in x11EventSourceDispatch (s=0x1bb47a0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#29 0x0000003207444a7d in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#30 0x0000003207445278 in ?? () from /lib64/libglib-2.0.so.0
#31 0x000000320744544c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#32 0x00000032161a682f in QEventDispatcherGlib::processEvents (this=0x1baf7e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#33 0x000000321906c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#34 0x0000003216176c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x0000003216176ed7 in QEventLoop::exec (this=0x7fffe4a31d40, flags=...) at kernel/qeventloop.cpp:204
#36 0x000000321617b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#37 0x000000000048b93d in main (argc=5, argv=<optimized out>) at /usr/src/debug/digikam-2.3.0/core/digikam/main/main.cpp:232

This bug may be a duplicate of or related to bug 285517.

Possible duplicates by query: bug 285517, bug 277808.

Reported using DrKonqi
Comment 1 caulier.gilles 2011-12-01 07:58:31 UTC

*** This bug has been marked as a duplicate of bug 285517 ***
Comment 2 caulier.gilles 2019-12-23 06:22:00 UTC
Problem is fixed with new 7.0.0-beta1 through this long story from this bug

https://bugs.kde.org/show_bug.cgi?id=399923

You can test digiKam 7.0.0-beta1 with bundle available here:

https://download.kde.org/unstable/digikam/

Don't hesitate to give us a fresh feedback about his entry.

Thanks in advance

Gilles Caulier