Bug 308486 - More ergonomic way associate windows to activities
Summary: More ergonomic way associate windows to activities
Status: RESOLVED DUPLICATE of bug 283309
Alias: None
Product: kwin
Classification: Unclassified
Component: activities (show other bugs)
Version: 4.8.4
Platform: Debian testing Linux
: NOR wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-16 12:37 UTC by dolgener
Modified: 2012-12-15 16:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dolgener 2012-10-16 12:37:19 UTC
When logout from your KDE desktop, leaving running applications on different activieties, and log on again, session management restores all active windows to that activity which finally had focus. This causes quite a lot of unnecessary work:




Reproducible: Always

Steps to Reproduce:
To move n windows do different actitiy/activities, today you need 6n user actions

For w in windows:
    Right click title bar
    select activities submenu
    select desired target activity.
    Right click title bar
    select activities submenu
    select current activity


Actual Results:  
To move n windows do different actitiy/activities, today you need 6n user actions

Expected Results:  
It should be as straightforward as moving files to trashcan or different folders, 
hence you just need to perform 1/3 (2n instead of 6n) handling actions:

a) a drag&drop approach:
For w in windows:
    1) select Window anywhere by alt-clicking (as if to move it)
    2) drag and drop it to a small activity drop-zone on a (small) plasmoid on the task bar
    
- OR -
b) a shortcut based approach
For w in windows:
    1) focus a window (by any of the common methods: click, alt-tab, ...)
    2) press a shortcut defined to send it onto the desired activity

Also see https://bugs.kde.org/show_bug.cgi?id=308475, where this suggestion originates from.
Comment 1 Thomas Lübking 2012-12-15 15:20:01 UTC
*** Bug 303982 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Lübking 2012-12-15 16:50:26 UTC

*** This bug has been marked as a duplicate of bug 283309 ***