Bug 303982 - Moving windows between Activities takes too many mouse clicks.
Summary: Moving windows between Activities takes too many mouse clicks.
Status: RESOLVED DUPLICATE of bug 283309
Alias: None
Product: kwin
Classification: Unclassified
Component: activities (show other bugs)
Version: 4.8.4
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-24 00:07 UTC by lnxusr
Modified: 2012-12-15 16:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lnxusr 2012-07-24 00:07:41 UTC
It takes, at a minimum, four mouse clicks to move a window to another activity.  Right now, we have to click the window menu icon, hover on 'Activities', click the activity we want the window to be displayed on, then repeat the process to "remove" the window from the current activity by unselecting..

Reproducible: Always




I see two quick fixes for this, 1 - keep the Window Menu open until the mouse leaves the area, or 2 - there could be a "Move Window to Activity" selection in the window menu similar to the "Move Window to Group" for groups.

Something similar to the pager where windows can be dragged between different desktops on the panel would be nice for a longer term solution.

Anything to make it easier to move windows between activities.
Comment 1 Dion Moult 2012-11-02 23:02:43 UTC
Something like a pager would be really nice, but keep in mind the pager was meant to show a list of desktops, not to show a list of applications assigned to activities. Google+'s friend-circle assignment model is probably more relevant solution.
Comment 2 Thomas Lübking 2012-12-15 15:20:01 UTC

*** This bug has been marked as a duplicate of bug 308486 ***
Comment 3 lnxusr 2012-12-15 16:23:17 UTC
(In reply to comment #2)
> 
> 
> *** This bug has been marked as a duplicate of bug 308486 ***

That should be the other way, Thomas, were the two actual duplicates.  I complained of this (not really a bug, more of a feature request/improvement) almost three months prior to bug 308486.  However, the two are not related as far as I can see.  Bug 308486 (which does appear to be a genuine bug) mentions the difficulty of moving a window back to the activity you want it on after logging out and back in.
Comment 4 Thomas Lübking 2012-12-15 16:50:15 UTC
from the other bug with subject "More ergonomic way associate windows to activities"

"Expected Results:  
It should be as straightforward as moving files to trashcan or different folders, 
hence you just need to perform 1/3 (2n instead of 6n) handling actions:"

this is the same bug and there's also bug #283309 which is effectively the same as well, but has quite specific talk to it.

The other bug had a more striking subject and a further link,

I really don't care about dates - this is not a "1st one" game, there are forums in IT online magazines for such and it is also not relevant for what reason one figures it's clumsy to assign windows to activities - it is and a reasonable solution will cover this, and the other two bugs.

In order to not get this unduped again, i'll dupe it on the by far oldest bug.

*** This bug has been marked as a duplicate of bug 283309 ***