Bug 308009 - crash on shutdown
Summary: crash on shutdown
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.8.5
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-07 09:45 UTC by theotyflos
Modified: 2013-08-30 21:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description theotyflos 2012-10-07 09:45:33 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-31-generic-pae i686
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

surfing the web, downloading torrents, shutdown whith browser and ktorrent open

The crash can be reproduced some of the time.

-- Backtrace:
Application: Κέλυφος επιφάνειας εργασίας (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xafe8fa40 (LWP 2024))]

Thread 4 (Thread 0xa82a1b40 (LWP 2025)):
#0  0xb2d03e13 in __pthread_mutex_lock (mutex=0xa7900568) at pthread_mutex_lock.c:113
#1  0xb7688a74 in pthread_mutex_lock (mutex=0xa7900568) at forward.c:182
#2  0xb2c303d0 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2bf0958 in g_main_context_query () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2bf100e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb2bf1201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb64948e7 in QEventDispatcherGlib::processEvents (this=0xa7900480, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb646050d in QEventLoop::processEvents (this=0xa82a1190, flags=...) at kernel/qeventloop.cpp:149
#8  0xb64607a9 in QEventLoop::exec (this=0xa82a1190, flags=...) at kernel/qeventloop.cpp:204
#9  0xb634994c in QThread::exec (this=0xa01fb28) at thread/qthread.cpp:501
#10 0xb643db5d in QInotifyFileSystemWatcherEngine::run (this=0xa01fb28) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb634cde0 in QThreadPrivate::start (arg=0xa01fb28) at thread/qthread_unix.cpp:298
#12 0xb2336a11 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#13 0x5c8b0824 in ?? ()
#14 0xbab80424 in ?? ()
#15 0x65000000 in ?? ()
#16 0x001015ff in ?? ()
#17 0xd3890000 in ?? ()
#18 0xfff0013d in ?? ()
#19 0xc30173ff in ?? ()
#20 0x0fc5a2e8 in ?? ()
#21 0x9fc18100 in ?? ()
#22 0x8b001774 in ?? ()
#23 0xffff0889 in ?? ()
#24 0x29d231ff in ?? ()
#25 0x0d0365c2 in ?? ()
#26 0x00000000 in ?? ()

Thread 3 (Thread 0xa6f04b40 (LWP 2026)):
#0  0xb77d0424 in __kernel_vsyscall ()
#1  0xb766a5fb in read () at ../sysdeps/unix/syscall-template.S:82
#2  0xb233372b in ?? () from /usr/lib/nvidia-current/libGL.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xa5466b40 (LWP 2029)):
#0  0xb77d0424 in __kernel_vsyscall ()
#1  0xb2d0596b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0xb768885c in __pthread_cond_wait (cond=0xb3dc6890, mutex=0xb3dc6878) at forward.c:139
#3  0xb3cc2029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb3cc206f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb2336a11 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#6  0x5c8b0824 in ?? ()
#7  0xbab80424 in ?? ()
#8  0x65000000 in ?? ()
#9  0x001015ff in ?? ()
#10 0xd3890000 in ?? ()
#11 0xfff0013d in ?? ()
#12 0xc30173ff in ?? ()
#13 0x0fc5a2e8 in ?? ()
#14 0x9fc18100 in ?? ()
#15 0x8b001774 in ?? ()
#16 0xffff0889 in ?? ()
#17 0x29d231ff in ?? ()
#18 0x0d0365c2 in ?? ()
#19 0x00000000 in ?? ()

Thread 1 (Thread 0xafe8fa40 (LWP 2024)):
[KCrash Handler]
#7  0xb5b7b03b in QRasterWindowSurface::~QRasterWindowSurface (this=0xa1a9e30, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#8  0xb5b7b0d2 in QRasterWindowSurface::~QRasterWindowSurface (this=0xa1a9e30, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#9  0xb5b96424 in QWidgetBackingStore::~QWidgetBackingStore (this=0xa172750, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#10 0xb599ecec in QWidgetBackingStoreTracker::destroy (this=0xa1726d8) at kernel/qwidget.cpp:217
#11 0xb599ee48 in QWidgetPrivate::deleteExtra (this=0x9f68a68) at kernel/qwidget.cpp:1830
#12 0xb599f05c in QWidgetPrivate::~QWidgetPrivate (this=0x9f68a68, __in_chrg=<optimized out>) at kernel/qwidget.cpp:357
#13 0xb599f372 in QWidgetPrivate::~QWidgetPrivate (this=0x9f68a68, __in_chrg=<optimized out>) at kernel/qwidget.cpp:362
#14 0xb647c4bb in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#15 ~QScopedPointer (this=0x9f3dbbc, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#16 QObject::~QObject (this=0x9f3dbb8, __in_chrg=<optimized out>) at kernel/qobject.cpp:817
#17 0xb59a122d in QWidget::~QWidget (this=0x9f3dbb8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1551
#18 0xb59a1482 in QWidget::~QWidget (this=0x9f3dbb8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1700
#19 0xb5fbd948 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0xb62e40f0, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1923
#20 0xb75bef61 in __run_exit_handlers (status=0, listp=0xb77323e4, run_list_atexit=true) at exit.c:78
#21 0xb75befed in __GI_exit (status=0) at exit.c:100
#22 0xb75a54db in __libc_start_main (main=0x80484f0 <main(int, char**)>, argc=1, ubp_av=0xbff64a04, init=0x80485e0 <__libc_csu_init>, fini=0x8048650 <__libc_csu_fini>, rtld_fini=0xb77e0270 <_dl_fini>, stack_end=0xbff649fc) at libc-start.c:258
#23 0x08048531 in _start ()

This bug may be a duplicate of or related to bug 306998.

Possible duplicates by query: bug 306998, bug 306716, bug 305852, bug 305687, bug 305475.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-10-11 13:16:06 UTC
Looks like a problem with your Qt version, please upgrade. See also http://kubuntu.org/news
Comment 2 Christoph Feck 2012-10-11 14:16:56 UTC
Crashes because of global static QWidget. Do you use oxygen-transparent style?
Comment 3 Dominik Haumann 2013-08-30 21:45:00 UTC

*** This bug has been marked as a duplicate of bug 261539 ***