Bug 306998 - Plasma crashes after problem with Date/Calendar applet
Summary: Plasma crashes after problem with Date/Calendar applet
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.8.5
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-18 19:44 UTC by gregpitta19
Modified: 2012-10-01 01:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gregpitta19 2012-09-18 19:44:18 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-30-generic x86_64
Distribution: KingBuntu OS 12.07 Beta

-- Information about the crash:
- What I was doing when the application crashed:
Calendar gives an error "unknow fetch job" when display events is checked.
Compositing stops and I restart Plasma with:
kbuildsycoca4 && kquitapp plasma-desktop && kstart plasma-desktop
Always gives the same crash.
- Custom settings of the application:
Dislplay events is checked on Date/calendar applet

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa2e91e7780 (LWP 3872))]

Thread 4 (Thread 0x7fa2c2dc7700 (LWP 3922)):
#0  0x00007fa2e8ab6b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa2dcc69036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa2dcc69164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa2e5c89426 in QEventDispatcherGlib::processEvents (this=0x7fa2bc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fa2e5c58c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa2e5c58ed7 in QEventLoop::exec (this=0x7fa2c2dc6dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fa2e5b57fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fa2e5c389ff in QInotifyFileSystemWatcherEngine::run (this=0x29ac8b0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fa2e5b5afcb in QThreadPrivate::start (arg=0x29ac8b0) at thread/qthread_unix.cpp:298
#9  0x00007fa2dd56de9a in start_thread (arg=0x7fa2c2dc7700) at pthread_create.c:308
#10 0x00007fa2e8ac24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa2c219f700 (LWP 3923)):
#0  0x00007fa2e8ab6b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa2dcc69036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa2dcc69164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa2e5c89426 in QEventDispatcherGlib::processEvents (this=0x7fa2b40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fa2e5c58c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa2e5c58ed7 in QEventLoop::exec (this=0x7fa2c219edd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fa2e5b57fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fa2e5c389ff in QInotifyFileSystemWatcherEngine::run (this=0x2b75600) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fa2e5b5afcb in QThreadPrivate::start (arg=0x2b75600) at thread/qthread_unix.cpp:298
#9  0x00007fa2dd56de9a in start_thread (arg=0x7fa2c219f700) at pthread_create.c:308
#10 0x00007fa2e8ac24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa2baef3700 (LWP 3948)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa2e2a3d222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fa2e2a3d259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fa2dd56de9a in start_thread (arg=0x7fa2baef3700) at pthread_create.c:308
#4  0x00007fa2e8ac24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa2e91e7780 (LWP 3872)):
[KCrash Handler]
#6  0x00007fa2e51dc199 in QRasterWindowSurface::~QRasterWindowSurface (this=0x26babe0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007fa2e51dc219 in QRasterWindowSurface::~QRasterWindowSurface (this=0x26babe0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007fa2e51f48de in QWidgetBackingStore::~QWidgetBackingStore (this=0x26bc420, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007fa2e50253d9 in QWidgetBackingStoreTracker::destroy (this=0x26bc370) at kernel/qwidget.cpp:217
#10 0x00007fa2e502552e in QWidgetPrivate::deleteExtra (this=0x26c3180) at kernel/qwidget.cpp:1830
#11 0x00007fa2e502575c in QWidgetPrivate::~QWidgetPrivate (this=0x26c3180, __in_chrg=<optimized out>) at kernel/qwidget.cpp:357
#12 0x00007fa2e5025a69 in QWidgetPrivate::~QWidgetPrivate (this=0x26c3180, __in_chrg=<optimized out>) at kernel/qwidget.cpp:362
#13 0x00007fa2e5c72bd0 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x26b53e8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x26b53e0, __in_chrg=<optimized out>) at kernel/qobject.cpp:817
#16 0x00007fa2e50277dd in QWidget::~QWidget (this=0x26b53e0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1551
#17 0x00007fa2e5027a19 in QWidget::~QWidget (this=0x26b53e0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1700
#18 0x00007fa2e55b1905 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7fa2e5ade038, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1923
#19 0x00007fa2e8a0b921 in __run_exit_handlers (status=0, listp=0x7fa2e8d86688, run_list_atexit=true) at exit.c:78
#20 0x00007fa2e8a0b9a5 in __GI_exit (status=<optimized out>) at exit.c:100
#21 0x00007fa2e89f1774 in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff0a9d80e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0a9d80d8) at libc-start.c:258
#22 0x0000000000400671 in _start ()

Possible duplicates by query: bug 306716, bug 305852, bug 305687, bug 305475, bug 297684.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-10-01 01:00:30 UTC

*** This bug has been marked as a duplicate of bug 261539 ***