Bug 307562 - krusader crash while opening file for editing
Summary: krusader crash while opening file for editing
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: krusader
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Krusader Bugs Distribution List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-29 08:19 UTC by pezdepa
Modified: 2018-05-06 00:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pezdepa 2012-09-29 08:19:44 UTC
Application: krusader (2.0.0 "Mars Pathfinder")
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.3
Operating System: Linux 3.4.6-2.10-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Just pressed F4 to start editing the XML file. Error occurs randomly, quite rarely.

-- Backtrace:
Application: Krusader (krusader), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6f49a2a780 (LWP 1931))]

Thread 3 (Thread 0x7f6f43439700 (LWP 2031)):
#0  0x00007f6f4ea3cd9f in __pthread_mutex_unlock_usercnt (mutex=0x7f6f3c000a60, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  0x00007f6f4ce5b4a1 in g_mutex_unlock (mutex=mutex@entry=0x7f6f3c0009a0) at gthread-posix.c:227
#2  0x00007f6f4ce1f55c in g_main_context_iterate (context=context@entry=0x7f6f3c0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3094
#3  0x00007f6f4ce1f7a4 in g_main_context_iteration (context=0x7f6f3c0009a0, may_block=1) at gmain.c:3207
#4  0x00007f6f51946cf6 in QEventDispatcherGlib::processEvents (this=0x7f6f3c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f6f5191785f in QEventLoop::processEvents (this=this@entry=0x7f6f43438dd0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f6f51917ae8 in QEventLoop::exec (this=0x7f6f43438dd0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f6f51819fc0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f6f518f7fcf in QInotifyFileSystemWatcherEngine::run (this=0x17be090) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f6f5181cf9c in QThreadPrivate::start (arg=0x17be090) at thread/qthread_unix.cpp:338
#10 0x00007f6f4ea39e0e in start_thread (arg=0x7f6f43439700) at pthread_create.c:305
#11 0x00007f6f50c5f2bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f6f2bdf8700 (LWP 13613)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f6f303d2ef7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f6f306e0640 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f6f303d2f29 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f6f4ea39e0e in start_thread (arg=0x7f6f2bdf8700) at pthread_create.c:305
#4  0x00007f6f50c5f2bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f6f49a2a780 (LWP 1931)):
[KCrash Handler]
#6  __memcpy_ssse3 () at ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:495
#7  0x00007f6f3031610b in memcpy (__len=<optimized out>, __src=<optimized out>, __dest=<optimized out>) at /usr/include/bits/string3.h:52
#8  executableCopy (allocator=0x7f6f40050960, this=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/AssemblerBuffer.h:139
#9  executableCopy (allocator=0x7f6f40050960, this=0x7fffc6662180) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1885
#10 executableCopy (allocator=0x7f6f40050960, this=0x7fffc6662180) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1583
#11 LinkBuffer (executablePool=..., masm=0x7fffc6662180, this=0x7fffc66620f0) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/LinkBuffer.h:67
#12 QTJSC::JIT::privateCompileCTIMachineTrampolines (this=0x7fffc6662180, executablePool=0x7f6f4004a9e8, globalData=<optimized out>, ctiStringLengthTrampoline=0x7f6f4004a9f0, ctiVirtualCallLink=0x7f6f4004a9f8, ctiVirtualCall=0x7f6f4004aa00, ctiNativeCallThunk=0x7f6f4004aa08) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITOpcodes.cpp:1817
#13 0x00007f6f3032b83c in QTJSC::JIT::compileCTIMachineTrampolines (globalData=0x7f6f40049800, executablePool=executablePool@entry=0x7f6f4004a9e8, ctiStringLengthTrampoline=ctiStringLengthTrampoline@entry=0x7f6f4004a9f0, ctiVirtualCallLink=ctiVirtualCallLink@entry=0x7f6f4004a9f8, ctiVirtualCall=ctiVirtualCall@entry=0x7f6f4004aa00, ctiNativeCallThunk=ctiNativeCallThunk@entry=0x7f6f4004aa08) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JIT.h:323
#14 0x00007f6f30327cf3 in QTJSC::JITThunks::JITThunks (this=0x7f6f4004a9e8, globalData=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:768
#15 0x00007f6f30374788 in QTJSC::JSGlobalData::JSGlobalData (this=0x7f6f40049800, isShared=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:146
#16 0x00007f6f30374e3c in QTJSC::JSGlobalData::create () at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:205
#17 0x00007f6f30413150 in QScriptEnginePrivate::QScriptEnginePrivate (this=0x2433010) at api/qscriptengine.cpp:979
#18 0x00007f6f30414156 in QScriptEngine::QScriptEngine (this=0x2432ff0) at api/qscriptengine.cpp:1964
#19 0x00007f6f30a3458a in load (this=0x15e7aa0) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:247
#20 KateScript::load (this=0x15e7aa0) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:230
#21 0x00007f6f30a348f9 in KateScript::clearExceptions (this=0x15e7aa0) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:157
#22 0x00007f6f30a35c1c in KateCommandLineScript::actionInfo (this=0x15e7aa0, cmd=...) at /usr/src/debug/kate-4.9.1/part/script/katecommandlinescript.cpp:78
#23 0x00007f6f30a3bba1 in KateScriptActionMenu::repopulate (this=this@entry=0x2412f90) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:118
#24 0x00007f6f30a3c27c in KateScriptActionMenu::KateScriptActionMenu (this=0x2412f90, view=0x216da90, text=...) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:74
#25 0x00007f6f30a9a69a in KateView::setupActions (this=this@entry=0x216da90) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:350
#26 0x00007f6f30a9e5f5 in KateView::KateView (this=0x216da90, doc=0x2185220, parent=<optimized out>) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:240
#27 0x00007f6f30a0a114 in KateDocument::createView (this=0x2185220, parent=0x0) at /usr/src/debug/kate-4.9.1/part/document/katedocument.cpp:335
#28 0x00007f6f30a0a1de in KateDocument::widget (this=0x2185220) at /usr/src/debug/kate-4.9.1/part/document/katedocument.cpp:325
#29 0x00000000004e51ec in ?? ()
#30 0x00000000004e267f in ?? ()
#31 0x00000000004fe9b9 in ?? ()
#32 0x00000000004763ba in ?? ()
#33 0x00007f6f5192f39f in QMetaObject::activate (sender=0x18098b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc6663110) at kernel/qobject.cpp:3556
#34 0x00007f6f51e49542 in QAction::triggered (this=this@entry=0x18098b0, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#35 0x00007f6f51e49730 in QAction::activate (this=0x18098b0, event=event@entry=QAction::Trigger) at kernel/qaction.cpp:1257
#36 0x00007f6f51e49897 in QAction::event (this=<optimized out>, e=<optimized out>) at kernel/qaction.cpp:1183
#37 0x00007f6f543a39e7 in KAction::event (this=<optimized out>, event=0x7fffc66636b0) at /usr/src/debug/kdelibs-4.9.1/kdeui/actions/kaction.cpp:131
#38 0x00007f6f51e4f74c in QApplicationPrivate::notify_helper (this=this@entry=0x1615390, receiver=receiver@entry=0x18098b0, e=e@entry=0x7fffc66636b0) at kernel/qapplication.cpp:4557
#39 0x00007f6f51e53bca in QApplication::notify (this=0x7fffc6664da0, receiver=0x18098b0, e=0x7fffc66636b0) at kernel/qapplication.cpp:4418
#40 0x00007f6f5447d0d6 in KApplication::notify (this=0x7fffc6664da0, receiver=0x18098b0, event=0x7fffc66636b0) at /usr/src/debug/kdelibs-4.9.1/kdeui/kernel/kapplication.cpp:311
#41 0x00007f6f51918b0e in QCoreApplication::notifyInternal (this=0x7fffc6664da0, receiver=0x18098b0, event=0x7fffc66636b0) at kernel/qcoreapplication.cpp:915
#42 0x00007f6f51e803f4 in sendEvent (event=0x7fffc66636b0, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:231
#43 QShortcutMap::dispatchEvent (this=this@entry=0x16154b0, e=e@entry=0x7fffc6663c80) at kernel/qshortcutmap.cpp:884
#44 0x00007f6f51e81a23 in QShortcutMap::tryShortcutEvent (this=0x16154b0, o=<optimized out>, e=0x7fffc6663c80) at kernel/qshortcutmap.cpp:364
#45 0x00007f6f51e558a9 in QApplication::notify (this=0x7fffc6664da0, receiver=0x1cdeb20, e=0x7fffc6663c80) at kernel/qapplication.cpp:3981
#46 0x00007f6f5447d0d6 in KApplication::notify (this=0x7fffc6664da0, receiver=0x1cdeb20, event=0x7fffc6663c80) at /usr/src/debug/kdelibs-4.9.1/kdeui/kernel/kapplication.cpp:311
#47 0x00007f6f51918b0e in QCoreApplication::notifyInternal (this=0x7fffc6664da0, receiver=0x1cdeb20, event=0x7fffc6663c80) at kernel/qcoreapplication.cpp:915
#48 0x00007f6f51eebcba in QKeyMapper::sendKeyEvent (keyWidget=keyWidget@entry=0x1cdeb20, grab=grab@entry=false, type=QEvent::KeyPress, code=16777267, modifiers=..., text=..., autorepeat=autorepeat@entry=false, count=1, nativeScanCode=70, nativeVirtualKey=65473, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1866
#49 0x00007f6f51eec0f1 in QKeyMapperPrivate::translateKeyEvent (this=0x1657990, keyWidget=0x1cdeb20, event=0x7fffc66646a0, grab=false) at kernel/qkeymapper_x11.cpp:1836
#50 0x00007f6f51ec9878 in QApplication::x11ProcessEvent (this=0x7fffc6664da0, event=0x7fffc66646a0) at kernel/qapplication_x11.cpp:3534
#51 0x00007f6f51eefde2 in x11EventSourceDispatch (s=s@entry=0x1617d20, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#52 0x00007f6f4ce1f3b5 in g_main_dispatch (context=0x1616a00) at gmain.c:2539
#53 g_main_context_dispatch (context=context@entry=0x1616a00) at gmain.c:3075
#54 0x00007f6f4ce1f6e8 in g_main_context_iterate (context=context@entry=0x1616a00, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3146
#55 0x00007f6f4ce1f7a4 in g_main_context_iteration (context=0x1616a00, may_block=1) at gmain.c:3207
#56 0x00007f6f51946cd6 in QEventDispatcherGlib::processEvents (this=0x15caad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#57 0x00007f6f51eefa5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#58 0x00007f6f5191785f in QEventLoop::processEvents (this=this@entry=0x7fffc6664a70, flags=...) at kernel/qeventloop.cpp:149
#59 0x00007f6f51917ae8 in QEventLoop::exec (this=0x7fffc6664a70, flags=...) at kernel/qeventloop.cpp:204
#60 0x00007f6f5191c788 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#61 0x0000000000453f7b in ?? ()
#62 0x00007f6f50b9c455 in __libc_start_main (main=0x451c30, argc=3, ubp_av=0x7fffc66650a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc6665098) at libc-start.c:226
#63 0x0000000000455c15 in _start ()

Possible duplicates by query: bug 305718.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-09-29 20:09:11 UTC

*** This bug has been marked as a duplicate of bug 305718 ***