Bug 307478 - crashs when quitting kde
Summary: crashs when quitting kde
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: 0.4
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-27 11:34 UTC by ipomo
Modified: 2012-09-27 12:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ipomo 2012-09-27 11:34:49 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.3
Operating System: Linux 3.1.10-70-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
quitting kde isn't poosible anymore without crashes of running applications

The crash can be reproduced every time.

-- Backtrace:
Application: Der KDE-Sitzungsmanager (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9d35d20760 (LWP 3122))]

Thread 2 (Thread 0x7f9d1d6af700 (LWP 6653)):
#0  0x00007f9d345bfe6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d2928a772 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f9d29583e80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f9d2928a7a9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f9d345bbf05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9d3331c10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9d35d20760 (LWP 3122)):
[KCrash Handler]
#6  0x00007f9d333625a7 in __memcpy_ssse3 () from /lib64/libc.so.6
#7  0x00007f9d291c4179 in executableCopy (allocator=0x7f9d1cdbe960, this=<optimized out>) at /usr/include/bits/string3.h:52
#8  executableCopy (this=0x7fff960e50c0, allocator=0x7f9d1cdbe960) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1885
#9  executableCopy (allocator=0x7f9d1cdbe960, this=0x7fff960e50c0) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1583
#10 LinkBuffer (executablePool=..., masm=0x7fff960e50c0, this=0x7fff960e4fe0) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/LinkBuffer.h:67
#11 QTJSC::JIT::privateCompileCTIMachineTrampolines (this=0x7fff960e50c0, executablePool=0x7f9d1cdb89e8, globalData=<optimized out>, ctiStringLengthTrampoline=0x7f9d1cdb89f0, ctiVirtualCallLink=0x7f9d1cdb89f8, ctiVirtualCall=0x7f9d1cdb8a00, ctiNativeCallThunk=0x7f9d1cdb8a08) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITOpcodes.cpp:1817
#12 0x00007f9d291e3e8c in QTJSC::JIT::compileCTIMachineTrampolines (globalData=0x7f9d1cdb7800, executablePool=0x7f9d1cdb89e8, ctiStringLengthTrampoline=0x7f9d1cdb89f0, ctiVirtualCallLink=0x7f9d1cdb89f8, ctiVirtualCall=0x7f9d1cdb8a00, ctiNativeCallThunk=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JIT.h:323
#13 0x00007f9d291e18ba in QTJSC::JITThunks::JITThunks (this=0x7f9d1cdb89e8, globalData=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:768
#14 0x00007f9d2922f9bd in QTJSC::JSGlobalData::JSGlobalData (this=0x7f9d1cdb7800, isShared=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:146
#15 0x00007f9d2923004c in QTJSC::JSGlobalData::create () at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:205
#16 0x00007f9d292cceb7 in QScriptEnginePrivate::QScriptEnginePrivate (this=0x924770) at api/qscriptengine.cpp:979
#17 0x00007f9d292cddf6 in QScriptEngine::QScriptEngine (this=0x924238) at api/qscriptengine.cpp:1964
#18 0x00007f9d28acdcdc in QDeclarativeScriptEngine::QDeclarativeScriptEngine (this=0x924238, priv=0x924130) at qml/qdeclarativeengine.cpp:388
#19 0x00007f9d28ad317f in QDeclarativeEnginePrivate::QDeclarativeEnginePrivate (this=0x924130, e=0x8f4dc0) at qml/qdeclarativeengine.cpp:355
#20 0x00007f9d28ad3481 in QDeclarativeEngine::QDeclarativeEngine (this=0x8f4dc0, parent=0x0) at qml/qdeclarativeengine.cpp:645
#21 0x00007f9d289ccda6 in QDeclarativeViewPrivate::init (this=<optimized out>) at util/qdeclarativeview.cpp:281
#22 0x00007f9d289ceb73 in QDeclarativeView::QDeclarativeView (this=0x860ba0, parent=0x8f5cb0) at util/qdeclarativeview.cpp:261
#23 0x00007f9d238b39a0 in ?? () from /usr/lib64/libkdeinit4_ksmserver.so
#24 0x00007f9d238b4b17 in ?? () from /usr/lib64/libkdeinit4_ksmserver.so
#25 0x00007f9d238c0866 in ?? () from /usr/lib64/libkdeinit4_ksmserver.so
#26 0x00007f9d3303e012 in _SmsProcessMessage () from /usr/lib64/libSM.so.6
#27 0x00007f9d32e2dd74 in IceProcessMessages () from /usr/lib64/libICE.so.6
#28 0x00007f9d238b043a in ?? () from /usr/lib64/libkdeinit4_ksmserver.so
#29 0x00007f9d238b0695 in ?? () from /usr/lib64/libkdeinit4_ksmserver.so
#30 0x00007f9d34967511 in QMetaObject::activate (sender=0x8ee270, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff960e6730) at kernel/qobject.cpp:3556
#31 0x00007f9d349b4b3e in QSocketNotifier::activated (this=<optimized out>, _t1=61) at .moc/release-shared/moc_qsocketnotifier.cpp:103
#32 0x00007f9d349707fb in QSocketNotifier::event (this=0x8ee270, e=0x7fff960e6da0) at kernel/qsocketnotifier.cpp:317
#33 0x00007f9d33ab90e4 in notify_helper (e=0x7fff960e6da0, receiver=0x8ee270, this=0x6e52e0) at kernel/qapplication.cpp:4557
#34 QApplicationPrivate::notify_helper (this=0x6e52e0, receiver=0x8ee270, e=0x7fff960e6da0) at kernel/qapplication.cpp:4529
#35 0x00007f9d33abdeb3 in QApplication::notify (this=0x6d9f70, receiver=0x8ee270, e=0x7fff960e6da0) at kernel/qapplication.cpp:4418
#36 0x00007f9d3571a246 in KApplication::notify (this=0x6d9f70, receiver=0x8ee270, event=0x7fff960e6da0) at /usr/src/debug/kdelibs-4.9.1/kdeui/kernel/kapplication.cpp:311
#37 0x00007f9d3495362c in QCoreApplication::notifyInternal (this=0x6d9f70, receiver=0x8ee270, event=0x7fff960e6da0) at kernel/qcoreapplication.cpp:915
#38 0x00007f9d34981c57 in sendEvent (event=0x7fff960e6da0, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#39 socketNotifierSourceDispatch (source=0x6e99d0) at kernel/qeventdispatcher_glib.cpp:110
#40 0x00007f9d2feba5dd in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#41 0x00007f9d2febadd8 in ?? () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f9d2febafa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#43 0x00007f9d349825ff in QEventDispatcherGlib::processEvents (this=0x617770, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#44 0x00007f9d33b5c91e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007f9d34952162 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007f9d349523b7 in QEventLoop::exec (this=0x7fff960e6fe0, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007f9d349571d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#48 0x00007f9d238ab90a in kdemain () from /usr/lib64/libkdeinit4_ksmserver.so
#49 0x0000000000408984 in _start ()

Possible duplicates by query: bug 305718.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-09-27 12:19:34 UTC

*** This bug has been marked as a duplicate of bug 305718 ***