Bug 307431 - kdeinit4 crashes at login (after K icon) in openSUSE 12.2 using KDE 4.9.1 (libqt?)
Summary: kdeinit4 crashes at login (after K icon) in openSUSE 12.2 using KDE 4.9.1 (li...
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-26 10:31 UTC by Johan Krüger Haglert
Modified: 2012-09-26 14:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.87 KB, text/plain)
2012-09-26 11:00 UTC, Johan Krüger Haglert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johan Krüger Haglert 2012-09-26 10:31:25 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.3
Operating System: Linux 3.4.6-2.10-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
Hi.

openSUSE 12.2
KDE 4.9.1

KDE from KDE49 repository.
gstreamer and libgst from openSUSE rather than packman respositories.
There's some newer branding and kdebase4 packages from opensuse-12.2-update but those require KDE 4.8.5 to be installed instead so..

Since this backtrace also wanted information for libqt I'll see what version of that I have.


Only thing I've done since the system worked is that themes wasn't transparent everywhere where they should had been so I redownloaded the kdelibs and kdebase packages with "upgrade uncondtionally" still from the kde49 repositories. Beyond that I had got an upgrade with a lot of ktp packages earlier but I've removed all ktp and telepathy packages and that didn't helped.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3db0ef3780 (LWP 11883))]

Thread 3 (Thread 0x7f3d90956700 (LWP 11885)):
#0  0x00007f3daf7b7dab in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f3dab2ad4a1 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f3dab270eb5 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f3dab2715ab in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f3dab2717a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f3dafb74cf6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f3dafb4585f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#7  0x00007f3dafb45ae8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#8  0x00007f3dafa47fc0 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#9  0x00007f3dafb25fcf in ?? () from /usr/lib64/libQtCore.so.4
#10 0x00007f3dafa4af9c in ?? () from /usr/lib64/libQtCore.so.4
#11 0x00007f3da0c16734 in ?? () from /usr/X11R6/lib64/libGL.so.1
#12 0x00007f3daf7b4e0e in start_thread () from /lib64/libpthread.so.0
#13 0x00007f3dae52f2bd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f3d859f1700 (LWP 11912)):
#0  0x00007f3daf7b88f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3da468def7 in ?? () from /usr/lib64/libQtScript.so.4
#2  0x00007f3da468df29 in ?? () from /usr/lib64/libQtScript.so.4
#3  0x00007f3da0c16734 in ?? () from /usr/X11R6/lib64/libGL.so.1
#4  0x00007f3daf7b4e0e in start_thread () from /lib64/libpthread.so.0
#5  0x00007f3dae52f2bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f3db0ef3780 (LWP 11883)):
[KCrash Handler]
#5  0x00007f3dae4d5ce1 in __memcpy_sse2 () from /lib64/libc.so.6
#6  0x00007f3da45d110b in ?? () from /usr/lib64/libQtScript.so.4
#7  0x00007f3da45e683c in ?? () from /usr/lib64/libQtScript.so.4
#8  0x00007f3da45e2cf3 in ?? () from /usr/lib64/libQtScript.so.4
#9  0x00007f3da462f788 in ?? () from /usr/lib64/libQtScript.so.4
#10 0x00007f3da462fe3c in ?? () from /usr/lib64/libQtScript.so.4
#11 0x00007f3da46ce150 in ?? () from /usr/lib64/libQtScript.so.4
#12 0x00007f3da46cf156 in QScriptEngine::QScriptEngine() () from /usr/lib64/libQtScript.so.4
#13 0x00007f3da3ed4dec in ?? () from /usr/lib64/libQtDeclarative.so.4
#14 0x00007f3da3ed9acf in ?? () from /usr/lib64/libQtDeclarative.so.4
#15 0x00007f3da3ed9dd1 in QDeclarativeEngine::QDeclarativeEngine(QObject*) () from /usr/lib64/libQtDeclarative.so.4
#16 0x00007f3da67cdfe4 in Plasma::DeclarativeWidget::DeclarativeWidget(QGraphicsWidget*) () from /usr/lib64/libplasma.so.3
#17 0x00007f3d87aa95df in DeclarativeAppletScript::init (this=0x1555170) at /usr/src/debug/kde-runtime-4.9.1/plasma/scriptengines/javascript/plasmoid/declarativeappletscript.cpp:84
#18 0x00007f3da66fc30f in Plasma::Applet::init() () from /usr/lib64/libplasma.so.3
#19 0x00007f3da6711115 in ?? () from /usr/lib64/libplasma.so.3
#20 0x00007f3da6724c4b in ?? () from /usr/lib64/libplasma.so.3
#21 0x00007f3da67258a4 in Plasma::Corona::loadLayout(QString const&) () from /usr/lib64/libplasma.so.3
#22 0x00007f3da672596c in Plasma::Corona::initializeLayout(QString const&) () from /usr/lib64/libplasma.so.3
#23 0x00007f3d9c42bef3 in PlasmaApp::corona (this=this@entry=0xe508e0, createIfMissing=createIfMissing@entry=true) at /usr/src/debug/kde-workspace-4.9.1/plasma/desktop/shell/plasmaapp.cpp:850
#24 0x00007f3d9c42c23d in PlasmaApp::setupDesktop (this=0xe508e0) at /usr/src/debug/kde-workspace-4.9.1/plasma/desktop/shell/plasmaapp.cpp:312
#25 0x00007f3d9c42d6ea in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kde-workspace-4.9.1/build/plasma/desktop/shell/plasmaapp.moc:125
#26 PlasmaApp::qt_static_metacall (_o=0xe508e0, _c=2232458624, _id=552, _a=0x10) at /usr/src/debug/kde-workspace-4.9.1/build/plasma/desktop/shell/plasmaapp.moc:101
#27 0x00007f3dafb5b4ee in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#28 0x00007f3daecd7854 in QApplication::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#29 0x00007f3daecd574c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#30 0x00007f3daecd9bca in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#31 0x00007f3db08e00d6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#32 0x00007f3dafb46b0e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#33 0x00007f3dafb4a471 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#34 0x00007f3dafb74b43 in ?? () from /usr/lib64/libQtCore.so.4
#35 0x00007f3dab2713b5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#36 0x00007f3dab2716e8 in ?? () from /usr/lib64/libglib-2.0.so.0
#37 0x00007f3dab2717a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#38 0x00007f3dafb74cd6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#39 0x00007f3daed75a5e in ?? () from /usr/lib64/libQtGui.so.4
#40 0x00007f3dafb4585f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#41 0x00007f3dafb45ae8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#42 0x00007f3dafb4a788 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#43 0x00007f3d9c414465 in kdemain (argc=1, argv=0xd22710) at /usr/src/debug/kde-workspace-4.9.1/plasma/desktop/shell/main.cpp:120
#44 0x0000000000408932 in launch (argc=argc@entry=1, _name=_name@entry=0xdd15e8 "/usr/bin/plasma-desktop", args=args@entry=0xdd1600 "", cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0xdd1608 "", reset_env=false, tty=tty@entry=0x0, avoid_loops=false, startup_id_str=startup_id_str@entry=0x40b1c6 "0") at /usr/src/debug/kdelibs-4.9.1/kinit/kinit.cpp:734
#45 0x00000000004097cb in handle_launcher_request (sock=8, who=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at /usr/src/debug/kdelibs-4.9.1/kinit/kinit.cpp:1226
#46 0x0000000000409e10 in handle_requests (waitForPid=waitForPid@entry=0) at /usr/src/debug/kdelibs-4.9.1/kinit/kinit.cpp:1419
#47 0x0000000000405997 in main (argc=4, argv=<optimized out>, envp=0x7fff3ecba320) at /usr/src/debug/kdelibs-4.9.1/kinit/kinit.cpp:1907

Reported using DrKonqi
Comment 1 Johan Krüger Haglert 2012-09-26 11:00:02 UTC
Created attachment 74180 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.9.1 "release 561" using Qt 4.8.3

At the first time looking for additional debugging packages work but now when I try it it just stop at the later part of the progress bar. I installed the libqt ones myself manually but I still lack whatever is needed for kdeinit and libqtscript :/

-- Backtrace (Reduced):
#13 0x00007ff48be5b156 in QScriptEngine::QScriptEngine() () from /usr/lib64/libQtScript.so.4
[...]
#16 0x00007ff48b665dd1 in QDeclarativeEngine::QDeclarativeEngine(QObject*) () from /usr/lib64/libQtDeclarative.so.4
#17 0x00007ff48df59fe4 in Plasma::DeclarativeWidget::DeclarativeWidget (this=0x17f4ab0, parent=<optimized out>) at /usr/src/debug/kdelibs-4.9.1/plasma/widgets/declarativewidget.cpp:196
#18 0x00007ff46f1505df in DeclarativeAppletScript::init (this=0x17e4cc0) at /usr/src/debug/kde-runtime-4.9.1/plasma/scriptengines/javascript/plasmoid/declarativeappletscript.cpp:84
#19 0x00007ff48de8830f in Plasma::Applet::init (this=0x1806210) at /usr/src/debug/kdelibs-4.9.1/plasma/applet.cpp:249
Comment 2 Rex Dieter 2012-09-26 14:59:25 UTC

*** This bug has been marked as a duplicate of bug 305718 ***