Bug 307179 - kdevelop crashses on start
Summary: kdevelop crashses on start
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: kdevelop
Classification: Applications
Component: general (show other bugs)
Version: 4.3.1
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: 4.3.0
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-21 22:02 UTC by Jimmy Berry
Modified: 2012-09-22 09:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jimmy Berry 2012-09-21 22:02:51 UTC
Application: kdevelop (4.3.1)
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.3
Operating System: Linux 3.4.6-2.10-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Starting application

I have sessions and file sets configured so it could be crashing trying to load those. This behavior started after updating. I was able to get kdevelop to start yesterday after crashing once.

The crash can be reproduced every time.

-- Backtrace:
Application: KDevelop (kdevelop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc8939ff780 (LWP 9165))]

Thread 4 (Thread 0x7fc87ba3d700 (LWP 9166)):
#0  0x00007fc8908d1c61 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc891ec6457 in wait (time=1000, this=0x260f1f0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x26114a0, time=1000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fc88e023dcb in KDevelop::DUChainPrivate::CleanupThread::run (this=0x2611480) at /usr/src/debug/kdevplatform-1.3.1/language/duchain/duchain.cpp:282
#4  0x00007fc891ec5f9c in QThreadPrivate::start (arg=0x2611480) at thread/qthread_unix.cpp:338
#5  0x00007fc8908cde0e in start_thread () from /lib64/libpthread.so.0
#6  0x00007fc890bc62bd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fc86c6e9700 (LWP 9167)):
#0  0x00007fc890bbe13f in poll () from /lib64/libc.so.6
#1  0x00007fc88b699684 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fc88b6997a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fc891fefcf6 in QEventDispatcherGlib::processEvents (this=0x7fc8640008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fc891fc085f in QEventLoop::processEvents (this=this@entry=0x7fc86c6e8e00, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc891fc0ae8 in QEventLoop::exec (this=0x7fc86c6e8e00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fc891ec2fc0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fc891ec5f9c in QThreadPrivate::start (arg=0x2f371b0) at thread/qthread_unix.cpp:338
#8  0x00007fc8908cde0e in start_thread () from /lib64/libpthread.so.0
#9  0x00007fc890bc62bd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fc86224e700 (LWP 9170)):
#0  0x00007fc8908d18f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc87c1e4ef7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fc87c4f2640 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fc87c1e4f29 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fc8908cde0e in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc890bc62bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fc8939ff780 (LWP 9165)):
[KCrash Handler]
#5  0x00007fc890b6cce1 in __memcpy_sse2 () from /lib64/libc.so.6
#6  0x00007fc87c12810b in memcpy (__len=<optimized out>, __src=<optimized out>, __dest=<optimized out>) at /usr/include/bits/string3.h:52
#7  executableCopy (allocator=0x7fc86195d960, this=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/AssemblerBuffer.h:139
#8  executableCopy (allocator=0x7fc86195d960, this=0x7fffdc675c60) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1885
#9  executableCopy (allocator=0x7fc86195d960, this=0x7fffdc675c60) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1583
#10 LinkBuffer (executablePool=..., masm=0x7fffdc675c60, this=0x7fffdc675bd0) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/LinkBuffer.h:67
#11 QTJSC::JIT::privateCompileCTIMachineTrampolines (this=0x7fffdc675c60, executablePool=0x7fc8619579e8, globalData=<optimized out>, ctiStringLengthTrampoline=0x7fc8619579f0, ctiVirtualCallLink=0x7fc8619579f8, ctiVirtualCall=0x7fc861957a00, ctiNativeCallThunk=0x7fc861957a08) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITOpcodes.cpp:1817
#12 0x00007fc87c13d83c in QTJSC::JIT::compileCTIMachineTrampolines (globalData=0x7fc861956800, executablePool=executablePool@entry=0x7fc8619579e8, ctiStringLengthTrampoline=ctiStringLengthTrampoline@entry=0x7fc8619579f0, ctiVirtualCallLink=ctiVirtualCallLink@entry=0x7fc8619579f8, ctiVirtualCall=ctiVirtualCall@entry=0x7fc861957a00, ctiNativeCallThunk=ctiNativeCallThunk@entry=0x7fc861957a08) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JIT.h:323
#13 0x00007fc87c139cf3 in QTJSC::JITThunks::JITThunks (this=0x7fc8619579e8, globalData=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:768
#14 0x00007fc87c186788 in QTJSC::JSGlobalData::JSGlobalData (this=0x7fc861956800, isShared=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:146
#15 0x00007fc87c186e3c in QTJSC::JSGlobalData::create () at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:205
#16 0x00007fc87c225150 in QScriptEnginePrivate::QScriptEnginePrivate (this=0x31b4b60) at api/qscriptengine.cpp:979
#17 0x00007fc87c226156 in QScriptEngine::QScriptEngine (this=0x31b4b40) at api/qscriptengine.cpp:1964
#18 0x00007fc87c60758a in load (this=0x16ac280) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:247
#19 KateScript::load (this=0x16ac280) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:230
#20 0x00007fc87c6078f9 in KateScript::clearExceptions (this=0x16ac280) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:157
#21 0x00007fc87c608c1c in KateCommandLineScript::actionInfo (this=0x16ac280, cmd=...) at /usr/src/debug/kate-4.9.1/part/script/katecommandlinescript.cpp:78
#22 0x00007fc87c60eba1 in KateScriptActionMenu::repopulate (this=this@entry=0x318a1f0) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:118
#23 0x00007fc87c60f27c in KateScriptActionMenu::KateScriptActionMenu (this=0x318a1f0, view=0x31564e0, text=...) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:74
#24 0x00007fc87c66d69a in KateView::setupActions (this=this@entry=0x31564e0) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:350
#25 0x00007fc87c6715f5 in KateView::KateView (this=0x31564e0, doc=0x3104cd0, parent=<optimized out>) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:240
#26 0x00007fc87c5dd114 in KateDocument::createView (this=0x3104cd0, parent=0x13ce5b0) at /usr/src/debug/kate-4.9.1/part/document/katedocument.cpp:335
#27 0x00007fc892ebcbe3 in KDevelop::TextDocument::createViewWidget (this=0x2fda8c0, parent=0x13ce5b0) at /usr/src/debug/kdevplatform-1.3.1/shell/textdocument.cpp:380
#28 0x00007fc892ebc9e2 in KDevelop::TextView::createWidget (this=0x30cdeb0, parent=0x13ce5b0) at /usr/src/debug/kdevplatform-1.3.1/shell/textdocument.cpp:630
#29 0x00007fc88dd5e646 in Sublime::View::widget (this=0x30cdeb0, parent=<optimized out>) at /usr/src/debug/kdevplatform-1.3.1/sublime/view.cpp:82
#30 0x00007fc88dd5bc05 in Sublime::MainWindowPrivate::ViewCreator::operator() (this=this@entry=0x7fffdc676a30, index=index@entry=0x14333a0) at /usr/src/debug/kdevplatform-1.3.1/sublime/mainwindow_p.cpp:294
#31 0x00007fc88dd5df95 in Sublime::Area::walkViewsInternal<Sublime::MainWindowPrivate::ViewCreator> (this=0x1432d50, op=..., index=index@entry=0x14333a0) at /usr/src/debug/kdevplatform-1.3.1/sublime/areawalkers.h:32
#32 0x00007fc88dd5c77e in walkViews<Sublime::MainWindowPrivate::ViewCreator> (index=0x14333a0, op=..., this=<optimized out>) at /usr/src/debug/kdevplatform-1.3.1/sublime/areawalkers.h:48
#33 Sublime::MainWindowPrivate::viewAdded (this=0x13de050, index=0x14333a0, view=0x30cdeb0) at /usr/src/debug/kdevplatform-1.3.1/sublime/mainwindow_p.cpp:471
#34 0x00007fc891fd839f in QMetaObject::activate (sender=0x1432d50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffdc676c30) at kernel/qobject.cpp:3556
#35 0x00007fc88dd4913c in Sublime::Area::viewAdded (this=this@entry=0x1432d50, _t1=_t1@entry=0x14333a0, _t2=_t2@entry=0x30cdeb0) at /usr/src/debug/kdevplatform-1.3.1/build/sublime/area.moc:129
#36 0x00007fc88dd4924c in Sublime::Area::addView (this=0x1432d50, view=0x30cdeb0, index=0x14333a0, after=<optimized out>) at /usr/src/debug/kdevplatform-1.3.1/sublime/area.cpp:173
#37 0x00007fc892e89bc7 in KDevelop::WorkingSet::loadToArea (this=this@entry=0x2fdff40, area=area@entry=0x1432d50, areaIndex=areaIndex@entry=0x14333a0, setGroup=<incomplete type>, areaGroup=<incomplete type>, recycle=...) at /usr/src/debug/kdevplatform-1.3.1/shell/workingsets/workingset.cpp:279
#38 0x00007fc892e8a9e2 in KDevelop::WorkingSet::loadToArea (this=0x2fdff40, area=0x1432d50, areaIndex=0x14333a0) at /usr/src/debug/kdevplatform-1.3.1/shell/workingsets/workingset.cpp:200
#39 0x00007fc892e857bd in KDevelop::WorkingSetController::changedWorkingSet (this=0x13cc470, area=0x1432d50, from=..., to=...) at /usr/src/debug/kdevplatform-1.3.1/shell/workingsetcontroller.cpp:302
#40 0x00007fc891fd839f in QMetaObject::activate (sender=0x1432d50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffdc677330) at kernel/qobject.cpp:3556
#41 0x00007fc88dd4958c in Sublime::Area::changedWorkingSet (this=this@entry=0x1432d50, _t1=_t1@entry=0x1432d50, _t2=..., _t3=...) at /usr/src/debug/kdevplatform-1.3.1/build/sublime/area.moc:185
#42 0x00007fc88dd496b1 in Sublime::Area::setWorkingSet (this=this@entry=0x1432d50, name=...) at /usr/src/debug/kdevplatform-1.3.1/sublime/area.cpp:417
#43 0x00007fc88dd4c000 in Sublime::Area::load (this=0x1432d50, group=...) at /usr/src/debug/kdevplatform-1.3.1/sublime/area.cpp:349
#44 0x00007fc892ea7684 in KDevelop::UiController::loadArea (this=this@entry=0x13cc660, area=area@entry=0x1432d50, group=...) at /usr/src/debug/kdevplatform-1.3.1/shell/uicontroller.cpp:427
#45 0x00007fc892ea957e in KDevelop::UiController::loadAllAreas (this=0x13cc660, config=...) at /usr/src/debug/kdevplatform-1.3.1/shell/uicontroller.cpp:519
#46 0x00007fc892ea54a0 in KDevelop::CorePrivate::initialize (this=0x141deb0, mode=mode@entry=KDevelop::Core::Default, session=...) at /usr/src/debug/kdevplatform-1.3.1/shell/core.cpp:239
#47 0x00007fc892ea68a4 in KDevelop::Core::initialize (splash=0x13a58d0, mode=KDevelop::Core::Default, session=...) at /usr/src/debug/kdevplatform-1.3.1/shell/core.cpp:290
#48 0x00000000004089d2 in ?? ()
#49 0x00007fc890b03455 in __libc_start_main () from /lib64/libc.so.6
#50 0x000000000040a2a1 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2012-09-22 09:26:17 UTC

*** This bug has been marked as a duplicate of bug 305718 ***