Bug 306149 - KDE Control module crashes when trying to open window manager settings
Summary: KDE Control module crashes when trying to open window manager settings
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-02 04:01 UTC by barneedhar
Modified: 2012-09-02 07:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description barneedhar 2012-09-02 04:01:45 UTC
Application: kcmshell4 ()
KDE Platform Version: 4.9.00
Qt Version: 4.8.2
Operating System: Linux 3.5.0-11-generic x86_64
Distribution: Ubuntu quantal (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
I clicked on Firefox icon on the title bar to open Window manager settings. Instead of opening the settings menu, KDE control module crashed instead.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Control Module (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f26d3604780 (LWP 10464))]

Thread 2 (Thread 0x7f26c0883700 (LWP 10465)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f26ccdfc967 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f26ccdfc999 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f26d5fd5e9a in start_thread (arg=0x7f26c0883700) at pthread_create.c:308
#4  0x00007f26d85e339d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f26d3604780 (LWP 10464)):
[KCrash Handler]
#6  __memcpy_ssse3_back () at ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:268
#7  0x00007f26ccd3f49b in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#8  0x00007f26ccd54d5f in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#9  0x00007f26ccd51103 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#10 0x00007f26ccd9df08 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#11 0x00007f26ccd9e5bc in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#12 0x00007f26cce3edb0 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#13 0x00007f26cce3fda6 in QScriptEngine::QScriptEngine() () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007f26cc645d0c in QDeclarativeScriptEngine::QDeclarativeScriptEngine (this=0x103cde8, priv=0x103cce0) at qml/qdeclarativeengine.cpp:382
#15 0x00007f26cc64abaf in QDeclarativeEnginePrivate::QDeclarativeEnginePrivate (this=0x103cce0, e=0x103a6e0) at qml/qdeclarativeengine.cpp:353
#16 0x00007f26cc64aec1 in QDeclarativeEngine::QDeclarativeEngine (this=0x103a6e0, parent=0x0) at qml/qdeclarativeengine.cpp:634
#17 0x00007f26cc549766 in QDeclarativeViewPrivate::init (this=this@entry=0x1041030) at util/qdeclarativeview.cpp:281
#18 0x00007f26cc549993 in QDeclarativeView::QDeclarativeView (this=0xe51140, parent=0xe91340) at util/qdeclarativeview.cpp:261
#19 0x00007f26c0b8ec09 in Ui_KWinDecorationForm::setupUi (this=this@entry=0xe91368, KWinDecorationForm=KWinDecorationForm@entry=0xe91340) at ./ui_decoration.h:56
#20 0x00007f26c0b8b288 in KWin::KWinDecorationForm::KWinDecorationForm (this=0xe91340, parent=<optimized out>) at ../../../../kwin/kcmkwin/kwindecoration/kwindecoration.cpp:68
#21 0x00007f26c0b8dbfe in KWin::KWinDecorationModule::KWinDecorationModule (this=0xee4010, parent=<optimized out>) at ../../../../kwin/kcmkwin/kwindecoration/kwindecoration.cpp:82
#22 0x00007f26c0b8f5c4 in KPluginFactory::createInstance<KWin::KWinDecorationModule, QWidget> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/KDE/../kpluginfactory.h:477
#23 0x00007f26d9f2e1c5 in KPluginFactory::create (this=0xeb6c40, iface=0x7f26da8b8c40 <qt_meta_stringdata_KCModule> "KCModule", parentWidget=0x0, parent=0xe88de0, args=..., keyword=...) at ../../kdecore/util/kpluginfactory.cpp:203
#24 0x00007f26cb13388a in create<KCModule> (args=..., keyword=..., parent=0xe88de0, parentWidget=0x0, this=<optimized out>) at ../../kdecore/util/kpluginfactory.h:531
#25 createInstance<KCModule> (error=0x7fffe3d0c0c0, args=..., parent=0xe88de0, parentWidget=0x0, this=0xe01a40) at ../../kdecore/services/kservice.h:559
#26 createInstance<KCModule> (error=0x7fffe3d0c0c0, args=..., parent=0xe88de0, this=0xe01a40) at ../../kdecore/services/kservice.h:536
#27 KCModuleLoader::loadModule (mod=..., report=KCModuleLoader::Inline, parent=0xe88de0, args=...) at ../../kutils/kcmoduleloader.cpp:89
#28 0x00007f26cb138870 in KCModuleProxyPrivate::loadModule (this=this@entry=0xe80570) at ../../kutils/kcmoduleproxy.cpp:106
#29 0x00007f26cb138fc5 in KCModuleProxy::realModule (this=this@entry=0xe88de0) at ../../kutils/kcmoduleproxy.cpp:83
#30 0x00007f26cb1392c9 in KCModuleProxy::useRootOnlyMessage (this=0xe88de0) at ../../kutils/kcmoduleproxy.cpp:315
#31 0x00007f26cb135647 in KCMultiDialog::addModule (this=0xdedb00, moduleInfo=..., parentItem=0x0, args=...) at ../../kutils/kcmultidialog.cpp:390
#32 0x00007f26c64ada61 in kdemain (_argc=13500768, _argv=<optimized out>) at ../../kcmshell/main.cpp:285
#33 0x0000000000408502 in launch (argc=argc@entry=13, _name=_name@entry=0xcb0758 "kcmshell4", args=0xcb0802 "\001", args@entry=0xcb0762 "--icon", cwd=cwd@entry=0x0, envc=envc@entry=1, envs=<optimized out>, envs@entry=0xcb080a "DISPLAY=:0", reset_env=false, tty=tty@entry=0x0, avoid_loops=false, startup_id_str=startup_id_str@entry=0x40b075 "0") at ../../kinit/kinit.cpp:746
#34 0x000000000040961b in handle_launcher_request (sock=8, who=<optimized out>) at ../../kinit/kinit.cpp:1238
#35 0x0000000000409c60 in handle_requests (waitForPid=waitForPid@entry=0) at ../../kinit/kinit.cpp:1431
#36 0x0000000000405387 in main (argc=4, argv=<optimized out>, envp=0x7fffe3d0d720) at ../../kinit/kinit.cpp:1919

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-09-02 07:42:40 UTC

*** This bug has been marked as a duplicate of bug 305718 ***