Bug 306016 - muon crash after click button info app.
Summary: muon crash after click button info app.
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: muon
Classification: Applications
Component: installer (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-30 05:01 UTC by anank three
Modified: 2012-09-04 09:55 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description anank three 2012-08-30 05:01:18 UTC
Application: muon-installer (1.3.1 "Daring Dalek")
KDE Platform Version: 4.9.00
Qt Version: 4.8.2
Operating System: Linux 3.2.0-29-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
i was start muon app centre , if I click button info for detail , muon app was crash

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f01772ea780 (LWP 7390))]

Thread 3 (Thread 0x7f0160d0e700 (LWP 7392)):
#0  0x00007f01738feb03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f016e620036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f016e620164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0174d4e9e6 in QEventDispatcherGlib::processEvents (this=0x7f015c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f0174d1df22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0174d1e177 in QEventLoop::exec (this=0x7f0160d0ddd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f0174c1d057 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f0174cfdc2f in QInotifyFileSystemWatcherEngine::run (this=0x1a51290) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f0174c2007b in QThreadPrivate::start (arg=0x1a51290) at thread/qthread_unix.cpp:307
#9  0x00007f016ecdce9a in start_thread (arg=0x7f0160d0e700) at pthread_create.c:308
#10 0x00007f017390a4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f015971c700 (LWP 7409)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f0170a97022 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f0170a97059 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f016ecdce9a in start_thread (arg=0x7f015971c700) at pthread_create.c:308
#4  0x00007f017390a4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f01772ea780 (LWP 7390)):
[KCrash Handler]
#6  __memcpy_ssse3 () at ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:495
#7  0x00007f01709d0f89 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#8  0x00007f01709f08df in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#9  0x00007f01709ee2ca in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#10 0x00007f0170a3c16d in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#11 0x00007f0170a3c7fc in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#12 0x00007f0170ad9787 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#13 0x00007f0170ada6c6 in QScriptEngine::QScriptEngine() () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007f0175fb4d5c in QDeclarativeScriptEngine::QDeclarativeScriptEngine (this=0x35b7e58, priv=0x35b7d50) at qml/qdeclarativeengine.cpp:382
#15 0x00007f0175fba40f in QDeclarativeEnginePrivate::QDeclarativeEnginePrivate (this=0x35b7d50, e=0x35b5aa0) at qml/qdeclarativeengine.cpp:353
#16 0x00007f0175fba721 in QDeclarativeEngine::QDeclarativeEngine (this=0x35b5aa0, parent=0x0) at qml/qdeclarativeengine.cpp:634
#17 0x00007f0175eb35d6 in QDeclarativeViewPrivate::init (this=<optimized out>) at util/qdeclarativeview.cpp:281
#18 0x00007f0175eb3813 in QDeclarativeView::QDeclarativeView (this=0x35a1560, parent=0x357c360) at util/qdeclarativeview.cpp:261
#19 0x0000000000430e27 in ApplicationDetailsWidget::ApplicationDetailsWidget (this=0x357c360, parent=<optimized out>, backend=<optimized out>) at /build/buildd/muon-1.3.1/installer/ApplicationDetailsView/ApplicationDetailsWidget.cpp:203
#20 0x000000000043445d in ApplicationDetailsView::ApplicationDetailsView (this=0x34af920, parent=<optimized out>, backend=0x1a50450) at /build/buildd/muon-1.3.1/installer/ApplicationDetailsView/ApplicationDetailsView.cpp:37
#21 0x000000000042f580 in ApplicationViewWidget::infoButtonClicked (this=0x3272860, app=0x2bcc110) at /build/buildd/muon-1.3.1/installer/ApplicationModel/ApplicationViewWidget.cpp:152
#22 0x00007f0174d33841 in QMetaObject::activate (sender=0x3288990, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff322db7f0) at kernel/qobject.cpp:3547
#23 0x000000000042dec0 in ApplicationDelegate::infoButtonClicked (this=<optimized out>, _t1=0x2bcc110) at /build/buildd/muon-1.3.1/obj-x86_64-linux-gnu/installer/ApplicationDelegate.moc:125
#24 0x000000000042e034 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /build/buildd/muon-1.3.1/obj-x86_64-linux-gnu/installer/ApplicationDelegate.moc:64
#25 ApplicationDelegate::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /build/buildd/muon-1.3.1/obj-x86_64-linux-gnu/installer/ApplicationDelegate.moc:57
#26 0x00007f0174d33841 in QMetaObject::activate (sender=0x3492190, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff322db970) at kernel/qobject.cpp:3547
#27 0x000000000042e9ed in ApplicationExtender::infoButtonClicked (this=<optimized out>, _t1=0x2bcc110) at /build/buildd/muon-1.3.1/obj-x86_64-linux-gnu/installer/ApplicationExtender.moc:129
#28 0x00007f0174d33841 in QMetaObject::activate (sender=0x3482bb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff322dbac0) at kernel/qobject.cpp:3547
#29 0x00007f01747310c2 in QAbstractButton::clicked (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:220
#30 0x00007f017446ecae in QAbstractButtonPrivate::emitClicked (this=<optimized out>) at widgets/qabstractbutton.cpp:548
#31 0x00007f017446ffeb in QAbstractButtonPrivate::click (this=0x34a04e0) at widgets/qabstractbutton.cpp:541
#32 0x00007f017447025c in QAbstractButton::mouseReleaseEvent (this=0x3482bb0, e=0x7fff322dc390) at widgets/qabstractbutton.cpp:1123
#33 0x00007f01740f0fb4 in QWidget::event (this=0x3482bb0, event=0x7fff322dc390) at kernel/qwidget.cpp:8371
#34 0x00007f01740a07b4 in notify_helper (e=0x7fff322dc390, receiver=0x3482bb0, this=0x1860020) at kernel/qapplication.cpp:4556
#35 QApplicationPrivate::notify_helper (this=0x1860020, receiver=0x3482bb0, e=0x7fff322dc390) at kernel/qapplication.cpp:4528
#36 0x00007f01740a5f2f in QApplication::notify (this=<optimized out>, receiver=0x3482bb0, e=0x7fff322dc390) at kernel/qapplication.cpp:4099
#37 0x00007f0175785456 in KApplication::notify (this=0x7fff322dd070, receiver=0x3482bb0, event=0x7fff322dc390) at ../../kdeui/kernel/kapplication.cpp:311
#38 0x00007f0174d1f3ec in QCoreApplication::notifyInternal (this=0x7fff322dd070, receiver=0x3482bb0, event=0x7fff322dc390) at kernel/qcoreapplication.cpp:915
#39 0x00007f01740a1782 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#40 QApplicationPrivate::sendMouseEvent (receiver=0x3482bb0, event=0x7fff322dc390, alienWidget=0x3482bb0, nativeWidget=0x19bd850, buttonDown=0x3482bb0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3167
#41 0x00007f0174120b15 in QETWidget::translateMouseEvent (this=0x19bd850, event=<optimized out>) at kernel/qapplication_x11.cpp:4617
#42 0x00007f017411face in QApplication::x11ProcessEvent (this=0x7fff322dd070, event=0x7fff322dcc60) at kernel/qapplication_x11.cpp:3732
#43 0x00007f0174149052 in x11EventSourceDispatch (s=0x1862920, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#44 0x00007f016e61fd53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f016e6200a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007f016e620164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#47 0x00007f0174d4e97f in QEventDispatcherGlib::processEvents (this=0x1834080, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#48 0x00007f0174148cde in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00007f0174d1df22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#50 0x00007f0174d1e177 in QEventLoop::exec (this=0x7fff322dd000, flags=...) at kernel/qeventloop.cpp:204
#51 0x00007f0174d234c7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#52 0x000000000041dc97 in main (argc=5, argv=0x7fff322dd2e8) at /build/buildd/muon-1.3.1/installer/main.cpp:61

Reported using DrKonqi
Comment 1 Christoph Feck 2012-09-04 09:55:11 UTC

*** This bug has been marked as a duplicate of bug 305718 ***