Bug 305969 - search folder is allways said to contain #results unread mails
Summary: search folder is allways said to contain #results unread mails
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: folders (show other bugs)
Version: 4.9.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-29 07:32 UTC by Anders Lund
Modified: 2012-12-21 16:18 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Lund 2012-08-29 07:32:00 UTC
After doing a search, the search folder is set to contain unread mails, even though it does not (nessecarily). The messages in there can not be set to read, since they already are, and folder->mark all messages as read have no effect. When navigating using the "+" shortcut to go to next unread message, the search folder is then always visited, even though there are no unread messages in it.

There is a possible relation with bug 302546.

Reproducible: Always

Steps to Reproduce:
1. do a search
Actual Results:  
search folder wrongly appears to have #results unread messages

Expected Results:  
search folder should have a true number of read messages
Comment 1 Daniel Vrátil 2012-12-21 16:18:32 UTC
Git commit 16951119eb0914c4869fdc8bb4b2339bea4241ab by Dan Vrátil.
Committed on 21/12/2012 at 17:14.
Pushed by dvratil into branch 'master'.

Correctly count items flags in virtual collections

REVIEW: 107715
Related: bug 274936

M  +7    -1    server/src/handlerhelper.cpp

http://commits.kde.org/akonadi/16951119eb0914c4869fdc8bb4b2339bea4241ab