Bug 305923 - Rekonq crashes upon startup
Summary: Rekonq crashes upon startup
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: 1.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-28 10:09 UTC by Lê Hoàng Phương
Modified: 2012-09-04 09:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lê Hoàng Phương 2012-08-28 10:09:46 UTC
Application: rekonq (1.0)
KDE Platform Version: 4.9.00
Qt Version: 4.8.2
Operating System: Linux 3.5.0-11-generic x86_64
Distribution: Ubuntu quantal (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

It just crashes when I open it. This problem recently occurs in kubuntu 12.10

The crash can be reproduced every time.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa221903780 (LWP 16919))]

Thread 5 (Thread 0x7fa20bfed700 (LWP 16920)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa22018db2d in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7fa220b4e280 <WTF::pageheap_memory>) at wtf/FastMalloc.cpp:2499
#2  0x00007fa22018dc39 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1622
#3  0x00007fa21b863e9a in start_thread (arg=0x7fa20bfed700) at pthread_create.c:308
#4  0x00007fa22110739d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fa209eec700 (LWP 16921)):
#0  0x00007fa2210f9f9d in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fa219f369bf in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa219efac14 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa219efb022 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa219efb1a4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa21d145076 in QEventDispatcherGlib::processEvents (this=0x7fa2000008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fa21d11567f in QEventLoop::processEvents (this=this@entry=0x7fa209eebe20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fa21d115908 in QEventLoop::exec (this=0x7fa209eebe20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fa21d018a50 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fa21d01b9eb in QThreadPrivate::start (arg=0x1424590) at thread/qthread_unix.cpp:307
#10 0x00007fa21b863e9a in start_thread (arg=0x7fa209eec700) at pthread_create.c:308
#11 0x00007fa22110739d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa207227700 (LWP 16922)):
#0  0x00007fa2210fb9e3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa219efb084 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa219efb1a4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa21d145076 in QEventDispatcherGlib::processEvents (this=0x7fa1f80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fa21d11567f in QEventLoop::processEvents (this=this@entry=0x7fa207226e20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa21d115908 in QEventLoop::exec (this=0x7fa207226e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fa21d018a50 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fa21d01b9eb in QThreadPrivate::start (arg=0x151f2a0) at thread/qthread_unix.cpp:307
#8  0x00007fa21b863e9a in start_thread (arg=0x7fa207227700) at pthread_create.c:308
#9  0x00007fa22110739d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa1f3fff700 (LWP 16924)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa220cf8967 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fa220cf8999 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fa21b863e9a in start_thread (arg=0x7fa1f3fff700) at pthread_create.c:308
#4  0x00007fa22110739d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa221903780 (LWP 16919)):
[KCrash Handler]
#6  __memcpy_ssse3_back () at ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:268
#7  0x00007fa220c3b49b in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#8  0x00007fa220c50d5f in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#9  0x00007fa220c4d103 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#10 0x00007fa220c99f08 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#11 0x00007fa220c9a5bc in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#12 0x00007fa220d3adb0 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#13 0x00007fa220d3bda6 in QScriptEngine::QScriptEngine() () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007fa2214cd388 in OpenSearchManager::loadEngines (this=0x15a7190) at /build/buildd/rekonq-1.0/src/opensearch/opensearchmanager.cpp:257
#15 0x00007fa22143c467 in Application::opensearchManager (this=0x7fff99a72f30) at /build/buildd/rekonq-1.0/src/application.cpp:412
#16 0x00007fa2214b183c in UrlBar::UrlBar (this=0x1599d90, parent=0x1599b20) at /build/buildd/rekonq-1.0/src/urlbar/urlbar.cpp:148
#17 0x00007fa2214850a0 in WebTab::WebTab (this=0x1599b20, parent=<optimized out>) at /build/buildd/rekonq-1.0/src/webtab.cpp:67
#18 0x00007fa2214497fa in MainView::newWebTab (this=0x11f1cf0, focused=<optimized out>) at /build/buildd/rekonq-1.0/src/mainview.cpp:311
#19 0x00007fa221469ec1 in loadViewTabs (mv=mv@entry=0x11f1cf0, window=..., checkViewExists=checkViewExists@entry=false) at /build/buildd/rekonq-1.0/src/sessionmanager.cpp:85
#20 0x00007fa22146a0a2 in SessionManager::restoreSessionFromScratch (this=<optimized out>) at /build/buildd/rekonq-1.0/src/sessionmanager.cpp:189
#21 0x00007fa2214405dc in Application::newInstance (this=0x7fff99a72f30) at /build/buildd/rekonq-1.0/src/application.cpp:285
#22 0x00007fa21ea01da2 in KUniqueApplicationAdaptor::newInstance (this=0x12379a0, asn_id=..., args=...) at ../../kdeui/kernel/kuniqueapplication.cpp:442
#23 0x00007fa21ea01e24 in qt_static_metacall (_a=0x7fff99a721c0, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./kuniqueapplication_p.moc:58
#24 KUniqueApplicationAdaptor::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fff99a721c0) at ./kuniqueapplication_p.moc:52
#25 0x00007fa21ea01f5b in KUniqueApplicationAdaptor::qt_metacall (this=0x12379a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff99a721c0) at ./kuniqueapplication_p.moc:102
#26 0x00007fa21cd47eb3 in QDBusConnectionPrivate::deliverCall (this=this@entry=0x103aff0, object=object@entry=0x12379a0, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:947
#27 0x00007fa21cd48ee6 in QDBusConnectionPrivate::activateCall (this=this@entry=0x103aff0, object=0x12379a0, flags=flags@entry=337, msg=...) at qdbusintegrator.cpp:850
#28 0x00007fa21cd4992f in QDBusConnectionPrivate::activateObject (this=0x103aff0, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#29 0x00007fa21cd49a0b in QDBusActivateObjectEvent::placeMetaCall (this=0x12981b0) at qdbusintegrator.cpp:1537
#30 0x00007fa21d12b7fe in QObject::event (this=0x7fff99a72f30, e=<optimized out>) at kernel/qobject.cpp:1195
#31 0x00007fa21c246e94 in QApplication::event (this=0x7fff99a72f30, e=0x12981b0) at kernel/qapplication.cpp:2538
#32 0x00007fa21c244d9c in QApplicationPrivate::notify_helper (this=this@entry=0x1064230, receiver=receiver@entry=0x7fff99a72f30, e=e@entry=0x12981b0) at kernel/qapplication.cpp:4556
#33 0x00007fa21c24920a in QApplication::notify (this=0x7fff99a72f30, receiver=0x7fff99a72f30, e=0x12981b0) at kernel/qapplication.cpp:4417
#34 0x00007fa21e9fbaf6 in KApplication::notify (this=0x7fff99a72f30, receiver=0x7fff99a72f30, event=0x12981b0) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007fa21d11692e in QCoreApplication::notifyInternal (this=0x7fff99a72f30, receiver=receiver@entry=0x7fff99a72f30, event=event@entry=0x12981b0) at kernel/qcoreapplication.cpp:915
#36 0x00007fa21d11a7b1 in sendEvent (event=0x12981b0, receiver=0x7fff99a72f30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#37 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x101a1f0) at kernel/qcoreapplication.cpp:1539
#38 0x00007fa21d144ec3 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=0x1066970) at kernel/qeventdispatcher_glib.cpp:279
#40 0x00007fa219efadb5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007fa219efb0e8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007fa219efb1a4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007fa21d145056 in QEventDispatcherGlib::processEvents (this=0x101bad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0x00007fa21c2e997e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007fa21d11567f in QEventLoop::processEvents (this=this@entry=0x7fff99a72df0, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007fa21d115908 in QEventLoop::exec (this=0x7fff99a72df0, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007fa21d11aac8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#48 0x00007fa2214e3aa1 in kdemain (argc=1, argv=0x7fff99a73108) at /build/buildd/rekonq-1.0/src/main.cpp:219
#49 0x00007fa22103676d in __libc_start_main (main=0x400690 <main(int, char**)>, argc=1, ubp_av=0x7fff99a73108, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff99a730f8) at libc-start.c:226
#50 0x00000000004006c1 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2012-09-04 09:54:31 UTC

*** This bug has been marked as a duplicate of bug 305718 ***