Bug 305913 - Kate crashes upon startup
Summary: Kate crashes upon startup
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash with 41 votes (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-28 08:15 UTC by Lê Hoàng Phương
Modified: 2012-09-04 09:54 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.01 KB, text/plain)
2012-08-28 14:49 UTC, Loïc Grobol
Details
New crash information added by DrKonqi (5.07 KB, text/plain)
2012-08-28 17:00 UTC, fa
Details
New crash information added by DrKonqi (5.11 KB, text/plain)
2012-08-31 10:22 UTC, Craig
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lê Hoàng Phương 2012-08-28 08:15:12 UTC
Application: kate (3.9.0)
KDE Platform Version: 4.9.00
Qt Version: 4.8.2
Operating System: Linux 3.5.0-11-generic x86_64
Distribution: Ubuntu quantal (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
Doing nothing. Just open it and then it crashes. This is from Kubuntu 12.10.

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0e3c597780 (LWP 10465))]

Thread 2 (Thread 0x7f0e2911a700 (LWP 10466)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f0e29d2e967 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f0e29d2e999 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f0e394dbe9a in start_thread (arg=0x7f0e2911a700) at pthread_create.c:308
#4  0x00007f0e3be9339d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0e3c597780 (LWP 10465)):
[KCrash Handler]
#6  __memcpy_ssse3_back () at ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:268
#7  0x00007f0e29c7149b in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#8  0x00007f0e29c86d5f in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#9  0x00007f0e29c83103 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#10 0x00007f0e29ccff08 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#11 0x00007f0e29cd05bc in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#12 0x00007f0e29d70db0 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#13 0x00007f0e29d71da6 in QScriptEngine::QScriptEngine() () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007f0e2a38735a in load (this=0x1253c20) at ../../part/script/katescript.cpp:247
#15 KateScript::load (this=0x1253c20) at ../../part/script/katescript.cpp:230
#16 0x00007f0e2a3876c9 in KateScript::clearExceptions (this=0x1253c20) at ../../part/script/katescript.cpp:157
#17 0x00007f0e2a3889ec in KateCommandLineScript::actionInfo (this=0x1253c20, cmd=...) at ../../part/script/katecommandlinescript.cpp:78
#18 0x00007f0e2a38e961 in KateScriptActionMenu::repopulate (this=this@entry=0x1556cc0) at ../../part/script/katescriptaction.cpp:118
#19 0x00007f0e2a38f03c in KateScriptActionMenu::KateScriptActionMenu (this=0x1556cc0, view=0x1510870, text=...) at ../../part/script/katescriptaction.cpp:74
#20 0x00007f0e2a3ed47a in KateView::setupActions (this=this@entry=0x1510870) at ../../part/view/kateview.cpp:350
#21 0x00007f0e2a3f13d5 in KateView::KateView (this=0x1510870, doc=0x126ffe0, parent=<optimized out>) at ../../part/view/kateview.cpp:240
#22 0x00007f0e2a35ceb4 in KateDocument::createView (this=0x126ffe0, parent=0x12dd6f0) at ../../part/document/katedocument.cpp:335
#23 0x00007f0e3a9ffafa in createView (doc=<optimized out>, this=0x12d4b50) at ../../../kate/app/kateviewmanager.cpp:391
#24 KateViewManager::createView (this=0x12d4b50, doc=<optimized out>) at ../../../kate/app/kateviewmanager.cpp:382
#25 0x00007f0e3aa041fa in KateViewSpace::restoreConfig (this=0x1328990, viewMan=0x12d4b50, config=0xf4eca0, groupname=...) at ../../../kate/app/kateviewspace.cpp:266
#26 0x00007f0e3aa0209c in KateViewManager::restoreSplitter (this=this@entry=0x12d4b50, configBase=0xf4eca0, group=..., parent=parent@entry=0x12d4b50, viewConfGrp=...) at ../../../kate/app/kateviewmanager.cpp:939
#27 0x00007f0e3aa0292d in KateViewManager::restoreViewConfiguration (this=0x12d4b50, config=...) at ../../../kate/app/kateviewmanager.cpp:820
#28 0x00007f0e3a9f745e in KateMainWindow::KateMainWindow (this=0x12bcf80, sconfig=0xf4eca0, sgroup=..., __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../kate/app/katemainwindow.cpp:195
#29 0x00007f0e3a9e8ca4 in KateApp::newMainWindow (this=<optimized out>, sconfig_=<optimized out>, sgroup_=...) at ../../../kate/app/kateapp.cpp:390
#30 0x00007f0e3aa0cbe3 in KateSessionManager::activateSession (this=0x12a6e70, session=..., closeLast=<optimized out>, saveLast=<optimized out>, loadNew=<optimized out>) at ../../../kate/app/katesession.cpp:338
#31 0x00007f0e3a9ea168 in KateApp::startupKate (this=0x7fffa1b8c520) at ../../../kate/app/kateapp.cpp:194
#32 0x00007f0e3a9ea995 in KateApp::initKate (this=this@entry=0x7fffa1b8c520) at ../../../kate/app/kateapp.cpp:135
#33 0x00007f0e3a9eabb2 in KateApp::KateApp (this=0x7fffa1b8c520, args=<optimized out>) at ../../../kate/app/kateapp.cpp:72
#34 0x00007f0e3c1895e8 in kdemain (argc=<optimized out>, argv=0x7fffa1b8c600) at ../../../kate/app/katemain.cpp:373
#35 0x00007f0e3bdc276d in __libc_start_main (main=0x400690 <main(int, char**)>, argc=3, ubp_av=0x7fffa1b8c6a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffa1b8c698) at libc-start.c:226
#36 0x00000000004006c1 in _start ()

Reported using DrKonqi
Comment 1 Loïc Grobol 2012-08-28 14:49:13 UTC
Created attachment 73526 [details]
New crash information added by DrKonqi

kate (3.9.0) on KDE Platform 4.9.00 using Qt 4.8.2

- What I was doing when the application crashed: Starting Kate. I had already started it several times today, and after doing nothing particular it refused to start several times, and now it works, with no obvious reason.

-- Backtrace (Reduced):
#6  __memcpy_ssse3 () at ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:495
[...]
#13 0x00007f07a66b06c6 in QScriptEngine::QScriptEngine() () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007f07a6ccf083 in load (this=0x22efa60) at ../../part/script/katescript.cpp:247
#15 KateScript::load (this=0x22efa60) at ../../part/script/katescript.cpp:230
#16 0x00007f07a6ccf429 in KateScript::clearExceptions (this=0x22efa60) at ../../part/script/katescript.cpp:157
Comment 2 fa 2012-08-28 17:00:56 UTC
Created attachment 73528 [details]
New crash information added by DrKonqi

kate (3.9.0) on KDE Platform 4.9.00 using Qt 4.8.2

- What I was doing when the application crashed:
Nothing ! 
- Unusual behavior I noticed:
Rekonq and Amarok will do the same... But never at the beggining of the session

-- Backtrace (Reduced):
#6  __memcpy_ssse3 () at ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:495
[...]
#13 0x00007f4620a7fda6 in QScriptEngine::QScriptEngine() () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007f462109535a in load (this=0x25b1b80) at ../../part/script/katescript.cpp:247
#15 KateScript::load (this=0x25b1b80) at ../../part/script/katescript.cpp:230
#16 0x00007f46210956c9 in KateScript::clearExceptions (this=0x25b1b80) at ../../part/script/katescript.cpp:157
Comment 3 Thomas Lübking 2012-08-29 23:22:00 UTC
KWin bug #305718 has better backtraces
Comment 4 Craig 2012-08-31 10:22:57 UTC
Created attachment 73572 [details]
New crash information added by DrKonqi

kate (3.9.0) on KDE Platform 4.9.00 using Qt 4.8.2

- What I was doing when the application crashed:
Editing a document through fish, suddenly crashed and unable to restart.  Have to log out of system , then kwin and numerous other processes crash on the logout process. 
Logging in fixes it for a short time untill it happens again.

-- Backtrace (Reduced):
#6  __memcpy_ssse3_back () at ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:268
[...]
#13 0x00007fd43c4a66c6 in QScriptEngine::QScriptEngine() () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007fd43cac5083 in load (this=0xd624d0) at ../../part/script/katescript.cpp:247
#15 KateScript::load (this=0xd624d0) at ../../part/script/katescript.cpp:230
#16 0x00007fd43cac5429 in KateScript::clearExceptions (this=0xd624d0) at ../../part/script/katescript.cpp:157
Comment 5 Becheru Petru-Ioan 2012-08-31 19:46:51 UTC
I confirm the bug with QT 4.8.2 and KDE 4.9!

WORKAROUND: downgrade QT to 4.8.1 !
With QT 4.8.1, the bug doesn't show up, so it must be a QT (script) issue; see bug 305718
Comment 6 Christoph Feck 2012-09-04 09:54:01 UTC

*** This bug has been marked as a duplicate of bug 305718 ***