Bug 305194 - When there is only one page, "Opposite pages" should have no effect
Summary: When there is only one page, "Opposite pages" should have no effect
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords: junior-jobs
: 307481 307819 309491 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-15 12:01 UTC by Kai Uwe Broulik
Modified: 2012-11-11 15:47 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.0


Attachments
Okular opposite wrong display (57.07 KB, image/png)
2012-08-15 12:01 UTC, Kai Uwe Broulik
Details
Patch (1.19 KB, patch)
2012-08-28 22:33 UTC, Sandro Mani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2012-08-15 12:01:03 UTC
I usually do "Opposite pages" view (not the one with "Opposite pages, first page centered"). When there is only one page in the document, this page should be full-screen regardless of the setting.

Reproducible: Always

Steps to Reproduce:
1. Open PDF that has only one page
2. Do View → View Mode → Opposite pages
3.
Actual Results:  
The page is aligned to the left border of the screen

Expected Results:  
The page is centered nontheless.
Comment 1 Kai Uwe Broulik 2012-08-15 12:01:40 UTC
Created attachment 73179 [details]
Okular opposite wrong display
Comment 2 Albert Astals Cid 2012-08-15 13:26:43 UTC
Makes sense
Comment 3 Sandro Mani 2012-08-28 22:33:53 UTC
Created attachment 73535 [details]
Patch

Patch: behave as FacingFirstCentered when there is only one page.
Comment 4 Albert Astals Cid 2012-08-29 23:03:54 UTC
Git commit 7d18d176bc60855dec4f38262fa32d9aa31146c4 by Albert Astals Cid, on behalf of Sandro Mani.
Committed on 30/08/2012 at 01:03.
Pushed by aacid into branch 'master'.

When there is only one page, "Opposite pages" should have no effect

FIXED-IN: 4.10.0

M  +3    -2    ui/pageview.cpp

http://commits.kde.org/okular/7d18d176bc60855dec4f38262fa32d9aa31146c4
Comment 5 Emmanuel C 2012-09-27 19:45:46 UTC
*** Bug 307481 has been marked as a duplicate of this bug. ***
Comment 6 Albert Astals Cid 2012-10-04 18:33:35 UTC
*** Bug 307819 has been marked as a duplicate of this bug. ***
Comment 7 Albert Astals Cid 2012-11-11 15:47:44 UTC
*** Bug 309491 has been marked as a duplicate of this bug. ***