Bug 305161 - logout confirmation window ignores DPI
Summary: logout confirmation window ignores DPI
Status: RESOLVED DUPLICATE of bug 216853
Alias: None
Product: ksmserver
Classification: Unclassified
Component: ui (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-14 19:55 UTC by Felix Miata
Modified: 2012-08-20 15:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:
jospoortvliet: Usability+


Attachments
screenshot (43.69 KB, image/png)
2012-08-14 19:55 UTC, Felix Miata
Details
180 DPI 4.9.0 full desktop screenshot (338.75 KB, image/jpeg)
2012-08-18 02:31 UTC, Felix Miata
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Miata 2012-08-14 19:55:44 UTC
Created attachment 73166 [details]
screenshot

4.8.4 on openSUSE 12.2

To reproduce:
1-configure Xorg for high DPI
2-log into KDE
3-select leave -> log out from application starter

Actual behavior:
1-tiny logout confirmation window opens
2-fonts too small to read, much smaller than in KDE apps like KCalc
3-confirm and cancel targets too small to reliably hit with mouse click

Expected behavior:
1-logout confirmation window with fonts sized appropriately to the environment opens
2-confirm and cancel targets reasonably sized to environment

Comments:
1-I estimate the logout window is hard coded to 96 DPI.
2-Screenshot system is 180 DPI.
Comment 1 Jekyll Wu 2012-08-15 04:13:54 UTC
That part has been ported to QML in KDE SC 4.9 and I remember it fixes that font size problem.
Comment 2 Christoph Feck 2012-08-16 12:09:55 UTC

*** This bug has been marked as a duplicate of bug 216853 ***
Comment 3 Felix Miata 2012-08-16 14:14:45 UTC
This may be related to bug 216853, but it is more fundamental, and so distinguishable. This is not about respecting KDE font settings, even though KDE font settings include an option to force DPI. DPI is a global Xorg setting, applicable whether or not KDE is even installed. Fonts sized in pt as KDE's are automatically adjust upwards or downwards as DPI rises or falls. This can be seen by comparing Konqueror to Firefox when adjusting DPI. Konq fonts, sized in pt like other KDE fonts, automatically change, while Firefox's don't, as they are set in pixels. If this and bug 216853 are the same, then that bug is not fixed. It was marked fixed 07 February, while this exists in and was filed against a KDE release made 4 months later.
Comment 4 Jekyll Wu 2012-08-16 14:21:13 UTC
@Felix

That fix is in KDE SC 4.9+, while you are using KDE SC 4.8.4.
Comment 5 Lamarque V. Souza 2012-08-16 14:30:17 UTC
KDE does not automatically adjust font size because of DPI change, you have to do that manually. So although this and #216853 are not exactly the same problem the fix the same: use 4.9.0+ and increase the desktop font size in systemsettings.
Comment 6 Felix Miata 2012-08-16 16:49:41 UTC
openSUSE is due for release 30 August with 4.8.4. Until after 30 August, I don't do 4.9.

(In reply to comment #4)
> That fix is in KDE SC 4.9+, while you are using KDE SC 4.8.4.

That "fix" was made 4 months prior to 4.8.4 release. Why didn't 4.8 get it?

(In reply to comment #5)
> KDE does not automatically adjust font size because of DPI change

This must be a break with long standing behavior in 4.9, because KDE fonts have always been specified in kcontrol and systemsettings in pt, which at least as far back as KDE 3.4, have changed in px size automatically according to display density (except in most of the most recent web browsers http://fm.no-ip.com/Auth/Font/fonts-pt2px.html). e.g., @72 DPI, 12pt=12px; @96 DPI, 12pt=16px; @120 DPI, 12pt=20px; @144 DPI, 12pt=24px, etc. Forcing DPI in X (alternatively, directly in KDE) in order to change font (and other object) sizes globally is a long-standing practice used by those with below average vision and others with objections to small everything on high density displays. http://fm.no-ip.com/Share/DisplaySize exists on my web site to assist others to implement the practice, which to amounts to a global zoom function traditionally lacking as such in all DEs, but present in Gnome 3.

>, you have
> to do that manually. So although this and #216853 are not exactly the same
> problem the fix the same: use 4.9.0+ and increase the desktop font size in
> systemsettings.

Like many, I don't change font sizes in the DE until after a global adjustment at the Xorg level. People lacking average or better vision have poor tolerance for use of high density displays in conjunction with Xorg, DEs and/or apps that force 96. Not all apps in any given DE are native to that DE. Non-native apps may or may not obey systemsettings, but as a rule are affected by DPI. So the place to start is getting the global (Xorg) setting satisfactory, and only then fine-tuning within the DE, here in KDE, via systemsettings.
Comment 7 Lamarque V. Souza 2012-08-16 17:31:23 UTC
(In reply to comment #6)
> openSUSE is due for release 30 August with 4.8.4. Until after 30 August, I
> don't do 4.9.
> 
> (In reply to comment #4)
> > That fix is in KDE SC 4.9+, while you are using KDE SC 4.8.4.
> 
> That "fix" was made 4 months prior to 4.8.4 release. Why didn't 4.8 get it?

4.8.x branch was already considered stable by that time. It used to receive only bug fixes, not completely new implementations like the new QML shutdown dialog, so I did not port it to 4.8.x branches. 4.9.0 is the stable branch now, there is no point in fixing bugs that only happen in older branches. I will close this bug as fixed since it works in 4.9.0.
 
> (In reply to comment #5)
> > KDE does not automatically adjust font size because of DPI change
> 
> This must be a break with long standing behavior in 4.9, because KDE fonts
> have always been specified in kcontrol and systemsettings in pt, which at
> least as far back as KDE 3.4, have changed in px size automatically
> according to display density (except in most of the most recent web browsers
> http://fm.no-ip.com/Auth/Font/fonts-pt2px.html). e.g., @72 DPI, 12pt=12px;
> @96 DPI, 12pt=16px; @120 DPI, 12pt=20px; @144 DPI, 12pt=24px, etc. Forcing
> DPI in X (alternatively, directly in KDE) in order to change font (and other
> object) sizes globally is a long-standing practice used by those with below
> average vision and others with objections to small everything on high
> density displays. http://fm.no-ip.com/Share/DisplaySize exists on my web
> site to assist others to implement the practice, which to amounts to a
> global zoom function traditionally lacking as such in all DEs, but present
> in Gnome 3.

What I meant is that KDE does not increase font's pt size when the DPI changes. Of course, the font size changes on the screen when the DPI changes, but that is a Xorg's thing, not KDE's. If you increase the DPI to a so high value as 180 Xorg the font will appear very small because Xorg does that, not KDE. Then you have to increase font's pt size or it will be too small, that is what I meant. KDE has kmag application to zoom in/out a specific screen region. You can also use kwin's zoom effect, press the win key plus = or - to zoom in/out the whole desktop, not only a specific region, that works for any running program, even non-KDE programs. Do not say it does not exist in KDE if you have never really tried it.
 
> >, you have
> > to do that manually. So although this and #216853 are not exactly the same
> > problem the fix the same: use 4.9.0+ and increase the desktop font size in
> > systemsettings.
> 
> Like many, I don't change font sizes in the DE until after a global
> adjustment at the Xorg level. People lacking average or better vision have
> poor tolerance for use of high density displays in conjunction with Xorg,
> DEs and/or apps that force 96. Not all apps in any given DE are native to
> that DE. Non-native apps may or may not obey systemsettings, but as a rule
> are affected by DPI. So the place to start is getting the global (Xorg)
> setting satisfactory, and only then fine-tuning within the DE, here in KDE,
> via systemsettings.

New Xorg versions do not fix DPI to 96 anymore, mine for instance set DPI to (116, 120) (horizontal, vertical). Since you already set the DPI to 180 now you need to adjust the font sizes in systemsettings, don't you agree? There is kcm module that applies font changes from systemsettings to gtk programs too, that way you cover most of the applications used in Linux. There are programs, like Firefox and Chromium that ignore font settings from gtk's global configuration files, so it will not work for them. That is true for any desktop environment you use.
Comment 8 Christoph Feck 2012-08-17 14:22:16 UTC
The previous (4.8 and older) versions used hard coded font size specified in pixels, not points. The QML version respects the KDE font settings correctly.

*** This bug has been marked as a duplicate of bug 216853 ***
Comment 9 Felix Miata 2012-08-18 02:31:43 UTC
Created attachment 73265 [details]
180 DPI 4.9.0 full desktop screenshot

(In reply to comment #8)
> The previous (4.8 and older) versions used hard coded font size specified in
> pixels, not points. The QML version respects the KDE font settings correctly.

I installed 4.9 on the attachment 73166 [details] system. The logout confirmation window is indeed fixed, but there appear to be plenty of standard objects that still need to be converted from pixel sizing to accessible/usable sizing, such as: scrollbar width & arrows, titlebar height & icons, select list widgets, system tray objects, activity toolbar objects, systemsettings icons, and more.

To be clear, the system I took these screenshots on is not my own, but belongs to a severely visually challenged friend, unable to see to drive since years ago, and unable to do his own installations because accessibility is not part of any OS installation process I've encountered. On my own systems bug 283366 makes KDE4 unusable for anything more than dabbling.
Comment 10 Christoph Feck 2012-08-18 08:47:10 UTC
Felix, please report one issue per one bug report. This bug report is only about the logout dialog.

Please check bug 272266 and the bugs it depends on for more information about high-DPI KDE. For example, it also lists a bug about the Oxygen decoration issues. The scrollbars can be made wider: run "oxygen-settings".

Note that you can change icon sizes in System Settings. In general, KDE should respect the icon and font sizes set by the user in System Settings. Applications that do not respect these settings have to offer their own, otherwise it is considered a bug.

The icons in the System Settings side pane respects the "Dialog" icon size, icons next to single line texts (buttons/menu items etc.) respect the "Small" icon size (it should ideally be the same height as text). Please check if there are remaining applications that use small fixed size icons.

For Plasma, several bugs about fixed icon sizes have been reported, notably bug 163283, bug 133936, and bug 303487. You might do a full text query on open bugs to find more. If in doubt, report new bugs.