Bug 303372 - crash on quit
Summary: crash on quit
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-11 14:55 UTC by Jannis Liapis
Modified: 2012-07-11 15:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jannis Liapis 2012-07-11 14:55:34 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.5.0-4-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:Now it crashed when I closed the application without playing any song. It was just open .

The crash can be reproduced some of the time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f25286e3780 (LWP 17544))]

Thread 12 (Thread 0x7f2506a8e700 (LWP 17547)):
#0  0x00007f2524fd3b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f251d42e35f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007f251d41f76c in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007f251d41fdd9 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007f251d41fe90 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007f251d42e30f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007f2518872d18 in ?? () from /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
#7  0x00007f25216eee9a in start_thread (arg=0x7f2506a8e700) at pthread_create.c:308
#8  0x00007f2524fdf4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f24f9808700 (LWP 17549)):
#0  0x00007f2524fd3b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f251fbd1036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f251fbd1164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f252596b426 in QEventDispatcherGlib::processEvents (this=0x7f24f4000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f252593ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f252593aed7 in QEventLoop::exec (this=0x7f24f9807dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f2525839fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f252591a9ff in QInotifyFileSystemWatcherEngine::run (this=0x1cfcbe0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f252583cfcb in QThreadPrivate::start (arg=0x1cfcbe0) at thread/qthread_unix.cpp:298
#9  0x00007f25216eee9a in start_thread (arg=0x7f24f9808700) at pthread_create.c:308
#10 0x00007f2524fdf4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f24f31a1700 (LWP 17550)):
#0  __pthread_mutex_lock (mutex=0x7f24ec000a60) at pthread_mutex_lock.c:127
#1  0x00007f251fc0c5a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f251fbd0f35 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f251fbd1164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f252596b426 in QEventDispatcherGlib::processEvents (this=0x7f24ec0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f252593ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f252593aed7 in QEventLoop::exec (this=0x7f24f31a0e00, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f2525839fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f252583cfcb in QThreadPrivate::start (arg=0x1fc9a20) at thread/qthread_unix.cpp:298
#9  0x00007f25216eee9a in start_thread (arg=0x7f24f31a1700) at pthread_create.c:308
#10 0x00007f2524fdf4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f24f1cde700 (LWP 17551)):
#0  0x00007fffc0dff60a in ?? ()
#1  0x00007fffc0dff8a4 in clock_gettime ()
#2  0x00007f251e60515d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#3  0x00007f2525893bb4 in do_gettime (frac=0x7f24f1cddbe8, sec=0x7f24f1cddbe0) at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007f252596bb8d in QTimerInfoList::updateCurrentTime (this=0x7f24e4002060) at kernel/qeventdispatcher_unix.cpp:343
#6  0x00007f252596bec3 in QTimerInfoList::timerWait (this=0x7f24e4002060, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#7  0x00007f252596a97c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f24f1cddc9c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007f251fbd0846 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f251fbd0f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f251fbd1164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f252596b426 in QEventDispatcherGlib::processEvents (this=0x7f24e40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f252593ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f252593aed7 in QEventLoop::exec (this=0x7f24f1cdde00, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f2525839fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007f252583cfcb in QThreadPrivate::start (arg=0x1ffcd80) at thread/qthread_unix.cpp:298
#16 0x00007f25216eee9a in start_thread (arg=0x7f24f1cde700) at pthread_create.c:308
#17 0x00007f2524fdf4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#18 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f24f08d1700 (LWP 17553)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f252583d4db in wait (time=18446744073709551615, this=0x204ecb0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x204ee30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2522c840eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x204eb60, th=0x204fc10) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f2522c869db in ThreadWeaver::WorkingHardState::applyForWork (this=0x204f8c0, th=0x204fc10) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f2522c869f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x204f8c0, th=0x204fc10) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f2522c8584f in ThreadWeaver::ThreadRunHelper::run (this=0x7f24f08d0e20, parent=0x204eb60, th=0x204fc10) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f2522c858db in ThreadWeaver::Thread::run (this=0x204fc10) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f252583cfcb in QThreadPrivate::start (arg=0x204fc10) at thread/qthread_unix.cpp:298
#9  0x00007f25216eee9a in start_thread (arg=0x7f24f08d1700) at pthread_create.c:308
#10 0x00007f2524fdf4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f24e3127700 (LWP 17555)):
#0  0x00007f25216f0f69 in __pthread_mutex_lock (mutex=0x7f24d8000a60) at pthread_mutex_lock.c:92
#1  0x00007f251fc0c5a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f251fbd0851 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f251fbd0f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f251fbd1164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f252596b426 in QEventDispatcherGlib::processEvents (this=0x7f24d80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f252593ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f252593aed7 in QEventLoop::exec (this=0x7f24e3126dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f2525839fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f252591a9ff in QInotifyFileSystemWatcherEngine::run (this=0x239d030) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f252583cfcb in QThreadPrivate::start (arg=0x239d030) at thread/qthread_unix.cpp:298
#11 0x00007f25216eee9a in start_thread (arg=0x7f24e3127700) at pthread_create.c:308
#12 0x00007f2524fdf4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f24e24fe700 (LWP 17556)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f252583d4db in wait (time=18446744073709551615, this=0x204ecb0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x204ee30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2522c840eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x204eb60, th=0x2443be0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f2522c869db in ThreadWeaver::WorkingHardState::applyForWork (this=0x204f8c0, th=0x2443be0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f2522c8584f in ThreadWeaver::ThreadRunHelper::run (this=0x7f24e24fde20, parent=0x204eb60, th=0x2443be0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f2522c858db in ThreadWeaver::Thread::run (this=0x2443be0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f252583cfcb in QThreadPrivate::start (arg=0x2443be0) at thread/qthread_unix.cpp:298
#8  0x00007f25216eee9a in start_thread (arg=0x7f24e24fe700) at pthread_create.c:308
#9  0x00007f2524fdf4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f24e1cfd700 (LWP 17557)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f252583d4db in wait (time=18446744073709551615, this=0x204ecb0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x204ee30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2522c840eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x204eb60, th=0x23ddb00) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f2522c869db in ThreadWeaver::WorkingHardState::applyForWork (this=0x204f8c0, th=0x23ddb00) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f2522c8584f in ThreadWeaver::ThreadRunHelper::run (this=0x7f24e1cfce20, parent=0x204eb60, th=0x23ddb00) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f2522c858db in ThreadWeaver::Thread::run (this=0x23ddb00) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f252583cfcb in QThreadPrivate::start (arg=0x23ddb00) at thread/qthread_unix.cpp:298
#8  0x00007f25216eee9a in start_thread (arg=0x7f24e1cfd700) at pthread_create.c:308
#9  0x00007f2524fdf4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f24e14fc700 (LWP 17558)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f252583d4db in wait (time=18446744073709551615, this=0x204ecb0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x204ee30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2522c840eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x204eb60, th=0x23de640) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f2522c869db in ThreadWeaver::WorkingHardState::applyForWork (this=0x204f8c0, th=0x23de640) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f2522c8584f in ThreadWeaver::ThreadRunHelper::run (this=0x7f24e14fbe20, parent=0x204eb60, th=0x23de640) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f2522c858db in ThreadWeaver::Thread::run (this=0x23de640) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f252583cfcb in QThreadPrivate::start (arg=0x23de640) at thread/qthread_unix.cpp:298
#8  0x00007f25216eee9a in start_thread (arg=0x7f24e14fc700) at pthread_create.c:308
#9  0x00007f2524fdf4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f24cffff700 (LWP 17559)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f251c80cdec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f251d1d5de0) at wtf/FastMalloc.cpp:2495
#2  0x00007f251c80cf19 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00007f25216eee9a in start_thread (arg=0x7f24cffff700) at pthread_create.c:308
#4  0x00007f2524fdf4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f24ceffd700 (LWP 17563)):
#0  0x00007f2524fab03d in nanosleep () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f2524faaedc in __sleep (seconds=0) at ../sysdeps/unix/sysv/linux/sleep.c:138
#2  0x00007f2521cc91b5 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f2521cc9259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#4  0x00007f25216eee9a in start_thread (arg=0x7f24ceffd700) at pthread_create.c:308
#5  0x00007f2524fdf4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f25286e3780 (LWP 17544)):
[KCrash Handler]
#6  0x00007f25259545dd in QObject::~QObject (this=0x1d17010, __in_chrg=<optimized out>) at kernel/qobject.cpp:820
#7  0x00007f2525954e69 in QObject::~QObject (this=0x1d17010, __in_chrg=<optimized out>) at kernel/qobject.cpp:940
#8  0x00007f252758902e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#9  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#10 CollectionManager::~CollectionManager (this=0x1c37960, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:137
#11 0x00007f2527589209 in CollectionManager::~CollectionManager (this=0x1c37960, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:145
#12 0x00007f25275874b6 in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:107
#13 0x00007f25276bc4cf in App::~App (this=0x7fffc0dd90e0, __in_chrg=<optimized out>) at ../../src/App.cpp:248
#14 0x0000000000408e5a in main (argc=1, argv=0x7fffc0ddb568) at ../../src/main.cpp:303

This bug may be a duplicate of or related to bug 300194.

Possible duplicates by query: bug 300194, bug 298222, bug 297555, bug 294709, bug 281312.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-11 15:25:58 UTC

*** This bug has been marked as a duplicate of bug 285951 ***