Bug 304433 - System freeze in a Skype 4.0 call
Summary: System freeze in a Skype 4.0 call
Status: RESOLVED DUPLICATE of bug 283105
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-02 11:21 UTC by Stefan Becker
Modified: 2012-08-03 15:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Becker 2012-08-02 11:21:56 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Phone via Skype
- Unusual behavior I noticed:
System totaly stpped. No mouse move, strg+alt+del dosn't work..only press 4 sec. powerb utton  :-(
in the synaptiks tools was touchpad disabled when keyboard ist in use....

-- Backtrace:
Application: KDE-Dienst (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6da5464780 (LWP 1526))]

Thread 2 (Thread 0x7f6d87ea6700 (LWP 1624)):
#0  0x00007f6da2c86b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f6d9fd9d036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6d9fd9d164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6da40d5426 in QEventDispatcherGlib::processEvents (this=0x7f6d800008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6da40a4c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6da40a4ed7 in QEventLoop::exec (this=0x7f6d87ea5dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6da3fa3fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f6da40849ff in QInotifyFileSystemWatcherEngine::run (this=0x1ea01a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f6da3fa6fcb in QThreadPrivate::start (arg=0x1ea01a0) at thread/qthread_unix.cpp:298
#9  0x00007f6da0673e9a in start_thread (arg=0x7f6d87ea6700) at pthread_create.c:308
#10 0x00007f6da2c924bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6da5464780 (LWP 1526)):
[KCrash Handler]
#6  0x00007f6d88a33cd6 in SecretStorage::walletOpenedForRead (this=0x21c0540, success=true) at ../../../libs/service/secretstorage.cpp:160
#7  0x00007f6da40ba281 in QMetaObject::activate (sender=0x21b8930, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffa1cccf00) at kernel/qobject.cpp:3547
#8  0x00007f6da4f58712 in KWallet::Wallet::walletOpened (this=<optimized out>, _t1=true) at ./kwallet.moc:167
#9  0x00007f6da40ba281 in QMetaObject::activate (sender=0x20d3760, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffa1ccd050) at kernel/qobject.cpp:3547
#10 0x00007f6da4f8a23f in OrgKdeKWalletInterface::walletAsyncOpened (this=<optimized out>, _t1=0, _t2=1570377686) at kwallet_interface.moc:324
#11 0x00007f6da4f8c9a6 in OrgKdeKWalletInterface::qt_static_metacall (_o=0x20d3760, _id=<optimized out>, _a=0x7fffa1ccd7b0, _c=<optimized out>) at kwallet_interface.moc:162
#12 0x00007f6da4f8cc4b in OrgKdeKWalletInterface::qt_metacall (this=0x20d3760, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa1ccd7b0) at kwallet_interface.moc:287
#13 0x00007f6da161137b in QDBusConnectionPrivate::deliverCall (this=0x1ebed60, object=0x20d3760, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:947
#14 0x00007f6da40bf446 in QObject::event (this=0x20d3760, e=<optimized out>) at kernel/qobject.cpp:1195
#15 0x00007f6da3428894 in notify_helper (e=0x2152500, receiver=0x20d3760, this=0x1eca280) at kernel/qapplication.cpp:4559
#16 QApplicationPrivate::notify_helper (this=0x1eca280, receiver=0x20d3760, e=0x2152500) at kernel/qapplication.cpp:4531
#17 0x00007f6da342d713 in QApplication::notify (this=0x7fffa1cce1b0, receiver=0x20d3760, e=0x2152500) at kernel/qapplication.cpp:4420
#18 0x00007f6da4e409e6 in KApplication::notify (this=0x7fffa1cce1b0, receiver=0x20d3760, event=0x2152500) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007f6da40a5e9c in QCoreApplication::notifyInternal (this=0x7fffa1cce1b0, receiver=0x20d3760, event=0x2152500) at kernel/qcoreapplication.cpp:876
#20 0x00007f6da40a9c6a in sendEvent (event=0x2152500, receiver=0x20d3760) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1e352b0) at kernel/qcoreapplication.cpp:1500
#22 0x00007f6da40d4f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#23 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#24 0x00007f6d9fd9cd53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f6d9fd9d0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f6d9fd9d164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f6da40d53bf in QEventDispatcherGlib::processEvents (this=0x1e377d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#28 0x00007f6da34d0d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007f6da40a4c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f6da40a4ed7 in QEventLoop::exec (this=0x7fffa1cce140, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007f6da40a9f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#32 0x00007f6d907c1e55 in kdemain (argc=1, argv=0x1e8a4d0) at ../../kded/kded.cpp:924
#33 0x00000000004086a4 in launch (argc=1, _name=0x40b497 "kded4", args=<optimized out>, cwd=0x0, envc=<optimized out>, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b31e "0") at ../../kinit/kinit.cpp:746
#34 0x0000000000405a59 in main (argc=4, argv=0x7fff00000001, envp=0x7fffa1ccf340) at ../../kinit/kinit.cpp:1861

Possible duplicates by query: bug 303556, bug 303528, bug 303465, bug 303393, bug 303024.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-08-03 15:02:15 UTC

*** This bug has been marked as a duplicate of bug 283105 ***