Bug 304219 - Kontact crashed when deleting a to-do
Summary: Kontact crashed when deleting a to-do
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Unclassified
Component: todoview (show other bugs)
Version: 4.8.x
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 304109 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-29 07:36 UTC by Chris Williamson
Modified: 2012-12-01 21:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Williamson 2012-07-29 07:36:29 UTC
Application: kontact (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I logged in and opened Kontact. I went to the To-do List, opened an item and viewed the Attendees tab. I'm pretty sure I clicked Cancel, then right-clicked on the to-do item and selected delete. I got a dialog asking if I wanted to notify the attendee, and I selected no (or whatever the exact phrasing is). That's when Kontact crashed.

It's crashed 5–10 times in the last day or two. I believe every time it's been when I've clicked something while working with the To-do List or a to-do item. Logging out and logging back in does not solve the problem, but rebooting did seem to, for a while.

I've added and deleted several address books, email accounts and calendars, of varying types. As of now I've deleted all but two POP3 email accounts, the standard address book and the standard calendar file. The deleted resources were a couple of Google address books, an IMAP account, a couple of DAV calendars and a couple of Google calendars. I added and deleted some of those twice.

I do recall a notification within the last few days about a ... "payload", I think it was. I saw it only once or twice.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb76c1980 (LWP 12614))]

Thread 4 (Thread 0xb57d7b40 (LWP 12615)):
#0  0x005fa416 in __kernel_vsyscall ()
#1  0x008a496b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x00ca23dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x02f97263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0x02f9737f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0x008a0d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x00c94ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xb4eb6b40 (LWP 12616)):
#0  0x01ae4287 in __i686.get_pc_thunk.bx () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#1  0x01c4d210 in QTimerInfoList::updateCurrentTime (this=0xb4502074) at kernel/qeventdispatcher_unix.cpp:342
#2  0x01c4ce16 in timerSourceCheckHelper (src=0xb4502040) at kernel/qeventdispatcher_glib.cpp:150
#3  timerSourceCheckHelper (src=0xb4502040) at kernel/qeventdispatcher_glib.cpp:144
#4  0x04765b7b in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x04766042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0x04766201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x01c4c8e7 in QEventDispatcherGlib::processEvents (this=0xb4500468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#8  0x01c1850d in QEventLoop::processEvents (this=0xb4eb6270, flags=...) at kernel/qeventloop.cpp:149
#9  0x01c187a9 in QEventLoop::exec (this=0xb4eb6270, flags=...) at kernel/qeventloop.cpp:204
#10 0x01b0194c in QThread::exec (this=0x86ccc58) at thread/qthread.cpp:501
#11 0x01b01a3b in QThread::run (this=0x86ccc58) at thread/qthread.cpp:568
#12 0x01b04de0 in QThreadPrivate::start (arg=0x86ccc58) at thread/qthread_unix.cpp:298
#13 0x008a0d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0x00c94ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb2a1cb40 (LWP 12638)):
#0  0x005fa416 in __kernel_vsyscall ()
#1  0x00c86380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x04773a7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x047660ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x04766201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x01c4c8e7 in QEventDispatcherGlib::processEvents (this=0xb2100468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x01c1850d in QEventLoop::processEvents (this=0xb2a1c240, flags=...) at kernel/qeventloop.cpp:149
#7  0x01c187a9 in QEventLoop::exec (this=0xb2a1c240, flags=...) at kernel/qeventloop.cpp:204
#8  0x01b0194c in QThread::exec (this=0x8dd9210) at thread/qthread.cpp:501
#9  0x01bf5b5d in QInotifyFileSystemWatcherEngine::run (this=0x8dd9210) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01b04de0 in QThreadPrivate::start (arg=0x8dd9210) at thread/qthread_unix.cpp:298
#11 0x008a0d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00c94ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb76c1980 (LWP 12614)):
[KCrash Handler]
#7  QSortFilterProxyModelPrivate::updateChildrenMapping (this=0x914fc38, source_parent=..., parent_mapping=0xafdeed8, orient=Qt::Vertical, start=50, end=50, delta_item_count=1, remove=true) at itemviews/qsortfilterproxymodel.cpp:948
#8  0x0174bffb in source_items_removed (orient=Qt::Vertical, end=50, start=50, source_parent=..., this=0x914fc38) at itemviews/qsortfilterproxymodel.cpp:890
#9  QSortFilterProxyModelPrivate::source_items_removed (this=0x914fc38, source_parent=..., start=50, end=50, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:848
#10 0x0174c1bb in QSortFilterProxyModelPrivate::_q_sourceRowsRemoved (this=0x914fc38, source_parent=..., start=50, end=50) at itemviews/qsortfilterproxymodel.cpp:1297
#11 0x01c306b1 in QMetaObject::activate (sender=0x914f8b8, m=0x1d772b8, local_signal_index=7, argv=0xbffbbee0) at kernel/qobject.cpp:3547
#12 0x01c824b5 in QAbstractItemModel::rowsRemoved (this=0x914f8b8, _t1=..., _t2=50, _t3=50) at .moc/release-shared/moc_qabstractitemmodel.cpp:211
#13 0x01c1336e in QAbstractItemModel::endRemoveRows (this=0x914f8b8) at kernel/qabstractitemmodel.cpp:2487
#14 0x07ed2db3 in KOTodoModel::processChange (this=0x914f8b8, aitem=..., action=174728072) at ../../korganizer/views/todoview/kotodomodel.cpp:313
#15 0x07eddb3e in KOTodoView::changeIncidenceDisplay (this=0x91e4640, incidence=..., action=2) at ../../korganizer/views/todoview/kotodoview.cpp:435
#16 0x07ef920f in CalendarView::changeIncidenceDisplay (this=0x907ee50, item=..., action=2) at ../../korganizer/calendarview.cpp:844
#17 0x07ef96a0 in CalendarView::incidenceDeleteFinished (this=0x907ee50, item=..., success=true) at ../../korganizer/calendarview.cpp:800
#18 0x07f1047b in CalendarView::qt_static_metacall (_o=0x907ee50, _c=QMetaObject::InvokeMetaMethod, _id=101, _a=0xbffbc2c4) at ./calendarview.moc:495
#19 0x01c306b1 in QMetaObject::activate (sender=0x91d9898, m=0x580b6a8, local_signal_index=2, argv=0xbffbc2c4) at kernel/qobject.cpp:3547
#20 0x0573ad95 in CalendarSupport::IncidenceChanger::incidenceDeleteFinished (this=0x91d9898, _t1=..., _t2=true) at moc_incidencechanger.cpp:139
#21 0x0578a658 in CalendarSupport::IncidenceChanger::deleteIncidenceFinished (this=0x91d9898, j=0xefb17e8) at ../../calendarsupport/incidencechanger.cpp:425
#22 0x0573af79 in qt_static_metacall (_a=0xbffbc4d8, _id=7, _o=0x91d9898, _c=<optimized out>) at moc_incidencechanger.cpp:76
#23 CalendarSupport::IncidenceChanger::qt_static_metacall (_o=0x91d9898, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbffbc4d8) at moc_incidencechanger.cpp:63
#24 0x01c306b1 in QMetaObject::activate (sender=0xf0d6a60, m=0xba24ac, local_signal_index=3, argv=0xbffbc4d8) at kernel/qobject.cpp:3547
#25 0x009ed7b5 in KJob::result (this=0xf0d6a60, _t1=0xf0d6a60) at ./kjob.moc:208
#26 0x009ed808 in KJob::emitResult (this=0xf0d6a60) at ../../kdecore/jobs/kjob.cpp:318
#27 0x07aec72e in Akonadi::JobPrivate::delayedEmitResult (this=0x92390a0) at ../../akonadi/job.cpp:144
#28 0x01c2bc01 in QMetaCallEvent::placeMetaCall (this=0xf0d8270, object=0xf0d6a60) at kernel/qobject.cpp:525
#29 0x01c34c7b in QObject::event (this=0xf0d6a60, e=0xf0d8270) at kernel/qobject.cpp:1195
#30 0x01104ed4 in notify_helper (e=0xf0d8270, receiver=0xf0d6a60, this=0x85d0b68) at kernel/qapplication.cpp:4559
#31 QApplicationPrivate::notify_helper (this=0x85d0b68, receiver=0xf0d6a60, e=0xf0d8270) at kernel/qapplication.cpp:4531
#32 0x0110a30d in QApplication::notify (this=0xf0d8270, receiver=0xf0d6a60, e=0xf0d8270) at kernel/qapplication.cpp:4288
#33 0x002fd401 in KApplication::notify (this=0xbffbcd14, receiver=0xf0d6a60, event=0xf0d8270) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x01c1997e in QCoreApplication::notifyInternal (this=0xbffbcd14, receiver=0xf0d6a60, event=0xf0d8270) at kernel/qcoreapplication.cpp:876
#35 0x01c1dad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x85a8ab8) at kernel/qcoreapplication.cpp:1500
#37 0x01c1de0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#38 0x01c4c494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=0x85d5aa0) at kernel/qeventdispatcher_glib.cpp:279
#40 0x04765d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0x04766125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#42 0x04766201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#43 0x01c4c887 in QEventDispatcherGlib::processEvents (this=0x85caf28, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0x011bdaaa in QGuiEventDispatcherGlib::processEvents (this=0x85caf28, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x01c1850d in QEventLoop::processEvents (this=0xbffbcc74, flags=...) at kernel/qeventloop.cpp:149
#46 0x01c187a9 in QEventLoop::exec (this=0xbffbcc74, flags=...) at kernel/qeventloop.cpp:204
#47 0x01c1deba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#48 0x01102a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#49 0x0804ac91 in main (argc=220362936, argv=0xa6a2368) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 304109.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-29 07:51:55 UTC
*** Bug 304109 has been marked as a duplicate of this bug. ***
Comment 2 Chris Williamson 2012-07-29 08:00:51 UTC
Seems like these two could be related:

https://bugs.kde.org/show_bug.cgi?id=297387
https://bugs.kde.org/show_bug.cgi?id=293781
Comment 3 Sergio Martins 2012-11-28 23:52:44 UTC
Fixed for 4.11