Bug 304109 - View filter change triggers crash
Summary: View filter change triggers crash
Status: RESOLVED DUPLICATE of bug 304219
Alias: None
Product: korganizer
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-26 20:20 UTC by Michael Hammond
Modified: 2012-07-29 07:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Hammond 2012-07-26 20:20:34 UTC
Application: korganizer (4.8.4- ())
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Changed current view filter from all except two categories to only one category.  Closed window with OK.  View appeared not to change to match current definition of filter.  Used menu to set 'No filter'; then immediately went back and set to the previous filter.  Crash.

-- Backtrace:
Application: KOrganizer (korganizer), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6e640e87c0 (LWP 5720))]

Thread 2 (Thread 0x7f6e481f0700 (LWP 7742)):
#0  0x00007f6e5a74af69 in __pthread_mutex_lock (mutex=0x7f6e40000a60) at pthread_mutex_lock.c:92
#1  0x00007f6e5a2b75a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6e5a27b675 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6e5a27bf5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6e5a27c164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6e6104d426 in QEventDispatcherGlib::processEvents (this=0x7f6e400008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f6e6101cc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f6e6101ced7 in QEventLoop::exec (this=0x7f6e481efd90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f6e60f1bfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f6e60ffc9ff in QInotifyFileSystemWatcherEngine::run (this=0xd08950) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f6e60f1efcb in QThreadPrivate::start (arg=0xd08950) at thread/qthread_unix.cpp:298
#11 0x00007f6e5a748e9a in start_thread (arg=0x7f6e481f0700) at pthread_create.c:308
#12 0x00007f6e606c24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6e640e87c0 (LWP 5720)):
[KCrash Handler]
#6  QSortFilterProxyModelPrivate::updateChildrenMapping (this=0x9d1c40, source_parent=..., parent_mapping=0x179d6d0, orient=Qt::Vertical, start=0, end=0, delta_item_count=1, remove=true) at itemviews/qsortfilterproxymodel.cpp:948
#7  0x00007f6e61fc7aa8 in source_items_removed (orient=Qt::Vertical, end=0, start=0, source_parent=..., this=0x9d1c40) at itemviews/qsortfilterproxymodel.cpp:890
#8  QSortFilterProxyModelPrivate::source_items_removed (this=0x9d1c40, source_parent=..., start=0, end=<optimized out>, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:848
#9  0x00007f6e61032281 in QMetaObject::activate (sender=0x9cb8e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff3dae43a0) at kernel/qobject.cpp:3547
#10 0x00007f6e6107e6e4 in QAbstractItemModel::rowsRemoved (this=<optimized out>, _t1=..., _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:211
#11 0x00007f6e61017f1d in QAbstractItemModel::endRemoveRows (this=0x9cb8e0) at kernel/qabstractitemmodel.cpp:2487
#12 0x00007f6e629b9fe3 in deleteMarked (this=0x11f0850) at ../../korganizer/views/todoview/kotodomodel.cpp:131
#13 deleteMarked (this=<optimized out>) at ../../korganizer/views/todoview/kotodomodel.cpp:136
#14 KOTodoModel::reloadTodos (this=0x9cb8e0) at ../../korganizer/views/todoview/kotodomodel.cpp:259
#15 0x00007f6e629f587e in KOViewManager::updateView (this=0x945120, start=..., end=..., preferredMonth=...) at ../../korganizer/koviewmanager.cpp:285
#16 0x00007f6e629dda56 in CalendarView::updateView (this=0x8eac30, start=..., end=..., preferredMonth=..., updateTodos=true) at ../../korganizer/calendarview.cpp:868
#17 0x00007f6e629ddaea in CalendarView::updateView (this=0x8eac30) at ../../korganizer/calendarview.cpp:882
#18 0x00007f6e629e4846 in CalendarView::filterActivated (this=0x8eac30, filterNo=<optimized out>) at ../../korganizer/calendarview.cpp:2226
#19 0x00007f6e629f3558 in CalendarView::qt_static_metacall (_o=0x8eac30, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./calendarview.moc:573
#20 0x00007f6e61032281 in QMetaObject::activate (sender=0xd90830, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff3dae4a50) at kernel/qobject.cpp:3547
#21 0x00007f6e63a179b1 in KSelectAction::triggered (this=<optimized out>, _t1=1) at ./kselectaction.moc:196
#22 0x00007f6e63a1821f in KSelectAction::actionTriggered (this=0xd90830, action=0x1e8d940) at ../../kdeui/actions/kselectaction.cpp:322
#23 0x00007f6e61032281 in QMetaObject::activate (sender=0xd90d70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff3dae4c00) at kernel/qobject.cpp:3547
#24 0x00007f6e61a14c9f in QActionGroup::triggered (this=<optimized out>, _t1=0x1e8d940) at .moc/release-shared/moc_qactiongroup.cpp:160
#25 0x00007f6e61a14d27 in QActionGroupPrivate::_q_actionTriggered (this=<optimized out>) at kernel/qactiongroup.cpp:93
#26 0x00007f6e61032281 in QMetaObject::activate (sender=0x1e8d940, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff3dae4d70) at kernel/qobject.cpp:3547
#27 0x00007f6e61a12132 in QAction::triggered (this=<optimized out>, _t1=true) at .moc/release-shared/moc_qaction.cpp:277
#28 0x00007f6e61a1231f in QAction::activate (this=0x1e8d940, event=<optimized out>) at kernel/qaction.cpp:1257
#29 0x00007f6e61e64119 in QMenuPrivate::activateCausedStack (this=0xd91030, causedStack=..., action=0x1e8d940, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1028
#30 0x00007f6e61e6a272 in QMenuPrivate::activateAction (this=0xd91030, action=0x1e8d940, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1120
#31 0x00007f6e63bb52d0 in KMenu::mouseReleaseEvent (this=0xd90ce0, e=0x7fff3dae5940) at ../../kdeui/widgets/kmenu.cpp:464
#32 0x00007f6e61a69144 in QWidget::event (this=0xd90ce0, event=0x7fff3dae5940) at kernel/qwidget.cpp:8362
#33 0x00007f6e61e6b80b in QMenu::event (this=0xd90ce0, e=0x7fff3dae5940) at widgets/qmenu.cpp:2469
#34 0x00007f6e61a18894 in notify_helper (e=0x7fff3dae5940, receiver=0xd90ce0, this=0x7de6c0) at kernel/qapplication.cpp:4559
#35 QApplicationPrivate::notify_helper (this=0x7de6c0, receiver=0xd90ce0, e=0x7fff3dae5940) at kernel/qapplication.cpp:4531
#36 0x00007f6e61a1e0bf in QApplication::notify (this=<optimized out>, receiver=0xd90ce0, e=0x7fff3dae5940) at kernel/qapplication.cpp:4102
#37 0x00007f6e63af49e6 in KApplication::notify (this=0x7fff3dae6600, receiver=0xd90ce0, event=0x7fff3dae5940) at ../../kdeui/kernel/kapplication.cpp:311
#38 0x00007f6e6101de9c in QCoreApplication::notifyInternal (this=0x7fff3dae6600, receiver=0xd90ce0, event=0x7fff3dae5940) at kernel/qcoreapplication.cpp:876
#39 0x00007f6e61a19862 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#40 QApplicationPrivate::sendMouseEvent (receiver=0xd90ce0, event=0x7fff3dae5940, alienWidget=0x0, nativeWidget=0xd90ce0, buttonDown=0x0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#41 0x00007f6e61a992c1 in QETWidget::translateMouseEvent (this=0xd90ce0, event=<optimized out>) at kernel/qapplication_x11.cpp:4551
#42 0x00007f6e61a97bae in QApplication::x11ProcessEvent (this=0x7fff3dae6600, event=0x7fff3dae6210) at kernel/qapplication_x11.cpp:3732
#43 0x00007f6e61ac10d2 in x11EventSourceDispatch (s=0x7de430, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#44 0x00007f6e5a27bd53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f6e5a27c0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007f6e5a27c164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#47 0x00007f6e6104d3bf in QEventDispatcherGlib::processEvents (this=0x7a7c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#48 0x00007f6e61ac0d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00007f6e6101cc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#50 0x00007f6e6101ced7 in QEventLoop::exec (this=0x7fff3dae65b0, flags=...) at kernel/qeventloop.cpp:204
#51 0x00007f6e61021f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#52 0x0000000000407df6 in main (argc=<optimized out>, argv=<optimized out>) at ../../korganizer/main.cpp:67

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-29 07:51:55 UTC

*** This bug has been marked as a duplicate of bug 304219 ***