Bug 303078 - Amarok crashed if I close it
Summary: Amarok crashed if I close it
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-05 19:34 UTC by Paul
Modified: 2012-07-05 19:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul 2012-07-05 19:34:15 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
- I run Amarok
- I listened music(*mp3)
- I exited out of Amarok and Amarok crashed

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f69bdec27c0 (LWP 10526))]

Thread 11 (Thread 0x7f698d55c700 (LWP 10531)):
#0  0x00007f69ba7b5b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f69b53b5036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f69b53b5164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f69bb14c426 in QEventDispatcherGlib::processEvents (this=0x7f6988000920, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f69bb11bc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f69bb11bed7 in QEventLoop::exec (this=0x7f698d55bcd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f69bb01afa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f69bb0fb9ff in QInotifyFileSystemWatcherEngine::run (this=0x2849f40) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x2849f40) at thread/qthread_unix.cpp:298
#9  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f69b6ed2e9a in start_thread (arg=0x7f698d55c700) at pthread_create.c:308
#11 0x00007f69ba7c14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f6986f08700 (LWP 10532)):
#0  0x00007f69b6ed4fc0 in __pthread_mutex_lock (mutex=0x7f6980000a80) at pthread_mutex_lock.c:113
#1  0x00007f69b53f05a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f69b53b4ff1 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f69b53b5164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f69bb14c426 in QEventDispatcherGlib::processEvents (this=0x7f69800008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f69bb11bc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f69bb11bed7 in QEventLoop::exec (this=0x7f6986f07d00, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f69bb01afa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x29c73b0) at thread/qthread_unix.cpp:298
#9  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f69b6ed2e9a in start_thread (arg=0x7f6986f08700) at pthread_create.c:308
#11 0x00007f69ba7c14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f6985a68700 (LWP 10533)):
#0  0x00007f69b6ed4fc0 in __pthread_mutex_lock (mutex=0x7f6978000a80) at pthread_mutex_lock.c:113
#1  0x00007f69b53f05a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f69b53b4851 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f69b53b4f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f69b53b5164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f69bb14c426 in QEventDispatcherGlib::processEvents (this=0x7f69780008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f69bb11bc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f69bb11bed7 in QEventLoop::exec (this=0x7f6985a67d00, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f69bb01afa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x2a32710) at thread/qthread_unix.cpp:298
#10 0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#11 0x00007f69b6ed2e9a in start_thread (arg=0x7f6985a68700) at pthread_create.c:308
#12 0x00007f69ba7c14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f6984e5c700 (LWP 10535)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f69bb01e4db in wait (time=18446744073709551615, this=0x2a97130) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2a972b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f69b84670eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2a96fe0, th=0x2a976d0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f69b84699db in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a97380, th=0x2a976d0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f69b84699f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a97380, th=0x2a976d0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f69b84699f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a97380, th=0x2a976d0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f69b846884f in ThreadWeaver::ThreadRunHelper::run (this=0x7f6984e5bd20, parent=0x2a96fe0, th=0x2a976d0) at ../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007f69b84688db in ThreadWeaver::Thread::run (this=0x2a976d0) at ../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x2a976d0) at thread/qthread_unix.cpp:298
#10 0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#11 0x00007f69b6ed2e9a in start_thread (arg=0x7f6984e5c700) at pthread_create.c:308
#12 0x00007f69ba7c14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f697ed5b700 (LWP 10536)):
#0  0x00007f69ba7b5b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f69b53b5036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f69b53b5164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f69bb14c426 in QEventDispatcherGlib::processEvents (this=0x7f69700008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f69bb11bc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f69bb11bed7 in QEventLoop::exec (this=0x7f697ed5acd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f69bb01afa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f69bb0fb9ff in QInotifyFileSystemWatcherEngine::run (this=0x2f18320) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x2f18320) at thread/qthread_unix.cpp:298
#9  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f69b6ed2e9a in start_thread (arg=0x7f697ed5b700) at pthread_create.c:308
#11 0x00007f69ba7c14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f697e132700 (LWP 10537)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f69bb01e4db in wait (time=18446744073709551615, this=0x2a97130) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2a972b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f69b84670eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2a96fe0, th=0x302d850) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f69b84699db in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a97380, th=0x302d850) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f69b846884f in ThreadWeaver::ThreadRunHelper::run (this=0x7f697e131d20, parent=0x2a96fe0, th=0x302d850) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f69b84688db in ThreadWeaver::Thread::run (this=0x302d850) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x302d850) at thread/qthread_unix.cpp:298
#8  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f69b6ed2e9a in start_thread (arg=0x7f697e132700) at pthread_create.c:308
#10 0x00007f69ba7c14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f696bfff700 (LWP 10538)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f69bb01e4db in wait (time=18446744073709551615, this=0x2a97130) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2a972b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f69b84670eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2a96fe0, th=0x302e8a0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f69b84699db in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a97380, th=0x302e8a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f69b846884f in ThreadWeaver::ThreadRunHelper::run (this=0x7f696bffed20, parent=0x2a96fe0, th=0x302e8a0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f69b84688db in ThreadWeaver::Thread::run (this=0x302e8a0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x302e8a0) at thread/qthread_unix.cpp:298
#8  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f69b6ed2e9a in start_thread (arg=0x7f696bfff700) at pthread_create.c:308
#10 0x00007f69ba7c14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f696b7fe700 (LWP 10539)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f69bb01e4db in wait (time=18446744073709551615, this=0x2a97130) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2a972b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f69b84670eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2a96fe0, th=0x2f78120) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f69b84699db in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a97380, th=0x2f78120) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f69b84699f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a97380, th=0x2f78120) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f69b846884f in ThreadWeaver::ThreadRunHelper::run (this=0x7f696b7fdd20, parent=0x2a96fe0, th=0x2f78120) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f69b84688db in ThreadWeaver::Thread::run (this=0x2f78120) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x2f78120) at thread/qthread_unix.cpp:298
#9  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f69b6ed2e9a in start_thread (arg=0x7f696b7fe700) at pthread_create.c:308
#11 0x00007f69ba7c14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f697d2f0700 (LWP 10540)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f69b1fd7dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f69b1fd7f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007f69b6ed2e9a in start_thread (arg=0x7f697d2f0700) at pthread_create.c:308
#5  0x00007f69ba7c14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f696a7fc700 (LWP 10543)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f69b74ac222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f69b74ac259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007f69b6ed2e9a in start_thread (arg=0x7f696a7fc700) at pthread_create.c:308
#5  0x00007f69ba7c14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f69bdec27c0 (LWP 10526)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f69bcd6a02e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  CollectionManager::~CollectionManager (this=0x2757b40, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:137
#10 0x00007f69bcd6a209 in CollectionManager::~CollectionManager (this=0x2757b40, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:145
#11 0x00007f69bcd684b6 in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:107
#12 0x00007f69bce9d4cf in App::~App (this=0x7fff986839c0, __in_chrg=<optimized out>) at ../../src/App.cpp:248
#13 0x0000000000408e5a in main (argc=1, argv=0x7fff98685e48) at ../../src/main.cpp:303

This bug may be a duplicate of or related to bug 285951.

Possible duplicates by query: bug 302727, bug 302467, bug 302141, bug 302113, bug 301107.

Reported using DrKonqi
Comment 1 Paul 2012-07-05 19:36:21 UTC
(In reply to comment #0)
> Application: amarok (2.5.0)
> KDE Platform Version: 4.8.4 (4.8.4)
> Qt Version: 4.8.1
> Operating System: Linux 3.2.0-26-generic x86_64
> Distribution: Ubuntu 12.04 LTS
> 
> -- Information about the crash:
> - What I was doing when the application crashed:
> - I run Amarok
> - I listened music(*mp3)
> - I exited out of Amarok and it crashed
> 
> The crash can be reproduced every time.
> 
> -- Backtrace:
> Application: Amarok (amarok), signal: Segmentation fault
> Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
> [Current thread is 1 (Thread 0x7f69bdec27c0 (LWP 10526))]
> 
> Thread 11 (Thread 0x7f698d55c700 (LWP 10531)):
> #0  0x00007f69ba7b5b03 in __GI___poll (fds=<optimized out>, nfds=<optimized
> out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
> #1  0x00007f69b53b5036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #2  0x00007f69b53b5164 in g_main_context_iteration () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #3  0x00007f69bb14c426 in QEventDispatcherGlib::processEvents
> (this=0x7f6988000920, flags=...) at kernel/qeventdispatcher_glib.cpp:426
> #4  0x00007f69bb11bc82 in QEventLoop::processEvents (this=<optimized out>,
> flags=...) at kernel/qeventloop.cpp:149
> #5  0x00007f69bb11bed7 in QEventLoop::exec (this=0x7f698d55bcd0, flags=...)
> at kernel/qeventloop.cpp:204
> #6  0x00007f69bb01afa7 in QThread::exec (this=<optimized out>) at
> thread/qthread.cpp:501
> #7  0x00007f69bb0fb9ff in QInotifyFileSystemWatcherEngine::run
> (this=0x2849f40) at io/qfilesystemwatcher_inotify.cpp:248
> #8  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x2849f40) at
> thread/qthread_unix.cpp:298
> #9  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
> #10 0x00007f69b6ed2e9a in start_thread (arg=0x7f698d55c700) at
> pthread_create.c:308
> #11 0x00007f69ba7c14bd in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
> #12 0x0000000000000000 in ?? ()
> 
> Thread 10 (Thread 0x7f6986f08700 (LWP 10532)):
> #0  0x00007f69b6ed4fc0 in __pthread_mutex_lock (mutex=0x7f6980000a80) at
> pthread_mutex_lock.c:113
> #1  0x00007f69b53f05a1 in g_mutex_lock () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #2  0x00007f69b53b4ff1 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #3  0x00007f69b53b5164 in g_main_context_iteration () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #4  0x00007f69bb14c426 in QEventDispatcherGlib::processEvents
> (this=0x7f69800008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
> #5  0x00007f69bb11bc82 in QEventLoop::processEvents (this=<optimized out>,
> flags=...) at kernel/qeventloop.cpp:149
> #6  0x00007f69bb11bed7 in QEventLoop::exec (this=0x7f6986f07d00, flags=...)
> at kernel/qeventloop.cpp:204
> #7  0x00007f69bb01afa7 in QThread::exec (this=<optimized out>) at
> thread/qthread.cpp:501
> #8  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x29c73b0) at
> thread/qthread_unix.cpp:298
> #9  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
> #10 0x00007f69b6ed2e9a in start_thread (arg=0x7f6986f08700) at
> pthread_create.c:308
> #11 0x00007f69ba7c14bd in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
> #12 0x0000000000000000 in ?? ()
> 
> Thread 9 (Thread 0x7f6985a68700 (LWP 10533)):
> #0  0x00007f69b6ed4fc0 in __pthread_mutex_lock (mutex=0x7f6978000a80) at
> pthread_mutex_lock.c:113
> #1  0x00007f69b53f05a1 in g_mutex_lock () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #2  0x00007f69b53b4851 in g_main_context_prepare () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #3  0x00007f69b53b4f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #4  0x00007f69b53b5164 in g_main_context_iteration () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #5  0x00007f69bb14c426 in QEventDispatcherGlib::processEvents
> (this=0x7f69780008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
> #6  0x00007f69bb11bc82 in QEventLoop::processEvents (this=<optimized out>,
> flags=...) at kernel/qeventloop.cpp:149
> #7  0x00007f69bb11bed7 in QEventLoop::exec (this=0x7f6985a67d00, flags=...)
> at kernel/qeventloop.cpp:204
> #8  0x00007f69bb01afa7 in QThread::exec (this=<optimized out>) at
> thread/qthread.cpp:501
> #9  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x2a32710) at
> thread/qthread_unix.cpp:298
> #10 0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
> #11 0x00007f69b6ed2e9a in start_thread (arg=0x7f6985a68700) at
> pthread_create.c:308
> #12 0x00007f69ba7c14bd in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
> #13 0x0000000000000000 in ?? ()
> 
> Thread 8 (Thread 0x7f6984e5c700 (LWP 10535)):
> #0  pthread_cond_wait@@GLIBC_2.3.2 () at
> ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
> #1  0x00007f69bb01e4db in wait (time=18446744073709551615, this=0x2a97130)
> at thread/qwaitcondition_unix.cpp:86
> #2  QWaitCondition::wait (this=<optimized out>, mutex=0x2a972b0,
> time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
> #3  0x00007f69b84670eb in
> ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned
> (this=0x2a96fe0, th=0x2a976d0) at
> ../../../threadweaver/Weaver/WeaverImpl.cpp:365
> #4  0x00007f69b84699db in ThreadWeaver::WorkingHardState::applyForWork
> (this=0x2a97380, th=0x2a976d0) at
> ../../../threadweaver/Weaver/WorkingHardState.cpp:71
> #5  0x00007f69b84699f4 in ThreadWeaver::WorkingHardState::applyForWork
> (this=0x2a97380, th=0x2a976d0) at
> ../../../threadweaver/Weaver/WorkingHardState.cpp:74
> #6  0x00007f69b84699f4 in ThreadWeaver::WorkingHardState::applyForWork
> (this=0x2a97380, th=0x2a976d0) at
> ../../../threadweaver/Weaver/WorkingHardState.cpp:74
> #7  0x00007f69b846884f in ThreadWeaver::ThreadRunHelper::run
> (this=0x7f6984e5bd20, parent=0x2a96fe0, th=0x2a976d0) at
> ../../../threadweaver/Weaver/Thread.cpp:87
> #8  0x00007f69b84688db in ThreadWeaver::Thread::run (this=0x2a976d0) at
> ../../../threadweaver/Weaver/Thread.cpp:142
> #9  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x2a976d0) at
> thread/qthread_unix.cpp:298
> #10 0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
> #11 0x00007f69b6ed2e9a in start_thread (arg=0x7f6984e5c700) at
> pthread_create.c:308
> #12 0x00007f69ba7c14bd in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
> #13 0x0000000000000000 in ?? ()
> 
> Thread 7 (Thread 0x7f697ed5b700 (LWP 10536)):
> #0  0x00007f69ba7b5b03 in __GI___poll (fds=<optimized out>, nfds=<optimized
> out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
> #1  0x00007f69b53b5036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #2  0x00007f69b53b5164 in g_main_context_iteration () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #3  0x00007f69bb14c426 in QEventDispatcherGlib::processEvents
> (this=0x7f69700008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
> #4  0x00007f69bb11bc82 in QEventLoop::processEvents (this=<optimized out>,
> flags=...) at kernel/qeventloop.cpp:149
> #5  0x00007f69bb11bed7 in QEventLoop::exec (this=0x7f697ed5acd0, flags=...)
> at kernel/qeventloop.cpp:204
> #6  0x00007f69bb01afa7 in QThread::exec (this=<optimized out>) at
> thread/qthread.cpp:501
> #7  0x00007f69bb0fb9ff in QInotifyFileSystemWatcherEngine::run
> (this=0x2f18320) at io/qfilesystemwatcher_inotify.cpp:248
> #8  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x2f18320) at
> thread/qthread_unix.cpp:298
> #9  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
> #10 0x00007f69b6ed2e9a in start_thread (arg=0x7f697ed5b700) at
> pthread_create.c:308
> #11 0x00007f69ba7c14bd in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
> #12 0x0000000000000000 in ?? ()
> 
> Thread 6 (Thread 0x7f697e132700 (LWP 10537)):
> #0  pthread_cond_wait@@GLIBC_2.3.2 () at
> ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
> #1  0x00007f69bb01e4db in wait (time=18446744073709551615, this=0x2a97130)
> at thread/qwaitcondition_unix.cpp:86
> #2  QWaitCondition::wait (this=<optimized out>, mutex=0x2a972b0,
> time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
> #3  0x00007f69b84670eb in
> ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned
> (this=0x2a96fe0, th=0x302d850) at
> ../../../threadweaver/Weaver/WeaverImpl.cpp:365
> #4  0x00007f69b84699db in ThreadWeaver::WorkingHardState::applyForWork
> (this=0x2a97380, th=0x302d850) at
> ../../../threadweaver/Weaver/WorkingHardState.cpp:71
> #5  0x00007f69b846884f in ThreadWeaver::ThreadRunHelper::run
> (this=0x7f697e131d20, parent=0x2a96fe0, th=0x302d850) at
> ../../../threadweaver/Weaver/Thread.cpp:87
> #6  0x00007f69b84688db in ThreadWeaver::Thread::run (this=0x302d850) at
> ../../../threadweaver/Weaver/Thread.cpp:142
> #7  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x302d850) at
> thread/qthread_unix.cpp:298
> #8  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
> #9  0x00007f69b6ed2e9a in start_thread (arg=0x7f697e132700) at
> pthread_create.c:308
> #10 0x00007f69ba7c14bd in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
> #11 0x0000000000000000 in ?? ()
> 
> Thread 5 (Thread 0x7f696bfff700 (LWP 10538)):
> #0  pthread_cond_wait@@GLIBC_2.3.2 () at
> ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
> #1  0x00007f69bb01e4db in wait (time=18446744073709551615, this=0x2a97130)
> at thread/qwaitcondition_unix.cpp:86
> #2  QWaitCondition::wait (this=<optimized out>, mutex=0x2a972b0,
> time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
> #3  0x00007f69b84670eb in
> ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned
> (this=0x2a96fe0, th=0x302e8a0) at
> ../../../threadweaver/Weaver/WeaverImpl.cpp:365
> #4  0x00007f69b84699db in ThreadWeaver::WorkingHardState::applyForWork
> (this=0x2a97380, th=0x302e8a0) at
> ../../../threadweaver/Weaver/WorkingHardState.cpp:71
> #5  0x00007f69b846884f in ThreadWeaver::ThreadRunHelper::run
> (this=0x7f696bffed20, parent=0x2a96fe0, th=0x302e8a0) at
> ../../../threadweaver/Weaver/Thread.cpp:87
> #6  0x00007f69b84688db in ThreadWeaver::Thread::run (this=0x302e8a0) at
> ../../../threadweaver/Weaver/Thread.cpp:142
> #7  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x302e8a0) at
> thread/qthread_unix.cpp:298
> #8  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
> #9  0x00007f69b6ed2e9a in start_thread (arg=0x7f696bfff700) at
> pthread_create.c:308
> #10 0x00007f69ba7c14bd in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
> #11 0x0000000000000000 in ?? ()
> 
> Thread 4 (Thread 0x7f696b7fe700 (LWP 10539)):
> #0  pthread_cond_wait@@GLIBC_2.3.2 () at
> ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
> #1  0x00007f69bb01e4db in wait (time=18446744073709551615, this=0x2a97130)
> at thread/qwaitcondition_unix.cpp:86
> #2  QWaitCondition::wait (this=<optimized out>, mutex=0x2a972b0,
> time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
> #3  0x00007f69b84670eb in
> ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned
> (this=0x2a96fe0, th=0x2f78120) at
> ../../../threadweaver/Weaver/WeaverImpl.cpp:365
> #4  0x00007f69b84699db in ThreadWeaver::WorkingHardState::applyForWork
> (this=0x2a97380, th=0x2f78120) at
> ../../../threadweaver/Weaver/WorkingHardState.cpp:71
> #5  0x00007f69b84699f4 in ThreadWeaver::WorkingHardState::applyForWork
> (this=0x2a97380, th=0x2f78120) at
> ../../../threadweaver/Weaver/WorkingHardState.cpp:74
> #6  0x00007f69b846884f in ThreadWeaver::ThreadRunHelper::run
> (this=0x7f696b7fdd20, parent=0x2a96fe0, th=0x2f78120) at
> ../../../threadweaver/Weaver/Thread.cpp:87
> #7  0x00007f69b84688db in ThreadWeaver::Thread::run (this=0x2f78120) at
> ../../../threadweaver/Weaver/Thread.cpp:142
> #8  0x00007f69bb01dfcb in QThreadPrivate::start (arg=0x2f78120) at
> thread/qthread_unix.cpp:298
> #9  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
> #10 0x00007f69b6ed2e9a in start_thread (arg=0x7f696b7fe700) at
> pthread_create.c:308
> #11 0x00007f69ba7c14bd in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
> #12 0x0000000000000000 in ?? ()
> 
> Thread 3 (Thread 0x7f697d2f0700 (LWP 10540)):
> #0  pthread_cond_wait@@GLIBC_2.3.2 () at
> ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
> #1  0x00007f69b1fd7dec in ?? () from
> /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
> #2  0x00007f69b1fd7f19 in ?? () from
> /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
> #3  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
> #4  0x00007f69b6ed2e9a in start_thread (arg=0x7f697d2f0700) at
> pthread_create.c:308
> #5  0x00007f69ba7c14bd in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
> #6  0x0000000000000000 in ?? ()
> 
> Thread 2 (Thread 0x7f696a7fc700 (LWP 10543)):
> #0  pthread_cond_wait@@GLIBC_2.3.2 () at
> ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
> #1  0x00007f69b74ac222 in ?? () from
> /usr/lib/x86_64-linux-gnu/libQtScript.so.4
> #2  0x00007f69b74ac259 in ?? () from
> /usr/lib/x86_64-linux-gnu/libQtScript.so.4
> #3  0x00007f69ac4b7b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
> #4  0x00007f69b6ed2e9a in start_thread (arg=0x7f696a7fc700) at
> pthread_create.c:308
> #5  0x00007f69ba7c14bd in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
> #6  0x0000000000000000 in ?? ()
> 
> Thread 1 (Thread 0x7f69bdec27c0 (LWP 10526)):
> [KCrash Handler]
> #6  0x0000000000000000 in ?? ()
> #7  0x00007f69bcd6a02e in
> qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=...,
> begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
> #8  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at
> /usr/include/qt4/QtCore/qalgorithms.h:330
> #9  CollectionManager::~CollectionManager (this=0x2757b40,
> __in_chrg=<optimized out>) at
> ../../src/core-impl/collections/support/CollectionManager.cpp:137
> #10 0x00007f69bcd6a209 in CollectionManager::~CollectionManager
> (this=0x2757b40, __in_chrg=<optimized out>) at
> ../../src/core-impl/collections/support/CollectionManager.cpp:145
> #11 0x00007f69bcd684b6 in CollectionManager::destroy () at
> ../../src/core-impl/collections/support/CollectionManager.cpp:107
> #12 0x00007f69bce9d4cf in App::~App (this=0x7fff986839c0,
> __in_chrg=<optimized out>) at ../../src/App.cpp:248
> #13 0x0000000000408e5a in main (argc=1, argv=0x7fff98685e48) at
> ../../src/main.cpp:303
> 
> This bug may be a duplicate of or related to bug 285951.
> 
> Possible duplicates by query: bug 302727, bug 302467, bug 302141, bug
> 302113, bug 301107.
> 
> Reported using DrKonqi
Comment 2 Jekyll Wu 2012-07-05 19:38:54 UTC

*** This bug has been marked as a duplicate of bug 285951 ***