Bug 302141 - Amarok crashed when I closed it
Summary: Amarok crashed when I closed it
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-18 18:11 UTC by jonny amrques
Modified: 2012-06-18 20:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonny amrques 2012-06-18 18:11:54 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-25-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed: I was using amarok, when I closed clicking on 'exit option', when the crash cames up. Some times anothers apps, like rekonq, has same kind crash when we close it.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f063350f780 (LWP 2292))]

Thread 12 (Thread 0x7f0604a8c700 (LWP 2297)):
#0  0x00007f062fe020bd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f062aa408cf in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f062aa05ba4 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f062aa05fd6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f062aa06164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f063079a426 in QEventDispatcherGlib::processEvents (this=0x7f0600000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f0630769c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f0630769ed7 in QEventLoop::exec (this=0x7f0604a8bdd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f0630668fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f06307499ff in QInotifyFileSystemWatcherEngine::run (this=0x17f7d60) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f063066bfcb in QThreadPrivate::start (arg=0x17f7d60) at thread/qthread_unix.cpp:298
#11 0x00007f062c523e9a in start_thread (arg=0x7f0604a8c700) at pthread_create.c:308
#12 0x00007f062fe0f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f05fe4d1700 (LWP 2298)):
#0  0x00007f062aa415d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f062aa057e2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f062aa05f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f062aa06164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f063079a426 in QEventDispatcherGlib::processEvents (this=0x7f05f80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f0630769c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f0630769ed7 in QEventLoop::exec (this=0x7f05fe4d0e00, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f0630668fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f063066bfcb in QThreadPrivate::start (arg=0x1a57770) at thread/qthread_unix.cpp:298
#9  0x00007f062c523e9a in start_thread (arg=0x7f05fe4d1700) at pthread_create.c:308
#10 0x00007f062fe0f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f05fd031700 (LWP 2299)):
#0  0x00007f062aa415d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f062aa0583b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f062aa05f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f062aa06164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f063079a426 in QEventDispatcherGlib::processEvents (this=0x7f05f00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f0630769c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f0630769ed7 in QEventLoop::exec (this=0x7f05fd030e00, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f0630668fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f063066bfcb in QThreadPrivate::start (arg=0x1a8dae0) at thread/qthread_unix.cpp:298
#9  0x00007f062c523e9a in start_thread (arg=0x7f05fd031700) at pthread_create.c:308
#10 0x00007f062fe0f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f05efbf4700 (LWP 2301)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f063066c4db in wait (time=18446744073709551615, this=0x1aba230) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1aba3b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f062dab70eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1aba0e0, th=0x1aba7d0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f062dab99db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1aba480, th=0x1aba7d0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f062dab99f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1aba480, th=0x1aba7d0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f062dab99f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1aba480, th=0x1aba7d0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f062dab884f in ThreadWeaver::ThreadRunHelper::run (this=0x7f05efbf3e20, parent=0x1aba0e0, th=0x1aba7d0) at ../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007f062dab88db in ThreadWeaver::Thread::run (this=0x1aba7d0) at ../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007f063066bfcb in QThreadPrivate::start (arg=0x1aba7d0) at thread/qthread_unix.cpp:298
#10 0x00007f062c523e9a in start_thread (arg=0x7f05efbf4700) at pthread_create.c:308
#11 0x00007f062fe0f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f05ef198700 (LWP 2302)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f063066c4db in wait (time=18446744073709551615, this=0x1aba230) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1aba3b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f062dab70eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1aba0e0, th=0x1ad5390) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f062dab99db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1aba480, th=0x1ad5390) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f062dab99f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1aba480, th=0x1ad5390) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f062dab99f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1aba480, th=0x1ad5390) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f062dab884f in ThreadWeaver::ThreadRunHelper::run (this=0x7f05ef197e20, parent=0x1aba0e0, th=0x1ad5390) at ../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007f062dab88db in ThreadWeaver::Thread::run (this=0x1ad5390) at ../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007f063066bfcb in QThreadPrivate::start (arg=0x1ad5390) at thread/qthread_unix.cpp:298
#10 0x00007f062c523e9a in start_thread (arg=0x7f05ef198700) at pthread_create.c:308
#11 0x00007f062fe0f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f05ee997700 (LWP 2303)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f063066c4db in wait (time=18446744073709551615, this=0x1aba230) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1aba3b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f062dab70eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1aba0e0, th=0x1aceb30) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f062dab99db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1aba480, th=0x1aceb30) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f062dab884f in ThreadWeaver::ThreadRunHelper::run (this=0x7f05ee996e20, parent=0x1aba0e0, th=0x1aceb30) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f062dab88db in ThreadWeaver::Thread::run (this=0x1aceb30) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f063066bfcb in QThreadPrivate::start (arg=0x1aceb30) at thread/qthread_unix.cpp:298
#8  0x00007f062c523e9a in start_thread (arg=0x7f05ee997700) at pthread_create.c:308
#9  0x00007f062fe0f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f05eda9c700 (LWP 2309)):
#0  0x00007f062c525fc0 in __pthread_mutex_lock (mutex=0x7f05d8000a60) at pthread_mutex_lock.c:113
#1  0x00007f062aa415a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f062aa05c36 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f062aa060a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f062aa06164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f063079a426 in QEventDispatcherGlib::processEvents (this=0x7f05d80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f0630769c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f0630769ed7 in QEventLoop::exec (this=0x7f05eda9bdd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f0630668fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f06307499ff in QInotifyFileSystemWatcherEngine::run (this=0x1808010) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f063066bfcb in QThreadPrivate::start (arg=0x1808010) at thread/qthread_unix.cpp:298
#11 0x00007f062c523e9a in start_thread (arg=0x7f05eda9c700) at pthread_create.c:308
#12 0x00007f062fe0f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f05dffff700 (LWP 2310)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f063066c4db in wait (time=18446744073709551615, this=0x1aba230) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1aba3b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f062dab70eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1aba0e0, th=0x2010660) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f062dab99db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1aba480, th=0x2010660) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f062dab884f in ThreadWeaver::ThreadRunHelper::run (this=0x7f05dfffee20, parent=0x1aba0e0, th=0x2010660) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f062dab88db in ThreadWeaver::Thread::run (this=0x2010660) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f063066bfcb in QThreadPrivate::start (arg=0x2010660) at thread/qthread_unix.cpp:298
#8  0x00007f062c523e9a in start_thread (arg=0x7f05dffff700) at pthread_create.c:308
#9  0x00007f062fe0f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f05df5e1700 (LWP 2311)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f0627641dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f0627641f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f062c523e9a in start_thread (arg=0x7f05df5e1700) at pthread_create.c:308
#4  0x00007f062fe0f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f05ddd4e700 (LWP 2328)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f062cafd222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f062cafd259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f062c523e9a in start_thread (arg=0x7f05ddd4e700) at pthread_create.c:308
#4  0x00007f062fe0f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f05b7be4700 (LWP 2334)):
#0  0x00007f062c525f69 in __pthread_mutex_lock (mutex=0x7f05f4004ae0) at pthread_mutex_lock.c:92
#1  0x00007f062aa415a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f062aa05ff1 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f062aa06164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f062aa061b1 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f062aa279e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f062c523e9a in start_thread (arg=0x7f05b7be4700) at pthread_create.c:308
#7  0x00007f062fe0f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f063350f780 (LWP 2292)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f06323b302e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  CollectionManager::~CollectionManager (this=0x16e3870, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:137
#10 0x00007f06323b3209 in CollectionManager::~CollectionManager (this=0x16e3870, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:145
#11 0x00007f06323b14b6 in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:107
#12 0x00007f06324e64cf in App::~App (this=0x7fff15b69090, __in_chrg=<optimized out>) at ../../src/App.cpp:248
#13 0x0000000000408e5a in main (argc=1, argv=0x7fff15b6b518) at ../../src/main.cpp:303

Possible duplicates by query: bug 302113, bug 301107, bug 301012, bug 300384, bug 300194.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-06-18 20:15:11 UTC

*** This bug has been marked as a duplicate of bug 285951 ***