Bug 302558 - Allow thinner sidebars
Summary: Allow thinner sidebars
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Ergonomy (show other bugs)
Version: 4.1.0
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-26 12:46 UTC by Dotan Cohen
Modified: 2022-01-21 07:56 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2012-06-26 12:46:55 UTC
Currently Digikam has a minimum size for the sidebars. Anything thinner and the sidebar collapses. This value is about three times to big, it leaves a huge wasted space when I am trying to tag photos and leave the tag sidebar open. Please reduce the minimum size for the sidebar to about one third or even one quarter of its current value.

Thank you!
Comment 1 caulier.gilles 2013-12-14 22:39:26 UTC
This entry still valid with digiKam 3.5.0 ?

Gilles Caulier
Comment 2 Shubham Patel 2014-02-24 12:01:35 UTC
Is this entry valid for digiKam 4.0.0? Is it solved?
Comment 3 Cruceru Calin-Cristian 2014-02-24 12:14:52 UTC
I don't know what was the minimum size in 2.6, but certainly in 4.0.0 it is still a little bit too large this minimum size.
Comment 4 caulier.gilles 2014-02-24 13:18:37 UTC
Size do not depand only of widget size. Text embeded in widget (as with label) has an effect to widget size, especially with translations. 

Developers test in English only. Applying translation to GUI will have effect to widget layout. Translators must take a care about

Gilles Caulier
Comment 5 caulier.gilles 2014-08-30 21:41:56 UTC
This file still valid using last digiKam 4.2.0 ?

Gilles Caulier
Comment 6 Dotan Cohen 2014-09-02 18:11:33 UTC
I'm having a hard time getting Digikam 4.2 installed, but on 4.1 the issue is still valid. Thanks, Gilles!
Comment 7 caulier.gilles 2016-07-16 12:54:16 UTC

*** This bug has been marked as a duplicate of bug 359959 ***
Comment 8 caulier.gilles 2022-01-21 07:38:28 UTC
Git commit d5e5a54950406ab5ab80a025de20adb2e566fa04 by Gilles Caulier.
Committed on 21/01/2022 at 07:37.
Pushed by cgilles into branch 'master'.

Fix sidebar horizontal layout to give preference width of canvas of digiKam image editor.

M  +1    -1    core/utilities/imageeditor/main/imagewindow_setup.cpp

https://invent.kde.org/graphics/digikam/commit/d5e5a54950406ab5ab80a025de20adb2e566fa04
Comment 9 caulier.gilles 2022-01-21 07:38:37 UTC
Git commit 3b748f8369a0760d849bd5cca63342e8f57c33ab by Gilles Caulier.
Committed on 21/01/2022 at 07:31.
Pushed by cgilles into branch 'master'.

Fix sidebar horizontal layout to give preference width of canvas (image editor) and stack (album-view).
When a sidebar is collapsed, if the opposite sidebar is open, the central view strech the free space instead to reajust the width of visible sidebar.
FIXED-IN: 7.6.0

M  +1    -0    core/app/views/stack/itemiconview.cpp
M  +1    -1    core/showfoto/main/showfoto_setup.cpp

https://invent.kde.org/graphics/digikam/commit/3b748f8369a0760d849bd5cca63342e8f57c33ab
Comment 10 caulier.gilles 2022-01-21 07:56:40 UTC
Git commit 2ff7af593b3b8cce90620d1847d8acbabe68b5f2 by Gilles Caulier.
Committed on 21/01/2022 at 07:54.
Pushed by cgilles into branch 'master'.

Fix sidebar layout preference in LightTable and Import Tool

M  +1    -3    core/libs/tags/manager/tagsmanager.cpp
M  +1    -1    core/utilities/import/main/importui.cpp
M  +1    -0    core/utilities/lighttable/lighttablewindow_setup.cpp

https://invent.kde.org/graphics/digikam/commit/2ff7af593b3b8cce90620d1847d8acbabe68b5f2