Bug 301678 - kmail crash after start up - segmentation fault
Summary: kmail crash after start up - segmentation fault
Status: RESOLVED DUPLICATE of bug 301625
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-11 18:53 UTC by Phillip Renner
Modified: 2012-06-12 12:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phillip Renner 2012-06-11 18:53:36 UTC
Application: kmail (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4) "release 511"
Qt Version: 4.8.2
Operating System: Linux 3.1.10-1.9-default i686
Distribution: "openSUSE 12.1 (i586)"

-- Information about the crash:
- kmail crashes after startup
- no crash when I'm offline and no folder (imap) or mail content is loaded
- crash as soon as I move to local folder or go online and open imap-folder
- thanks a lot (Danke)

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0xb17bb980 (LWP 8085))]

Thread 4 (Thread 0xb02b0b40 (LWP 8098)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb585ca4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5e6730c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb3854189 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb38541cf in ?? () from /usr/lib/libQtWebKit.so.4
#5  0xb5858e32 in start_thread () from /lib/libpthread.so.0
#6  0xb5e599de in clone () from /lib/libc.so.6

Thread 3 (Thread 0xaf987b40 (LWP 8099)):
#0  0xb4576e6d in clock_gettime () from /lib/librt.so.1
#1  0xb6bd1c35 in do_gettime (frac=0xaf986ff0, sec=0xaf986fe8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6cbb486 in QTimerInfoList::updateCurrentTime (this=0xaf001abc) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb6cbb7ea in QTimerInfoList::timerWait (this=0xaf001abc, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0xb6cb9fe3 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xaf9870dc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb44bd44c in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#7  0xb44be207 in ?? () from /usr/lib/libglib-2.0.so.0
#8  0xb44be7fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#9  0xb6cbab47 in QEventDispatcherGlib::processEvents (this=0xaf000468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#10 0xb6c8664d in QEventLoop::processEvents (this=0xaf987270, flags=...) at kernel/qeventloop.cpp:149
#11 0xb6c868e9 in QEventLoop::exec (this=0xaf987270, flags=...) at kernel/qeventloop.cpp:204
#12 0xb6b6fdac in QThread::exec (this=0x84cf2c8) at thread/qthread.cpp:501
#13 0xb6b6fe9b in QThread::run (this=0x84cf2c8) at thread/qthread.cpp:568
#14 0xb6b73290 in QThreadPrivate::start (arg=0x84cf2c8) at thread/qthread_unix.cpp:307
#15 0xb5858e32 in start_thread () from /lib/libpthread.so.0
#16 0xb5e599de in clone () from /lib/libc.so.6

Thread 2 (Thread 0xadbc8b40 (LWP 8319)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb585ce04 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5e67364 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb6b7378f in wait (time=30000, this=0x879fc60) at thread/qwaitcondition_unix.cpp:84
#4  QWaitCondition::wait (this=0x8715a50, mutex=0x8715a4c, time=30000) at thread/qwaitcondition_unix.cpp:158
#5  0xb6b65c04 in QThreadPoolThread::run (this=0x87a8460) at concurrent/qthreadpool.cpp:141
#6  0xb6b73290 in QThreadPrivate::start (arg=0x87a8460) at thread/qthread_unix.cpp:307
#7  0xb5858e32 in start_thread () from /lib/libpthread.so.0
#8  0xb5e599de in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb17bb980 (LWP 8085)):
[KCrash Handler]
#7  deref (this=0xb26015ac) at /usr/include/QtCore/qatomic_i386.h:132
#8  ~KSharedPtr (this=0x8490670, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/ksharedptr.h:90
#9  ~ParsingData (this=0x8490670, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:40
#10 qThreadStorage_deleteData<KTraderParse::ParsingData> (d=0x8490670) at /usr/include/QtCore/qthreadstorage.h:97
#11 QThreadStorage<KTraderParse::ParsingData*>::deleteData (x=0x8490670) at /usr/include/QtCore/qthreadstorage.h:140
#12 0xb6b70f42 in QThreadStorageData::set (this=0x86d98f8, p=0x8860cb0) at thread/qthreadstorage.cpp:165
#13 0xb717d1d9 in qThreadStorage_setLocalData<KTraderParse::ParsingData> (d=<optimized out>, t=<optimized out>) at /usr/include/QtCore/qthreadstorage.h:92
#14 setLocalData (t=0x8860cb0, this=<optimized out>) at /usr/include/QtCore/qthreadstorage.h:155
#15 KTraderParse::parseConstraints (_constr=...) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:55
#16 0xb717c655 in applyConstraints (constraint=..., lst=...) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/kservicetypetrader.cpp:59
#17 KServiceTypeTrader::applyConstraints (lst=..., constraint=...) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/kservicetypetrader.cpp:53
#18 0xb717c84f in KServiceTypeTrader::defaultOffers (this=0x83ac888, serviceType=..., constraint=...) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/kservicetypetrader.cpp:127
#19 0xb717d060 in KServiceTypeTrader::query (this=0x83ac888, serviceType=..., constraint=...) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/kservicetypetrader.cpp:141
#20 0xb263ae7f in KEmoticonsPrivate::loadServiceList (this=0x8fb1ba0) at /usr/src/debug/kdelibs-4.8.4/kutils/kemoticons/kemoticons.cpp:71
#21 0xb263b001 in KEmoticons::KEmoticons (this=0x87927b0) at /usr/src/debug/kdelibs-4.8.4/kutils/kemoticons/kemoticons.cpp:121
#22 0xb4970d55 in operator-> (this=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.4/kpimutils/linklocator.cpp:56
#23 KPIMUtils::LinkLocator::convertToHtml (plainText=..., flags=11, maxUrlLen=4096, maxAddressLen=255) at /usr/src/debug/kdepimlibs-4.8.4/kpimutils/linklocator.cpp:426
#24 0xb48b62d8 in MessageViewer::ObjectTreeParser::quotedHTML (this=0xbfe06670, s=..., decorate=true) at /usr/src/debug/kdepim-4.8.4/messageviewer/objecttreeparser.cpp:3254
#25 0xb48c1ff6 in MessageViewer::ObjectTreeParser::writeBodyStr (this=0xbfe06670, aStr=..., aCodec=0x805b4d0, fromAddress=..., inlineSignatureState=@0xbfe06478, inlineEncryptionState=@0xbfe0647c, decorate=true) at /usr/src/debug/kdepim-4.8.4/messageviewer/objecttreeparser.cpp:3106
#26 0xb48c2611 in MessageViewer::ObjectTreeParser::writeBodyString (this=0xbfe06670, bodyString=..., fromAddress=..., codec=0x805b4d0, result=..., decorate=true) at /usr/src/debug/kdepim-4.8.4/messageviewer/objecttreeparser.cpp:2175
#27 0xb48c9a30 in MessageViewer::ObjectTreeParser::processTextPlainSubtype (this=0xbfe06670, curNode=0x8942960, result=...) at /usr/src/debug/kdepim-4.8.4/messageviewer/objecttreeparser.cpp:1422
#28 0xb487548b in (anonymous namespace)::TextPlainBodyPartFormatter::process (this=0x883a5b0, otp=0xbfe06670, node=0x8942960, result=...) at /usr/src/debug/kdepim-4.8.4/messageviewer/bodypartformatter.cpp:108
#29 0xb48c3297 in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=0xbfe06670, node=0x8942960) at /usr/src/debug/kdepim-4.8.4/messageviewer/objecttreeparser.cpp:353
#30 0xb48c3b8b in MessageViewer::ObjectTreeParser::stdChildHandling (this=0xbfe06898, child=0x8942960) at /usr/src/debug/kdepim-4.8.4/messageviewer/objecttreeparser.cpp:1445
#31 0xb48c3d85 in MessageViewer::ObjectTreeParser::processMultiPartAlternativeSubtype (this=0xbfe06898, node=0x8ed0a20) at /usr/src/debug/kdepim-4.8.4/messageviewer/objecttreeparser.cpp:1531
#32 0xb487551b in (anonymous namespace)::MultiPartAlternativeBodyPartFormatter::process (this=0x894fde8, otp=0xbfe06898, node=0x8ed0a20, result=...) at /usr/src/debug/kdepim-4.8.4/messageviewer/bodypartformatter.cpp:120
#33 0xb48c3297 in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=0xbfe06898, node=0x8ed0a20) at /usr/src/debug/kdepim-4.8.4/messageviewer/objecttreeparser.cpp:353
#34 0xb48c4046 in MessageViewer::ObjectTreeParser::parseObjectTree (this=0xbfe06898, node=0x8ed0a20) at /usr/src/debug/kdepim-4.8.4/messageviewer/objecttreeparser.cpp:266
#35 0xb48f7730 in MessageViewer::ViewerPrivate::parseContent (this=0x84c1b00, content=0x8ed0a20) at /usr/src/debug/kdepim-4.8.4/messageviewer/viewer_p.cpp:918
#36 0xb48f8bf7 in MessageViewer::ViewerPrivate::displayMessage (this=0x84c1b00) at /usr/src/debug/kdepim-4.8.4/messageviewer/viewer_p.cpp:790
#37 0xb48f9440 in MessageViewer::ViewerPrivate::updateReaderWin (this=0x84c1b00) at /usr/src/debug/kdepim-4.8.4/messageviewer/viewer_p.cpp:2084
#38 0xb490152d in MessageViewer::ViewerPrivate::qt_static_metacall (_o=0x84c1b00, _c=QMetaObject::InvokeMetaMethod, _id=29, _a=0xbfe06b40) at /usr/src/debug/kdepim-4.8.4/build/messageviewer/viewer_p.moc:208
#39 0xb6c9e69f in QMetaObject::activate (sender=0x84c1b44, m=0xb6de64d8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3556
#40 0xb6cf2125 in QTimer::timeout (this=0x84c1b44) at .moc/release-shared/moc_qtimer.cpp:148
#41 0xb6ca7656 in QTimer::timerEvent (this=0x84c1b44, e=0xbfe07058) at kernel/qtimer.cpp:280
#42 0xb6ca2b74 in QObject::event (this=0x84c1b44, e=0xbfe07058) at kernel/qobject.cpp:1166
#43 0xb616e404 in notify_helper (e=0xbfe07058, receiver=0x84c1b44, this=0x80950c0) at kernel/qapplication.cpp:4551
#44 QApplicationPrivate::notify_helper (this=0x80950c0, receiver=0x84c1b44, e=0xbfe07058) at kernel/qapplication.cpp:4523
#45 0xb6173743 in QApplication::notify (this=0xbfe07058, receiver=0x84c1b44, e=0xbfe07058) at kernel/qapplication.cpp:4280
#46 0xb74d6491 in KApplication::notify (this=0xbfe073cc, receiver=0x84c1b44, event=0xbfe07058) at /usr/src/debug/kdelibs-4.8.4/kdeui/kernel/kapplication.cpp:311
#47 0xb6c87dce in QCoreApplication::notifyInternal (this=0xbfe073cc, receiver=0x84c1b44, event=0xbfe07058) at kernel/qcoreapplication.cpp:915
#48 0xb6cbcbdf in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#49 QTimerInfoList::activateTimers (this=0x80972c4) at kernel/qeventdispatcher_unix.cpp:626
#50 0xb6cba2c8 in timerSourceDispatch (source=0x8097290) at kernel/qeventdispatcher_glib.cpp:186
#51 timerSourceDispatch (source=0x8097290) at kernel/qeventdispatcher_glib.cpp:180
#52 0xb44bde2f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#53 0xb44be560 in ?? () from /usr/lib/libglib-2.0.so.0
#54 0xb44be7fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#55 0xb6cbaae7 in QEventDispatcherGlib::processEvents (this=0x8051388, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#56 0xb622240a in QGuiEventDispatcherGlib::processEvents (this=0x8051388, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#57 0xb6c8664d in QEventLoop::processEvents (this=0xbfe072f4, flags=...) at kernel/qeventloop.cpp:149
#58 0xb6c868e9 in QEventLoop::exec (this=0xbfe072f4, flags=...) at kernel/qeventloop.cpp:204
#59 0xb6c8be2a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#60 0xb616c2a4 in QApplication::exec () at kernel/qapplication.cpp:3812
#61 0x0804a496 in main (argc=) at /usr/src/debug/kdepim-4.8.4/kmail/main.cpp:145

This bug may be a duplicate of or related to bug 301625.

Possible duplicates by query: bug 301625, bug 301602, bug 300203, bug 277705.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-06-12 12:02:16 UTC

*** This bug has been marked as a duplicate of bug 301625 ***