Bug 301625 - kmail crashes during startup (segfault)
Summary: kmail crashes during startup (segfault)
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 301678 301710 302019 302166 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-11 08:03 UTC by konold
Modified: 2012-07-03 09:36 UTC (History)
19 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.5


Attachments
New crash information added by DrKonqi (9.75 KB, text/plain)
2012-06-11 10:16 UTC, Vojtěch Zeisek
Details
New crash information added by DrKonqi (7.86 KB, text/plain)
2012-06-11 10:39 UTC, Juergen Spitzmueller
Details
New crash information added by DrKonqi (9.37 KB, text/plain)
2012-06-11 13:13 UTC, giuliano.torrente
Details
New crash information added by DrKonqi (8.09 KB, text/plain)
2012-06-11 16:33 UTC, Rudy Raab
Details
New crash information added by DrKonqi (7.89 KB, text/plain)
2012-06-12 09:59 UTC, alexander.willand
Details
New crash information added by DrKonqi (7.68 KB, text/plain)
2012-06-12 19:52 UTC, Eric Seynaeve
Details
New crash information added by DrKonqi (9.49 KB, text/plain)
2012-06-13 01:34 UTC, Allan Mau
Details
New crash information added by DrKonqi (7.91 KB, text/plain)
2012-06-13 14:07 UTC, Cyrille Dunant
Details
crashreport (8.06 KB, application/octet-stream)
2012-06-18 10:18 UTC, Axel Braun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description konold 2012-06-11 08:03:04 UTC
Application: kmail (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4) "release 511"
Qt Version: 4.8.2
Operating System: Linux 3.1.10-43-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- zypper up
- startin kmail
- crashes immediately after the hints dialog

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6f7dc95780 (LWP 9249))]

Thread 6 (Thread 0x7f6f5f453700 (LWP 9254)):
#0  0x00007f6f78dc9e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6f6f463c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f6f6f463c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f6f78dc5f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f6f7afc110d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f6f5eb52700 (LWP 9255)):
#0  0x00007f6f78dc9109 in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f6f7317cf81 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6f7c61fe36 in QEventDispatcherGlib::processEvents (this=0x7f6f580008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#3  0x00007f6f7c5ef842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f6f7c5efa97 in QEventLoop::exec (this=0x7f6f5eb51e00, flags=...) at kernel/qeventloop.cpp:204
#5  0x00007f6f7c4ef5f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#6  0x00007f6f7c4f261b in QThreadPrivate::start (arg=0xa583a0) at thread/qthread_unix.cpp:307
#7  0x00007f6f78dc5f05 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f6f7afc110d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f6f5d030700 (LWP 9256)):
#0  0x00007f6f78dca1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6f7c4f2a8f in wait (time=30000, this=0xc01280) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xc011f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6f7c4e5e9f in QThreadPoolThread::run (this=0xc15230) at concurrent/qthreadpool.cpp:141
#4  0x00007f6f7c4f261b in QThreadPrivate::start (arg=0xc15230) at thread/qthread_unix.cpp:307
#5  0x00007f6f78dc5f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6f7afc110d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f6f165d1700 (LWP 9268)):
#0  0x00007f6f78dca1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6f7c4f2a8f in wait (time=30000, this=0xdcb320) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xdcb2c8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6f7c4e5e9f in QThreadPoolThread::run (this=0xdcb5f0) at concurrent/qthreadpool.cpp:141
#4  0x00007f6f7c4f261b in QThreadPrivate::start (arg=0xdcb5f0) at thread/qthread_unix.cpp:307
#5  0x00007f6f78dc5f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6f7afc110d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f6f15917700 (LWP 9272)):
#0  0x00007f6f78dca1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6f7c4f2a8f in wait (time=30000, this=0x17cde60) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x17ce1d8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6f7c4e5e9f in QThreadPoolThread::run (this=0x17cb670) at concurrent/qthreadpool.cpp:141
#4  0x00007f6f7c4f261b in QThreadPrivate::start (arg=0x17cb670) at thread/qthread_unix.cpp:307
#5  0x00007f6f78dc5f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6f7afc110d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f6f7dc95780 (LWP 9249)):
[KCrash Handler]
#6  deref (this=0x7f6f6cabda18) at /usr/include/QtCore/qatomic_x86_64.h:133
#7  ~KSharedPtr (this=0xa749d0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/ksharedptr.h:90
#8  ~ParsingData (this=0xa749d0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:40
#9  qThreadStorage_deleteData<KTraderParse::ParsingData> (d=0xa749d0) at /usr/include/QtCore/qthreadstorage.h:97
#10 QThreadStorage<KTraderParse::ParsingData*>::deleteData (x=0xa749d0) at /usr/include/QtCore/qthreadstorage.h:140
#11 0x00007f6f7c4f05ed in QThreadStorageData::set (this=0x184c240, p=0x18849a0) at thread/qthreadstorage.cpp:165
#12 0x00007f6f7d111d77 in qThreadStorage_setLocalData<KTraderParse::ParsingData> (d=<optimized out>, t=<optimized out>) at /usr/include/QtCore/qthreadstorage.h:92
#13 setLocalData (t=0x18849a0, this=<optimized out>) at /usr/include/QtCore/qthreadstorage.h:155
#14 KTraderParse::parseConstraints (_constr=...) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:55
#15 0x00007f6f7d1112e2 in applyConstraints (constraint=<optimized out>, lst=...) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/kservicetypetrader.cpp:59
#16 KServiceTypeTrader::applyConstraints (lst=..., constraint=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/kservicetypetrader.cpp:53
#17 0x00007f6f7d1114ce in KServiceTypeTrader::defaultOffers (this=<optimized out>, serviceType=<optimized out>, constraint=...) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/kservicetypetrader.cpp:127
#18 0x00007f6f7d111c21 in KServiceTypeTrader::query (this=0x858470, serviceType=..., constraint=...) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/kservicetypetrader.cpp:141
#19 0x00007f6f6cef79de in KEmoticonsPrivate::loadServiceList (this=0x1884070) at /usr/src/debug/kdelibs-4.8.4/kutils/kemoticons/kemoticons.cpp:71
#20 0x00007f6f6cef7b3a in KEmoticons::KEmoticons (this=0x184c030) at /usr/src/debug/kdelibs-4.8.4/kutils/kemoticons/kemoticons.cpp:121
#21 0x00007f6f74837502 in operator-> (this=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.4/kpimutils/linklocator.cpp:56
#22 KPIMUtils::LinkLocator::convertToHtml (plainText=<optimized out>, flags=<optimized out>, maxUrlLen=<optimized out>, maxAddressLen=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.4/kpimutils/linklocator.cpp:426
#23 0x00007f6f74356d04 in MessageViewer::strToHtml (str=<optimized out>, flags=<optimized out>) at /usr/src/debug/kdepim-4.8.4/messageviewer/headerstyle.cpp:84
#24 0x00007f6f74356fc0 in MessageViewer::subjectString (message=0x1536cf0, flags=3) at /usr/src/debug/kdepim-4.8.4/messageviewer/headerstyle.cpp:111
#25 0x00007f6f7435f29c in MessageViewer::FancyHeaderStyle::format (this=0xa94130, message=0x1536cf0) at /usr/src/debug/kdepim-4.8.4/messageviewer/headerstyle.cpp:612
#26 0x00007f6f743ae9df in MessageViewer::ViewerPrivate::writeMsgHeader (this=0x9fabf0, aMsg=0x1536cf0, vCardNode=<optimized out>, topLevel=true) at /usr/src/debug/kdepim-4.8.4/messageviewer/viewer_p.cpp:968
#27 0x00007f6f743bb8bd in MessageViewer::ViewerPrivate::parseContent (this=0x9fabf0, content=0x1536cf0) at /usr/src/debug/kdepim-4.8.4/messageviewer/viewer_p.cpp:907
#28 0x00007f6f743bcd1e in MessageViewer::ViewerPrivate::displayMessage (this=0x9fabf0) at /usr/src/debug/kdepim-4.8.4/messageviewer/viewer_p.cpp:790
#29 0x00007f6f743bd532 in MessageViewer::ViewerPrivate::updateReaderWin (this=0x9fabf0) at /usr/src/debug/kdepim-4.8.4/messageviewer/viewer_p.cpp:2084
#30 0x00007f6f743c4c5a in MessageViewer::ViewerPrivate::qt_static_metacall (_o=0x9fabf0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdepim-4.8.4/build/messageviewer/viewer_p.moc:208
#31 0x00007f6f7c604c41 in QMetaObject::activate (sender=0x9fac78, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3556
#32 0x00007f6f7c609b39 in QObject::event (this=0x9fac78, e=<optimized out>) at kernel/qobject.cpp:1166
#33 0x00007f6f7b973fe4 in notify_helper (e=0x7fff55aa00f0, receiver=0x9fac78, this=0x6571e0) at kernel/qapplication.cpp:4551
#34 QApplicationPrivate::notify_helper (this=0x6571e0, receiver=0x9fac78, e=0x7fff55aa00f0) at kernel/qapplication.cpp:4523
#35 0x00007f6f7b978db3 in QApplication::notify (this=0x7fff55aa0520, receiver=0x9fac78, e=0x7fff55aa00f0) at kernel/qapplication.cpp:4412
#36 0x00007f6f7d6a7746 in KApplication::notify (this=0x7fff55aa0520, receiver=0x9fac78, event=0x7fff55aa00f0) at /usr/src/debug/kdelibs-4.8.4/kdeui/kernel/kapplication.cpp:311
#37 0x00007f6f7c5f0d0c in QCoreApplication::notifyInternal (this=0x7fff55aa0520, receiver=0x9fac78, event=0x7fff55aa00f0) at kernel/qcoreapplication.cpp:915
#38 0x00007f6f7c621be8 in sendEvent (event=0x7fff55aa00f0, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#39 QTimerInfoList::activateTimers (this=0x65aaf0) at kernel/qeventdispatcher_unix.cpp:626
#40 0x00007f6f7c61f59d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#41 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#42 0x00007f6f7317c58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#43 0x00007f6f7317cd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#44 0x00007f6f7317cf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#45 0x00007f6f7c61fdcf in QEventDispatcherGlib::processEvents (this=0x60b000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#46 0x00007f6f7ba1769e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007f6f7c5ef842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#48 0x00007f6f7c5efa97 in QEventLoop::exec (this=0x7fff55aa0400, flags=...) at kernel/qeventloop.cpp:204
#49 0x00007f6f7c5f48b5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#50 0x0000000000402df3 in ?? ()
#51 0x00007f6f7af0723d in __libc_start_main () from /lib64/libc.so.6
#52 0x00000000004032d5 in _start ()

Possible duplicates by query: bug 301602, bug 300203, bug 277705.

Reported using DrKonqi
Comment 1 Vojtěch Zeisek 2012-06-11 10:16:51 UTC
Created attachment 71728 [details]
New crash information added by DrKonqi

kmail (4.8.4) on KDE Platform 4.8.4 (4.8.4) "release 511" using Qt 4.8.2

KMail crashes during startup after upgrade to KDE 4.8.4.

-- Backtrace (Reduced):
#7  ~KSharedPtr (this=0xb68be0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/ksharedptr.h:90
#8  ~ParsingData (this=0xb68be0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:40
#9  qThreadStorage_deleteData<KTraderParse::ParsingData> (d=0xb68be0) at /usr/include/QtCore/qthreadstorage.h:97
#10 QThreadStorage<KTraderParse::ParsingData*>::deleteData (x=0xb68be0) at /usr/include/QtCore/qthreadstorage.h:140
#11 0x00007f80eb07a5ed in QThreadStorageData::set (this=0x1334620, p=0x8e65f0) at thread/qthreadstorage.cpp:165
Comment 2 Juergen Spitzmueller 2012-06-11 10:39:29 UTC
Created attachment 71729 [details]
New crash information added by DrKonqi

kmail (4.8.4) on KDE Platform 4.8.4 (4.8.4) "release 511" using Qt 4.8.2

- What I was doing when the application crashed:

The crash happens immediately when I start KMail (this is since I upgraded to KDE 4.8.4/Qt 4.8.2).

With Kontact, the mail component does not crash immediately, but Kontact always crashes when I try to open the message composer (i.e, new mail or reply to mail).

-- Backtrace (Reduced):
#7  ~KSharedPtr (this=0x839f890, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/ksharedptr.h:90
#8  ~ParsingData (this=0x839f890, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:40
#9  qThreadStorage_deleteData<KTraderParse::ParsingData> (d=0x839f890) at /usr/include/QtCore/qthreadstorage.h:97
#10 QThreadStorage<KTraderParse::ParsingData*>::deleteData (x=0x839f890) at /usr/include/QtCore/qthreadstorage.h:140
#11 0xb6b6ef42 in QThreadStorageData::set (this=0x98b3320, p=0x98b3528) at thread/qthreadstorage.cpp:165
Comment 3 Axel Braun 2012-06-11 10:46:00 UTC
same Problem here..... KDE 4.8.4, 86_x64
Comment 4 giuliano.torrente 2012-06-11 13:13:12 UTC
Created attachment 71735 [details]
New crash information added by DrKonqi

kmail (4.8.4) on KDE Platform 4.8.4 (4.8.4) "release 511" using Qt 4.8.2

Application: kmail (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4) "release 511"
Qt Version: 4.8.2
Operating System: Linux 3.1.10-43-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- zypper up
- startin kmail
- crashes immediately after the hints dialog

-- Backtrace (Reduced):
#7  ~KSharedPtr (this=0xb296a0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/ksharedptr.h:90
#8  ~ParsingData (this=0xb296a0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:40
#9  qThreadStorage_deleteData<KTraderParse::ParsingData> (d=0xb296a0) at /usr/include/QtCore/qthreadstorage.h:97
#10 QThreadStorage<KTraderParse::ParsingData*>::deleteData (x=0xb296a0) at /usr/include/QtCore/qthreadstorage.h:140
#11 0x00007f00a39c25ed in QThreadStorageData::set (this=0x39d7180, p=0x39e7bc0) at thread/qthreadstorage.cpp:165
Comment 5 Rudy Raab 2012-06-11 16:33:51 UTC
Created attachment 71741 [details]
New crash information added by DrKonqi

kmail (4.8.4) on KDE Platform 4.8.4 (4.8.4) "release 511" using Qt 4.8.2

- What I was doing when the application crashed:

Same as everyone else: merely opened kmail after update to 4.8.4. Another related issue: Kontact does not crash when opening, but crashes when I click "reply" on a mail.

-- Backtrace (Reduced):
#7  ~KSharedPtr (this=0xb3bd80, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/ksharedptr.h:90
#8  ~ParsingData (this=0xb3bd80, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:40
#9  qThreadStorage_deleteData<KTraderParse::ParsingData> (d=0xb3bd80) at /usr/include/QtCore/qthreadstorage.h:97
#10 QThreadStorage<KTraderParse::ParsingData*>::deleteData (x=0xb3bd80) at /usr/include/QtCore/qthreadstorage.h:140
#11 0x00007f3f38c505ed in QThreadStorageData::set (this=0x1ba0480, p=0x1b9a380) at thread/qthreadstorage.cpp:165
Comment 6 dev.dliw 2012-06-11 17:37:47 UTC
Same problem here after update to kde 4.8.4, openSUSE 12.1
KMail crashes after I try to view a message, maybe it doesn't crash because my "initial" view is the kde starting page and not a message;
but crashlog is the same
Comment 7 alexander.willand 2012-06-12 09:59:59 UTC
Created attachment 71755 [details]
New crash information added by DrKonqi

kmail (4.8.4) on KDE Platform 4.8.4 (4.8.4) "release 6" using Qt 4.8.2

Same here, *but this is really important to be fixed*. If I can help, please say so.

-- Backtrace (Reduced):
#7  ~KSharedPtr (this=0x260eef0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/ksharedptr.h:90
#8  ~ParsingData (this=0x260eef0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:40
#9  qThreadStorage_deleteData<KTraderParse::ParsingData> (d=0x260eef0) at /usr/include/QtCore/qthreadstorage.h:97
#10 QThreadStorage<KTraderParse::ParsingData*>::deleteData (x=0x260eef0) at /usr/include/QtCore/qthreadstorage.h:140
#11 0x00007fdb55cca5ed in QThreadStorageData::set (this=0x2db6e60, p=0x2db08d0) at thread/qthreadstorage.cpp:165
Comment 8 Laurent Montel 2012-06-12 10:59:28 UTC
*** Bug 301710 has been marked as a duplicate of this bug. ***
Comment 9 Laurent Montel 2012-06-12 12:02:16 UTC
*** Bug 301678 has been marked as a duplicate of this bug. ***
Comment 10 Vojtěch Zeisek 2012-06-12 12:02:42 UTC
When I launch KMail from console, it says
$ kmail
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kmail2(4518)/kdepimlibs (mailtransport): Could not access Outbox. 
There is still kmail process running, gut application does not start.
I use openSUSE 12.1, KDE 4.8.4, x86_64
Comment 11 Rudy Raab 2012-06-12 12:52:44 UTC
Apparently the OpenSUSE KDE Release 4.8 (KR48) repo is broken. See here:
http://kdeatopensuse.wordpress.com/2012/06/11/warning-do-not-update-to-the-packages-from-kr48/

I wish I had known sooner...
Comment 12 Eric Seynaeve 2012-06-12 19:52:46 UTC
Created attachment 71774 [details]
New crash information added by DrKonqi

kmail (4.8.4) on KDE Platform 4.8.4 (4.8.4) using Qt 4.8.2

- What I was doing when the application crashed:
KDE was upgraded to 4.8.4 in Fedora 16.
When I use Kontakt, kmail crashes when trying to compose a new message.

-- Backtrace (Reduced):
#7  ~KSharedPtr (this=0x26967c0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/ksharedptr.h:90
#8  ~ParsingData (this=0x26967c0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:40
#9  qThreadStorage_deleteData<KTraderParse::ParsingData> (d=0x26967c0) at /usr/include/QtCore/qthreadstorage.h:97
#10 QThreadStorage<KTraderParse::ParsingData*>::deleteData (x=0x26967c0) at /usr/include/QtCore/qthreadstorage.h:140
#11 0x00007f943a33fb5d in QThreadStorageData::set (this=0x2e544c0, p=0x2e50ff0) at thread/qthreadstorage.cpp:165
Comment 13 Allan Mau 2012-06-13 01:34:26 UTC
Created attachment 71781 [details]
New crash information added by DrKonqi

kmail (4.8.4) on KDE Platform 4.8.4 (4.8.4) "release 511" using Qt 4.8.2

- What I was doing when the application crashed:

Simply trying to start the program after the latest update, but kmail2 has frequently crashed since initial installation when deleting messages.  Until now, I was always able to restart, now even this is impossible.

-- Backtrace (Reduced):
#7  ~KSharedPtr (this=0xc07160, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/ksharedptr.h:90
#8  ~ParsingData (this=0xc07160, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:40
#9  qThreadStorage_deleteData<KTraderParse::ParsingData> (d=0xc07160) at /usr/include/QtCore/qthreadstorage.h:97
#10 QThreadStorage<KTraderParse::ParsingData*>::deleteData (x=0xc07160) at /usr/include/QtCore/qthreadstorage.h:140
#11 0x00007fb5572ff5ed in QThreadStorageData::set (this=0xedce50, p=0xedc950) at thread/qthreadstorage.cpp:165
Comment 14 Cyrille Dunant 2012-06-13 14:07:13 UTC
Created attachment 71794 [details]
New crash information added by DrKonqi

kmail (4.8.4) on KDE Platform 4.8.4 (4.8.4) using Qt 4.8.2

- What I was doing when the application crashed:

I just launched the application

- Unusual behavior I noticed:

The email indexer crashes regularly

-- Backtrace (Reduced):
#7  ~KSharedPtr (this=0xa83530, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/ksharedptr.h:90
#8  ~ParsingData (this=0xa83530, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/services/ktraderparse.cpp:40
#9  qThreadStorage_deleteData<KTraderParse::ParsingData> (d=0xa83530) at /usr/include/QtCore/qthreadstorage.h:97
#10 QThreadStorage<KTraderParse::ParsingData*>::deleteData (x=0xa83530) at /usr/include/QtCore/qthreadstorage.h:140
#11 0x00007f3071e235ed in QThreadStorageData::set (this=0x913f00, p=0xa1c0a0) at thread/qthreadstorage.cpp:165
Comment 15 Axel Braun 2012-06-13 14:09:25 UTC
Deactivate Nepomuk and restart the system. Then you can at least use Kmail2, although some functions are missing
Comment 16 Ralph Moenchmeyer 2012-06-14 07:48:07 UTC
I had this and other problems with Kontact/Kmail 4.8.4 on Opensuse 12.1 x86_64. 
See bug #301812. I found a workaround in one of Opensuse's forums. See the contribution of "UNIX-Pete" at: 

http://forums.opensuse.org/english/get-technical-help-here/applications/476040-re-kmail.html 

Quote: "Using the soprano packages from Index of /repositories/KDE:/Unstable:/SC/openSUSE_12.1 I could manage to get the segfault issues in kmail and gwenview of the KDE 4.8.4 release fixed." 

I then combined KDE 4.8.4 from Opensuse's KDE Release Factory with the soprano RPMs from the KDE Unstable Repository as suggested. It worked ! Kmail can be started again from the command line. ( However, the message 
"kmail2(5266)/kdepimlibs (mailtransport): Could not access Outbox." 
remains. )
Comment 17 Tamás Németh 2012-06-18 09:24:36 UTC
Works since today morning!
Comment 18 Tamás Németh 2012-06-18 09:55:34 UTC
(In reply to comment #17)
> Works since today morning!

But after logging in and out, it started crashing again just like before. Unbeliveable :-(
Comment 19 Axel Braun 2012-06-18 10:18:07 UTC
Created attachment 71905 [details]
crashreport

Can confirm that the upgrade to soprano 2.7.6 does not fix it
Comment 20 Ralph Moenchmeyer 2012-06-18 10:26:10 UTC
> I then combined KDE 4.8.4 from Opensuse's KDE Release Factory with the
> soprano RPMs from the KDE Unstable Repository as suggested. It worked !
> Kmail can be started again from the command line. ( However, the message 
> "kmail2(5266)/kdepimlibs (mailtransport): Could not access Outbox." 
> remains. )

Some more details regarding the workaround: 

I use KDE 4.8.4 including Kontact/Kmail from Opensuse's Release Repository [http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1]. 

But I do not use the included version 2.7.6 of the RPMs for 

* libsoprano4
* soprano
* soprano-backend-virtuoso
* soprano-backend-redland 

These soprano versions lead to crashes and other problems with Kontact/Kmail 4.8.4. 

Instead I use version 2.6.56 for the soprano RPMs from the Opensuses's Unstable Repository 
[http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1].  

This really helped and I do not get any crashes any more.
Comment 21 Tamás Németh 2012-06-18 11:25:02 UTC
(In reply to comment #20)
> Instead I use version 2.6.56 for the soprano RPMs from the Opensuses's
> Unstable Repository 
> [http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1].  

Do you mean 2.7.56 from http://download.opensuse.org/repositories/KDE:/Unstable:/SC/openSUSE_12.1 ?
Comment 22 Ralph Moenchmeyer 2012-06-19 07:36:45 UTC
> Do you mean 2.7.56 from
> http://download.opensuse.org/repositories/KDE:/Unstable:/SC/openSUSE_12.1 ?

Yes, you are of course right. Sorry for the wrong information in comment #20. 

I used version 
2.7.56 
from
http://download.opensuse.org/repositories/KDE:/Unstable:/SC/openSUSE_12.1 
to get Kmail working .
Comment 23 Tamás Németh 2012-06-19 08:18:23 UTC
(In reply to comment #22)
> I used version 
> 2.7.56 
> from
> http://download.opensuse.org/repositories/KDE:/Unstable:/SC/openSUSE_12.1 
> to get Kmail working .

It works for me, too.
Comment 24 Axel Braun 2012-06-19 08:59:42 UTC
(In reply to comment #23)
> > I used version 
> > 2.7.56 
> > from
> > http://download.opensuse.org/repositories/KDE:/Unstable:/SC/openSUSE_12.1 
> > to get Kmail working .
> 
> It works for me, too.

For me as well. Maybe it is a good idea for the maintainers of the KDE48-repo to update the four soprano-packages...otherwise the 'stable' KDE48 remains broken
Comment 25 Tamás Németh 2012-06-21 12:14:22 UTC
It really seems to be solved now. Doesn't it?
Comment 26 Laurent Montel 2012-07-02 08:21:22 UTC
Fixed in 4.8.5 (in kdelibs)
pb with nepomuk+soprano
Comment 27 Jekyll Wu 2012-07-03 09:36:05 UTC
*** Bug 302019 has been marked as a duplicate of this bug. ***
Comment 28 Jekyll Wu 2012-07-03 09:36:18 UTC
*** Bug 302166 has been marked as a duplicate of this bug. ***