Bug 301498 - Gwenview closed while zooming in and zooming out
Summary: Gwenview closed while zooming in and zooming out
Status: RESOLVED DUPLICATE of bug 282235
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 2.8.3
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-09 10:00 UTC by Özgür Sarıer
Modified: 2012-10-19 13:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Özgür Sarıer 2012-06-09 10:00:40 UTC
Application: gwenview (2.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.2
Operating System: Linux 3.3.7-1-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:
Zooming in and out cause gwenview closed when i open a 10,3mb jpeg image.
- Custom settings of the application:
All settings have never been changed.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f41b9144780 (LWP 2238))]

Thread 3 (Thread 0x7f41a5756700 (LWP 2240)):
#0  0x00007f41b5b83068 in poll () from /lib/libc.so.6
#1  0x00007f41b2350774 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f41b2350894 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f41b7fb1b06 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f41b7f8263f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f41b7f828c8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f41b7e866e0 in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f41b7f6303f in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f41b7e8967b in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f41b4309e0e in start_thread () from /lib/libpthread.so.0
#10 0x00007f41b5b8b1ed in clone () from /lib/libc.so.6

Thread 2 (Thread 0x7f419faff700 (LWP 2247)):
#0  0x00007f41b430d8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f41b7e89b7b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f41b8a93a16 in ?? () from /usr/lib/libgwenviewlib.so.4
#3  0x00007f41b7e8967b in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f41b4309e0e in start_thread () from /lib/libpthread.so.0
#5  0x00007f41b5b8b1ed in clone () from /lib/libc.so.6

Thread 1 (Thread 0x7f41b9144780 (LWP 2238)):
[KCrash Handler]
#5  0x00007f41b68d9e6a in ?? () from /usr/lib/libQtGui.so.4
#6  0x00007f41b68d5153 in ?? () from /usr/lib/libQtGui.so.4
#7  0x00007f41b69a0e45 in ?? () from /usr/lib/libQtGui.so.4
#8  0x00007f41b699ed35 in ?? () from /usr/lib/libQtGui.so.4
#9  0x00007f41b692af2d in QPainter::drawImage(QPointF const&, QImage const&) () from /usr/lib/libQtGui.so.4
#10 0x00007f41b689a3c5 in QImage::transformed(QTransform const&, Qt::TransformationMode) const () from /usr/lib/libQtGui.so.4
#11 0x00007f41b689aeb8 in QImage::scaled(QSize const&, Qt::AspectRatioMode, Qt::TransformationMode) const () from /usr/lib/libQtGui.so.4
#12 0x00007f41b8a2fb47 in Gwenview::Document::prepareDownSampledImageForZoom(double) () from /usr/lib/libgwenviewlib.so.4
#13 0x00007f41b8a6140a in Gwenview::ImageScaler::doScale() () from /usr/lib/libgwenviewlib.so.4
#14 0x00007f41b8a46a23 in ?? () from /usr/lib/libgwenviewlib.so.4
#15 0x00007f41b8a45f81 in Gwenview::RasterImageView::onZoomChanged() () from /usr/lib/libgwenviewlib.so.4
#16 0x00007f41b8a396df in ?? () from /usr/lib/libgwenviewlib.so.4
#17 0x00007f41b8a4027b in Gwenview::DocumentView::zoomOut(QPointF const&) () from /usr/lib/libgwenviewlib.so.4
#18 0x00007f41b8a405b2 in Gwenview::DocumentView::wheelEvent(QGraphicsSceneWheelEvent*) () from /usr/lib/libgwenviewlib.so.4
#19 0x00007f41b6d99283 in QGraphicsItem::sceneEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x00007f41b6dc9130 in QGraphicsScene::wheelEvent(QGraphicsSceneWheelEvent*) () from /usr/lib/libQtGui.so.4
#21 0x00007f41b6dd5f16 in QGraphicsScene::event(QEvent*) () from /usr/lib/libQtGui.so.4
#22 0x00007f41b67dcf7c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#23 0x00007f41b67e13fa in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#24 0x00007f41b74f9fc6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#25 0x00007f41b7f838ee in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#26 0x00007f41b6de6b5b in QGraphicsView::wheelEvent(QWheelEvent*) () from /usr/lib/libQtGui.so.4
#27 0x00007f41b682c9be in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#28 0x00007f41b6bd6ef6 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#29 0x00007f41b6def70b in QGraphicsView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#30 0x00007f41b7f83a56 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#31 0x00007f41b67dcf4c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#32 0x00007f41b67e1e9d in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#33 0x00007f41b74f9fc6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#34 0x00007f41b7f838ee in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#35 0x00007f41b684747d in ?? () from /usr/lib/libQtGui.so.4
#36 0x00007f41b6858a8e in ?? () from /usr/lib/libQtGui.so.4
#37 0x00007f41b6857591 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#38 0x00007f41b687d682 in ?? () from /usr/lib/libQtGui.so.4
#39 0x00007f41b23504a5 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#40 0x00007f41b23507d8 in ?? () from /usr/lib/libglib-2.0.so.0
#41 0x00007f41b2350894 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#42 0x00007f41b7fb1ae6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#43 0x00007f41b687d2fe in ?? () from /usr/lib/libQtGui.so.4
#44 0x00007f41b7f8263f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#45 0x00007f41b7f828c8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#46 0x00007f41b7f87568 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#47 0x0000000000427082 in ?? ()
#48 0x00007f41b5ac8455 in __libc_start_main () from /lib/libc.so.6
#49 0x0000000000427341 in _start ()

Possible duplicates by query: bug 287628, bug 282235, bug 278669.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-04 12:34:23 UTC

*** This bug has been marked as a duplicate of bug 282235 ***