Bug 278669 - Gwenview crashes
Summary: Gwenview crashes
Status: RESOLVED DUPLICATE of bug 282235
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-28 07:18 UTC by Rose
Modified: 2012-10-19 13:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rose 2011-07-28 07:18:53 UTC
Application: gwenview (2.5.0)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-30-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I was rotating images. Perhaps too many at one time?  But I usually get a message that memory is running low and I should save my work. I use this on a Gnome desktop. (This is not in the summary)

The crash can be reproduced some of the time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78bfa20 (LWP 3062))]

Thread 3 (Thread 0xb762fb70 (LWP 3063)):
#0  __i686.get_pc_thunk.bx () at ../sysdeps/i386/i686/multiarch/strcmp.S:49
#1  0x005f8f3b in pthread_mutex_lock (mutex=0x9655de4) at forward.c:182
#2  0x02108412 in g_main_context_release () from /lib/libglib-2.0.so.0
#3  0x0210a473 in ?? () from /lib/libglib-2.0.so.0
#4  0x0210aba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#5  0x02bee6b4 in ?? () from /usr/lib/libgio-2.0.so.0
#6  0x0213148f in ?? () from /lib/libglib-2.0.so.0
#7  0x006fccc9 in start_thread (arg=0xb762fb70) at pthread_create.c:304
#8  0x005eb69e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb44d2b70 (LWP 3186)):
#0  0x006ff3eb in __pthread_mutex_lock (mutex=0x9ae5714) at pthread_mutex_lock.c:61
#1  0x005f8f66 in pthread_mutex_lock (mutex=0x9ae5714) at forward.c:182
#2  0x0210a4a4 in ?? () from /lib/libglib-2.0.so.0
#3  0x0210a848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x002a259f in QEventDispatcherGlib::processEvents (this=0x9800080, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00272609 in QEventLoop::processEvents (this=0xb44d2290, flags=) at kernel/qeventloop.cpp:149
#6  0x00272a8a in QEventLoop::exec (this=0xb44d2290, flags=...) at kernel/qeventloop.cpp:201
#7  0x0016eb7e in QThread::exec (this=0x9b0f2e0) at thread/qthread.cpp:490
#8  0x0025135b in QInotifyFileSystemWatcherEngine::run (this=0x9b0f2e0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00171df9 in QThreadPrivate::start (arg=0x9b0f2e0) at thread/qthread_unix.cpp:266
#10 0x006fccc9 in start_thread (arg=0xb44d2b70) at pthread_create.c:304
#11 0x005eb69e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb78bfa20 (LWP 3062)):
[KCrash Handler]
#7  0x08ac922d in write (destPixels=0x866f5008 "", dbpl=6528, srcPixels=0x8ab8c008 <Address 0x8ab8c008 out of bounds>, sbpl=13056, targetRect=..., srcRect=..., clip=..., blender=...) at painting/qblendfunctions.cpp:567
#8  qt_scale_image_32bit<Blend_RGB32_on_RGB32_NoAlpha> (destPixels=0x866f5008 "", dbpl=6528, srcPixels=0x8ab8c008 <Address 0x8ab8c008 out of bounds>, sbpl=13056, targetRect=..., srcRect=..., clip=..., blender=...) at painting/qblendfunctions_p.h:244
#9  0x08ba54a8 in QRasterPaintEngine::drawImage (this=0x9db4678, r=..., img=..., sr=...) at painting/qpaintengine_raster.cpp:2693
#10 0x08b9e214 in QRasterPaintEngine::drawImage (this=0x9db4678, p=..., img=...) at painting/qpaintengine_raster.cpp:2487
#11 0x08b1d4e4 in QPainter::drawImage (this=0xbf986b9c, p=..., image=...) at painting/qpainter.cpp:5555
#12 0x08a848bb in drawImage (this=0x9da1e54, matrix=..., mode=Qt::FastTransformation) at ../../include/QtGui/../../src/gui/painting/qpainter.h:918
#13 QImage::transformed (this=0x9da1e54, matrix=..., mode=Qt::FastTransformation) at image/qimage.cpp:6515
#14 0x08a85962 in QImage::scaled (this=0x9da1e54, s=..., aspectMode=Qt::KeepAspectRatio, mode=Qt::FastTransformation) at image/qimage.cpp:4319
#15 0x00760501 in Gwenview::Document::prepareDownSampledImageForZoom (this=0x9da4d00, zoom=0.36315359477124182) at ../../../gwenview/lib/document/document.cpp:372
#16 0x0808e229 in Gwenview::Preloader::doPreload (this=0x97589a0) at ../../../gwenview/app/preloader.cpp:91
#17 0x0808e4e3 in Gwenview::Preloader::preload (this=0x97589a0, url=..., size=...) at ../../../gwenview/app/preloader.cpp:73
#18 0x08085373 in Gwenview::MainWindow::preloadNextUrl (this=0x9621268) at ../../../gwenview/app/mainwindow.cpp:1470
#19 0x080899f3 in Gwenview::MainWindow::qt_metacall (this=0x9621268, _c=QMetaObject::InvokeMetaMethod, _id=80, _a=0xbf986f7c) at ./mainwindow.moc:165
#20 0x002798ca in QMetaObject::metacall (object=0x9621268, cl=QMetaObject::InvokeMetaMethod, idx=80, argv=0xbf986f7c) at kernel/qmetaobject.cpp:237
#21 0x0028c6ad in QMetaObject::activate (sender=0x9dc0098, m=0x3a5188, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#22 0x00291a47 in QSingleShotTimer::timeout (this=0x9dc0098) at .moc/release-shared/qtimer.moc:82
#23 0x00291b5c in QSingleShotTimer::timerEvent (this=0x9dc0098) at kernel/qtimer.cpp:308
#24 0x00286504 in QObject::event (this=0x9dc0098, e=0xffff) at kernel/qobject.cpp:1183
#25 0x0899ffdc in QApplicationPrivate::notify_helper (this=0x961ef48, receiver=0x9dc0098, e=0xbf9874b0) at kernel/qapplication.cpp:4396
#26 0x089a604e in QApplication::notify (this=0xbf98782c, receiver=0x9dc0098, e=0xbf9874b0) at kernel/qapplication.cpp:3798
#27 0x0113568a in KApplication::notify (this=0xbf98782c, receiver=0x9dc0098, event=0xbf9874b0) at ../../kdeui/kernel/kapplication.cpp:310
#28 0x00273b3b in QCoreApplication::notifyInternal (this=0xbf98782c, receiver=0x9dc0098, event=0xbf9874b0) at kernel/qcoreapplication.cpp:732
#29 0x002a5ad6 in sendEvent (this=0x9622134) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QTimerInfoList::activateTimers (this=0x9622134) at kernel/qeventdispatcher_unix.cpp:602
#31 0x002a2874 in timerSourceDispatch (source=0x9622100) at kernel/qeventdispatcher_glib.cpp:184
#32 0x02106855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#33 0x0210a668 in ?? () from /lib/libglib-2.0.so.0
#34 0x0210a848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#35 0x002a2565 in QEventDispatcherGlib::processEvents (this=0x9609d68, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#36 0x08a61be5 in QGuiEventDispatcherGlib::processEvents (this=0x9609d68, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#37 0x00272609 in QEventLoop::processEvents (this=0xbf987774, flags=) at kernel/qeventloop.cpp:149
#38 0x00272a8a in QEventLoop::exec (this=0xbf987774, flags=...) at kernel/qeventloop.cpp:201
#39 0x0027700f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#40 0x0899ee07 in QApplication::exec () at kernel/qapplication.cpp:3672
#41 0x08082ffd in main (argc=5, argv=0xbf987994) at ../../../gwenview/app/main.cpp:139

Reported using DrKonqi
Comment 1 Christoph Feck 2011-08-13 01:59:34 UTC
Are you using "raster" Qt graphicssystem ? Could be the same issue as bug 278320.
Comment 2 Rose 2011-08-17 10:21:29 UTC
(In reply to comment #1)
> Are you using "raster" Qt graphicssystem ? Could be the same issue as bug
> 278320.

 Looking at the bug 278320, I tried running: "gwenview -graphicssystem native"
Gwenview did not crash. Then I tried it with "gwenview -graphicssystem raster", still no crash.
Comment 3 Jekyll Wu 2012-05-29 09:38:58 UTC

*** This bug has been marked as a duplicate of bug 282235 ***