Bug 301260 - akonadi_imap_resource (KDE 4.8.3, Kubuntu 12.04, 64 bit) has crashed
Summary: akonadi_imap_resource (KDE 4.8.3, Kubuntu 12.04, 64 bit) has crashed
Status: RESOLVED DUPLICATE of bug 292607
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.8
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-06 08:36 UTC by Thomas Dreibholz
Modified: 2012-07-06 19:14 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.75 KB, text/plain)
2012-06-06 08:37 UTC, Thomas Dreibholz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Dreibholz 2012-06-06 08:36:10 UTC
Application: akonadi_imap_resource (4.8)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

akonadi_imap_resource (KDE 4.8.3, Kubuntu 12.04, 64 bit) has crashed, possibly when network connection was temporarily interrupted. Before, it reported a login error (wrong password), although the credentials had been okay.

-- Backtrace:
Application: Uni-DUE vom Typ IMAP-E-Mail-Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7d5040f780 (LWP 2204))]

Thread 2 (Thread 0x7f7d351b4700 (LWP 5311)):
#0  0x00007ffff3bb570c in ?? ()
#1  0x00007ffff3bb5959 in ?? ()
#2  0x00007f7d4abbf15d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#3  0x00007f7d4f761bb4 in do_gettime (frac=0x7f7d351b3b98, sec=0x7f7d351b3b90) at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007f7d4f839b8d in QTimerInfoList::updateCurrentTime (this=0x7f7d2c001c60) at kernel/qeventdispatcher_unix.cpp:343
#6  0x00007f7d4f839ec3 in QTimerInfoList::timerWait (this=0x7f7d2c001c60, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#7  0x00007f7d4f83897c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f7d351b3c6c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007f7d4f838a25 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007f7d4a90d71e in g_main_context_prepare (context=0x7f7d2c0009a0, priority=0x7f7d351b3cb8) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:2813
#10 0x00007f7d4a90df1b in g_main_context_iterate (dispatch=1, block=1, context=0x7f7d2c0009a0, self=<optimized out>) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3103
#11 g_main_context_iterate (context=0x7f7d2c0009a0, block=1, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3060
#12 0x00007f7d4a90e124 in g_main_context_iteration (context=0x7f7d2c0009a0, may_block=1) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3184
#13 0x00007f7d4f839426 in QEventDispatcherGlib::processEvents (this=0x7f7d2c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#14 0x00007f7d4f808c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#15 0x00007f7d4f808ed7 in QEventLoop::exec (this=0x7f7d351b3dd0, flags=...) at kernel/qeventloop.cpp:204
#16 0x00007f7d4f707fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#17 0x00007f7d4f7e89ff in QInotifyFileSystemWatcherEngine::run (this=0x19fdb90) at io/qfilesystemwatcher_inotify.cpp:248
#18 0x00007f7d4f70afcb in QThreadPrivate::start (arg=0x19fdb90) at thread/qthread_unix.cpp:298
#19 0x00007f7d4b429e9a in start_thread (arg=0x7f7d351b4700) at pthread_create.c:308
#20 0x00007f7d4bdcd4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#21 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7d5040f780 (LWP 2204)):
[KCrash Handler]
#6  0x0000000001fa2ec0 in ?? ()
#7  0x00007f7d4f81db04 in QObject::disconnect (sender=0x181dba0, signal=0x1d45c79 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=0x1878660, method=0x19ae1f9 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2891
#8  0x0000000000454365 in SessionPool::killSession (this=0x1878660, session=0x181dba0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:176
#9  0x0000000000454d67 in SessionPool::cancelSessionCreation (this=0x1878660, session=0x181dba0, errorCode=4, errorMessage=...) at ../../../resources/imap/sessionpool.cpp:233
#10 0x0000000000455090 in SessionPool::onPasswordRequestDone (this=0x1878660, resultType=<optimized out>, password=...) at ../../../resources/imap/sessionpool.cpp:308
#11 0x0000000000456cd7 in SessionPool::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./sessionpool.moc:94
#12 0x00007f7d4f81e281 in QMetaObject::activate (sender=0x1872400, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff3b58630) at kernel/qobject.cpp:3547
#13 0x00000000004421c1 in PasswordRequesterInterface::done (this=<optimized out>, _t1=2, _t2=...) at ./passwordrequesterinterface.moc:118
#14 0x0000000000420d2a in SettingsPasswordRequester::askUserInput (this=0x1872400, serverError=...) at ../../../resources/imap/settingspasswordrequester.cpp:75
#15 0x00007f7d4f823446 in QObject::event (this=0x1872400, e=<optimized out>) at kernel/qobject.cpp:1195
#16 0x00007f7d4eb8c894 in notify_helper (e=0x1e63960, receiver=0x1872400, this=0x16d3f40) at kernel/qapplication.cpp:4559
#17 QApplicationPrivate::notify_helper (this=0x16d3f40, receiver=0x1872400, e=0x1e63960) at kernel/qapplication.cpp:4531
#18 0x00007f7d4eb91713 in QApplication::notify (this=0x7ffff3b591f0, receiver=0x1872400, e=0x1e63960) at kernel/qapplication.cpp:4420
#19 0x00007f7d4ccb7bb6 in KApplication::notify (this=0x7ffff3b591f0, receiver=0x1872400, event=0x1e63960) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007f7d4f809e9c in QCoreApplication::notifyInternal (this=0x7ffff3b591f0, receiver=0x1872400, event=0x1e63960) at kernel/qcoreapplication.cpp:876
#21 0x00007f7d4f80dc6a in sendEvent (event=0x1e63960, receiver=0x1872400) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x16aa4d0) at kernel/qcoreapplication.cpp:1500
#23 0x00007f7d4f838f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#24 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#25 0x00007f7d4a90dc9a in g_main_dispatch (context=0x16d6b00) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:2515
#26 g_main_context_dispatch (context=0x16d6b00) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3052
#27 0x00007f7d4a90e060 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x16d6b00, self=<optimized out>) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3123
#28 g_main_context_iterate (context=0x16d6b00, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3060
#29 0x00007f7d4a90e124 in g_main_context_iteration (context=0x16d6b00, may_block=1) at /build/buildd/glib2.0-2.32.1/./glib/gmain.c:3184
#30 0x00007f7d4f8393bf in QEventDispatcherGlib::processEvents (this=0x16abcb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#31 0x00007f7d4ec34d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007f7d4f808c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f7d4f808ed7 in QEventLoop::exec (this=0x7ffff3b59170, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007f7d4f80df67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#35 0x00007f7d4ff382f6 in Akonadi::ResourceBase::init (r=0x1813810) at ../../akonadi/resourcebase.cpp:412
#36 0x000000000041a996 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#37 0x00007f7d4bcfc76d in __libc_start_main (main=0x4151c0 <main(int, char**)>, argc=3, ubp_av=0x7ffff3b59308, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff3b592f8) at libc-start.c:226
#38 0x0000000000415375 in _start ()

Possible duplicates by query: bug 294489, bug 294130, bug 293189, bug 292607, bug 288268.

Reported using DrKonqi
Comment 1 Thomas Dreibholz 2012-06-06 08:37:36 UTC
Created attachment 71615 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.8) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.1

- What I was doing when the application crashed:

Crash happened again, with other IMAP account.

-- Backtrace (Reduced):
#6  0x00007fd65b346b02 in QObject::disconnect (sender=0x111f1a0, signal=0x16ade49 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=0x127b620, method=0x1608119 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2891
#7  0x0000000000454365 in SessionPool::killSession (this=0x127b620, session=0x111f1a0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:176
#8  0x0000000000454d67 in SessionPool::cancelSessionCreation (this=0x127b620, session=0x111f1a0, errorCode=2, errorMessage=...) at ../../../resources/imap/sessionpool.cpp:233
#9  0x00000000004550d4 in SessionPool::onPasswordRequestDone (this=0x127b620, resultType=<optimized out>, password=...) at ../../../resources/imap/sessionpool.cpp:295
#10 0x0000000000456cd7 in SessionPool::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./sessionpool.moc:94
Comment 2 Jekyll Wu 2012-07-06 19:14:35 UTC

*** This bug has been marked as a duplicate of bug 292607 ***