Bug 292607 - IMAP resource crashed after resource shutdown
Summary: IMAP resource crashed after resource shutdown
Status: RESOLVED DUPLICATE of bug 288268
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.8
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
: 293189 294130 294489 301260 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-27 16:52 UTC by Martin
Modified: 2012-09-02 06:54 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.12 KB, text/plain)
2012-04-26 18:05 UTC, romain
Details
New crash information added by DrKonqi (8.35 KB, text/plain)
2012-06-28 07:16 UTC, Diego
Details
New crash information added by DrKonqi (5.07 KB, text/plain)
2012-08-31 08:12 UTC, Diego
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2012-01-27 16:52:30 UTC
Application: akonadi_imap_resource (4.8)
KDE Platform Version: 4.8.00 (4.8.0
Qt Version: 4.8.0
Operating System: Linux 3.2.0-10-generic x86_64
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
I was working when said IMAP resource asked for my password (even though I did not change it nor any configuration). When I clicked on cancel the resource went down and crashed. The Akonadi Configuration says 'Could not connect to the IMAP-server ***. Could not read the password: user rejected walled access' (which I did not).

-- Backtrace:
Application: RWTH of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8b5ea9d7a0 (LWP 2081))]

Thread 2 (Thread 0x7f8b4a87e700 (LWP 6997)):
#0  0x00007fffa65ff98f in clock_gettime ()
#1  0x00007f8b5927005b in __GI_clock_gettime (clock_id=1, tp=0x7f8b4a87db60) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f8b5ddf15d4 in do_gettime (frac=0x7f8b4a87db78, sec=0x7f8b4a87db70) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f8b5dec910d in QTimerInfoList::updateCurrentTime (this=0x2472900) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f8b5dec9443 in QTimerInfoList::timerWait (this=0x2472900, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f8b5dec7efc in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f8b4a87dc4c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f8b5dec7fa5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f8b58fc025e in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f8b58fc0a5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f8b58fc0c64 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f8b5dec89a6 in QEventDispatcherGlib::processEvents (this=0x21c1f40, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f8b5de98202 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f8b5de98457 in QEventLoop::exec (this=0x7f8b4a87ddb0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f8b5dd97f17 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007f8b5de77f9f in QInotifyFileSystemWatcherEngine::run (this=0x2471190) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f8b5dd9af3b in QThreadPrivate::start (arg=0x2471190) at thread/qthread_unix.cpp:298
#17 0x00007f8b59adae2b in start_thread (arg=0x7f8b4a87e700) at pthread_create.c:304
#18 0x00007f8b5a4710dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8b5ea9d7a0 (LWP 2081)):
[KCrash Handler]
#6  0x00007f8b5dead082 in QObject::disconnect (sender=0x242f6a0, signal=0x2155a69 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=0x2116170, method=0x234e4d9 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2891
#7  0x0000000000453d25 in SessionPool::killSession (this=0x2116170, session=0x242f6a0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:175
#8  0x0000000000454487 in SessionPool::cancelSessionCreation (this=0x2116170, session=0x242f6a0, errorCode=4, errorMessage=...) at ../../../resources/imap/sessionpool.cpp:227
#9  0x0000000000454798 in SessionPool::onPasswordRequestDone (this=0x2116170, resultType=<optimized out>, password=...) at ../../../resources/imap/sessionpool.cpp:302
#10 0x0000000000456597 in SessionPool::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./sessionpool.moc:94
#11 0x00007f8b5dead801 in QMetaObject::activate (sender=0x2116fd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffa65d51f0) at kernel/qobject.cpp:3547
#12 0x0000000000441fc1 in PasswordRequesterInterface::done (this=<optimized out>, _t1=2, _t2=...) at ./passwordrequesterinterface.moc:118
#13 0x0000000000420b2a in SettingsPasswordRequester::askUserInput (this=0x2116fd0, serverError=...) at ../../../resources/imap/settingspasswordrequester.cpp:75
#14 0x00007f8b5deb29c6 in QObject::event (this=0x2116fd0, e=<optimized out>) at kernel/qobject.cpp:1195
#15 0x00007f8b5d21c5e4 in notify_helper (e=0x7f8b3c008910, receiver=0x2116fd0, this=0x1f93120) at kernel/qapplication.cpp:4555
#16 QApplicationPrivate::notify_helper (this=0x1f93120, receiver=0x2116fd0, e=0x7f8b3c008910) at kernel/qapplication.cpp:4527
#17 0x00007f8b5d221463 in QApplication::notify (this=0x7fffa65d5db0, receiver=0x2116fd0, e=0x7f8b3c008910) at kernel/qapplication.cpp:4416
#18 0x00007f8b5b34ca46 in KApplication::notify (this=0x7fffa65d5db0, receiver=0x2116fd0, event=0x7f8b3c008910) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007f8b5de9941c in QCoreApplication::notifyInternal (this=0x7fffa65d5db0, receiver=0x2116fd0, event=0x7f8b3c008910) at kernel/qcoreapplication.cpp:876
#20 0x00007f8b5de9d1ea in sendEvent (event=0x7f8b3c008910, receiver=0x2116fd0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1f5d4d0) at kernel/qcoreapplication.cpp:1500
#22 0x00007f8b5dec8513 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#23 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#24 0x00007f8b58fc07da in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f8b58fc0ba0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f8b58fc0c64 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f8b5dec893f in QEventDispatcherGlib::processEvents (this=0x1f5ecb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#28 0x00007f8b5d2c41ce in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007f8b5de98202 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f8b5de98457 in QEventLoop::exec (this=0x7fffa65d5d30, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007f8b5de9d4e7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#32 0x00007f8b5e5c5a26 in Akonadi::ResourceBase::init (r=0x20fd600) at ../../akonadi/resourcebase.cpp:408
#33 0x000000000041a856 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#34 0x00007f8b5a3ae30d in __libc_start_main (main=0x4150e0 <main(int, char**)>, argc=3, ubp_av=0x7fffa65d5ec8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffa65d5eb8) at libc-start.c:226
#35 0x0000000000415295 in _start ()

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-02-03 12:59:13 UTC
*** Bug 293189 has been marked as a duplicate of this bug. ***
Comment 2 Christophe Giboudeaux 2012-02-03 12:59:37 UTC
from bug 293189

-- Information about the crash:
- What I was doing when the application crashed:

Basically nothing related. Suddenly a dialog appeared saying that my gmail
password is incorrect (no, it is not). So I click Try Again and this crash
happened.
Comment 3 Martin 2012-02-04 10:14:31 UTC
Interestingly, the IMAP resource came back online after a while (again, without any effort from my side).
Comment 4 Kevin Ottens 2012-02-10 18:11:02 UTC
The relevant part of the code changed recently, fix to be in 4.8.1 AFAIK. Please test again when this version is out and reopen.

In any case for that one we'll need more info if it shows up again. Please see:
http://techbase.kde.org/Projects/PIM/Akonadi/Debug_IMAP
Comment 5 Christophe Giboudeaux 2012-03-31 14:00:30 UTC
*** Bug 294489 has been marked as a duplicate of this bug. ***
Comment 6 Christophe Giboudeaux 2012-03-31 14:01:00 UTC
*** Bug 294130 has been marked as a duplicate of this bug. ***
Comment 7 romain 2012-04-26 18:05:21 UTC
Created attachment 70676 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.8) on KDE Platform 4.8.2 (4.8.2) using Qt 4.8.1

kmail crashed when i tried to configure it with imap account.
I make make a mistake in the configuration and i think it's the cause of this crash.
drkonqi made me a pop-up  that the bug had been fixed in kde 4.8.1 but I'm on 4.8.2.

-- Backtrace (Reduced):
#7  0x00007fe4a300eb04 in QObject::disconnect (sender=0xfbaad0, signal=0xfc7159 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=0x11491d0, method=0x115bb39 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2891
#8  0x0000000000454365 in SessionPool::killSession (this=0x11491d0, session=0xfbaad0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:176
#9  0x0000000000454d67 in SessionPool::cancelSessionCreation (this=0x11491d0, session=0xfbaad0, errorCode=2, errorMessage=...) at ../../../resources/imap/sessionpool.cpp:233
#10 0x00000000004550d4 in SessionPool::onPasswordRequestDone (this=0x11491d0, resultType=<optimized out>, password=...) at ../../../resources/imap/sessionpool.cpp:295
#11 0x0000000000456cd7 in SessionPool::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./sessionpool.moc:94
Comment 8 Diego 2012-06-28 07:16:26 UTC
Created attachment 72185 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.8) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.2

- What I was doing when the application crashed:

This bug is definitely not fixed, as the user in the previous commit had 4.8.2 and I have 4.8.3.

-- Backtrace (Reduced):
#7  0x00007f609c8654d1 in QObject::disconnect (sender=0x1f780e0, signal=0x216a239 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=0x1f390a0, method=0x1f6b969 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2891
#8  0x0000000000452765 in SessionPool::killSession (this=this@entry=0x1f390a0, session=session@entry=0x1f780e0, termination=termination@entry=SessionPool::LogoutSession) at /usr/src/debug/kdepim-runtime-4.8.3/resources/imap/sessionpool.cpp:176
#9  0x0000000000453191 in SessionPool::cancelSessionCreation (this=this@entry=0x1f390a0, session=0x1f780e0, errorCode=errorCode@entry=4, errorMessage=...) at /usr/src/debug/kdepim-runtime-4.8.3/resources/imap/sessionpool.cpp:233
#10 0x00000000004544d5 in SessionPool::onPasswordRequestDone (this=0x1f390a0, resultType=<optimized out>, password=...) at /usr/src/debug/kdepim-runtime-4.8.3/resources/imap/sessionpool.cpp:308
#11 0x0000000000455097 in SessionPool::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdepim-runtime-4.8.3/x86_64-redhat-linux-gnu/resources/imap/sessionpool.moc:93
Comment 9 Diego 2012-06-28 07:52:28 UTC
I'll try to give you the additional debug informations if I'm able to, but please at least reopen this bug. IMAP server is using Zimbra.
Comment 10 Jekyll Wu 2012-07-06 19:14:35 UTC
*** Bug 301260 has been marked as a duplicate of this bug. ***
Comment 11 Diego 2012-08-31 08:12:54 UTC
Created attachment 73570 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.8) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.2

- What I was doing when the application crashed:

A IMAP Resource crashed just after adding it.

-- Backtrace (Reduced):
#6  0x00007f35befae4cf in QObject::disconnect (sender=0x2422340, signal=0x23c0629 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=0x23ba800, method=0x241cc19 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2891
#7  0x0000000000452765 in SessionPool::killSession (this=this@entry=0x23ba800, session=session@entry=0x2422340, termination=termination@entry=SessionPool::LogoutSession) at /usr/src/debug/kdepim-runtime-4.8.5/resources/imap/sessionpool.cpp:176
#8  0x0000000000453191 in SessionPool::cancelSessionCreation (this=this@entry=0x23ba800, session=0x2422340, errorCode=errorCode@entry=2, errorMessage=...) at /usr/src/debug/kdepim-runtime-4.8.5/resources/imap/sessionpool.cpp:233
#9  0x0000000000454519 in SessionPool::onPasswordRequestDone (this=0x23ba800, resultType=<optimized out>, password=...) at /usr/src/debug/kdepim-runtime-4.8.5/resources/imap/sessionpool.cpp:295
#10 0x0000000000455097 in SessionPool::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdepim-runtime-4.8.5/x86_64-redhat-linux-gnu/resources/imap/sessionpool.moc:93
Comment 12 Myriam Schweingruber 2012-09-02 06:54:10 UTC

*** This bug has been marked as a duplicate of bug 288268 ***