Bug 301178 - Kmail2 hangs on reply with "Please wait while the message is transferred" dialog
Summary: Kmail2 hangs on reply with "Please wait while the message is transferred" dialog
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Applications
Component: commands and actions (show other bugs)
Version: 4.8
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-04 20:50 UTC by Christopher Heiny
Modified: 2017-01-07 23:13 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Heiny 2012-06-04 20:50:39 UTC
Opened kmail2 for the second time (I'm using X11 forwarding, so it hangs the first time you start it).  Started reading some emails.  Hit "r" to reply to one.  Kmail2 hung displaying a dialog that says "Please wait while the message is transferred".  I gave it 5 minutes, then hit Cancel on the dialog.  Same thing happens when when I click the Reply button.  No output was present on stderr or stdout.  Ctrl-Q'ed and restarted, and reply worked OK.

Reproducible: Always
Comment 1 Christopher Heiny 2013-03-15 20:58:30 UTC
Still happening with kmail2 4.9.5.  Still a freaking pain in the neck.

Looks like Bug #311184 might be a duplicate, based on the symptoms.
Comment 2 Andre Blanchet 2013-10-23 06:40:18 UTC
I have the same problem with KMail 4.11.2 on Kubuntu 13.10.
Comment 3 Andre Blanchet 2013-10-23 06:54:23 UTC
I forgot to mention that in my case, it doesn't occur on all messages. For example, in one of the  Local Folders I've created, recent e-mails display their contents correctly, but e-mails from 2012 don't: when I scroll through the messages sorted in reverse chronological order, the oldest 2013 message displays its contents correctly, but the contents of this e-mail still shows while I'm scrolling through the e-mails that follow, dated 2012 and before. Trying a reply to an e-mail that doesn't display contents gives the everlasting "Please wait while the message is transferred" message; trying to copy the e-mail to another folder gives the error: "Unable to retrieve item from resource: invalid item retrieved".
Comment 4 Denis Kurz 2016-09-24 17:58:08 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 5 Christopher Heiny 2016-09-25 05:58:31 UTC
I gave up on Kmail about a year and a half ago.  As far as I'm concerned, you can close this bug.
Comment 6 Denis Kurz 2017-01-07 23:13:59 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.