Bug 300955 - KWin crashed when I closed its helper
Summary: KWin crashed when I closed its helper
Status: RESOLVED DUPLICATE of bug 295940
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-31 18:03 UTC by Unknown
Modified: 2012-05-31 18:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2012-05-31 18:03:06 UTC
Application: kwin (4.8.3 (4.8.3) "release 501")
KDE Platform Version: 4.8.3 (4.8.3) "release 501"
Qt Version: 4.8.1
Operating System: Linux 3.1.10-1.9-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Dolphin was freezing and KWin helper appeared. With Task manager I closed all three Dolphin-related windows, including KWin killer helper. Shortly after that KWin crashed.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f27ffe697a0 (LWP 3386))]

Thread 2 (Thread 0x7f27de92a700 (LWP 3417)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f27fc11e952 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f27fc417e80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f27fc11e989 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f27fb8c4b74 in ?? () from /usr/X11R6/lib64/libGL.so.1
#4  0x00007f27fa9d2f05 in start_thread (arg=0x7f27de92a700) at pthread_create.c:301
#5  0x00007f27ff6a510d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f27ffe697a0 (LWP 3386)):
[KCrash Handler]
#6  QProcess::setProcessState (this=0x3591780, state=QProcess::NotRunning) at io/qprocess.cpp:1770
#7  0x00007f27facfdb8f in QProcessPrivate::cleanup (this=0x2f3c860) at io/qprocess.cpp:799
#8  0x00007f27fad050f9 in QProcessPrivate::_q_processDied (this=0x2f3c860) at io/qprocess.cpp:1058
#9  0x00007f27fad051be in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qprocess.cpp:92
#10 QProcess::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qprocess.cpp:69
#11 0x00007f27fad7c0f1 in QMetaObject::activate (sender=0x3cfa8e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff7ccb7930) at kernel/qobject.cpp:3556
#12 0x00007f27fadc97be in QSocketNotifier::activated (this=<optimized out>, _t1=31) at .moc/release-shared/moc_qsocketnotifier.cpp:103
#13 0x00007f27fad8547b in QSocketNotifier::event (this=0x3cfa8e0, e=0x7fff7ccb7fa0) at kernel/qsocketnotifier.cpp:317
#14 0x00007f27f9ed00d4 in notify_helper (e=0x7fff7ccb7fa0, receiver=0x3cfa8e0, this=0x6b1630) at kernel/qapplication.cpp:4554
#15 QApplicationPrivate::notify_helper (this=0x6b1630, receiver=0x3cfa8e0, e=0x7fff7ccb7fa0) at kernel/qapplication.cpp:4526
#16 0x00007f27f9ed4f53 in QApplication::notify (this=0x7fff7ccb84e0, receiver=0x3cfa8e0, e=0x7fff7ccb7fa0) at kernel/qapplication.cpp:4415
#17 0x00007f27ff1968f6 in KApplication::notify (this=0x7fff7ccb84e0, receiver=0x3cfa8e0, event=0x7fff7ccb7fa0) at /usr/src/debug/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#18 0x00007f27fad6822c in QCoreApplication::notifyInternal (this=0x7fff7ccb84e0, receiver=0x3cfa8e0, event=0x7fff7ccb7fa0) at kernel/qcoreapplication.cpp:876
#19 0x00007f27fad9851b in sendEvent (event=0x7fff7ccb7fa0, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#20 QEventDispatcherUNIX::activateSocketNotifiers (this=<optimized out>) at kernel/qeventdispatcher_unix.cpp:899
#21 0x00007f27fad99dc2 in QEventDispatcherUNIXPrivate::doSelect (this=0x6b17c0, flags=<error reading variable: Cannot access memory at address 0x7fff00000000>, timeout=0x607000) at kernel/qeventdispatcher_unix.cpp:309
#22 0x00007f27fad9a183 in QEventDispatcherUNIX::processEvents (this=0x607000, flags=...) at kernel/qeventdispatcher_unix.cpp:941
#23 0x00007f27f9f74598 in QEventDispatcherX11::processEvents (this=0x607000, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#24 0x00007f27fad67012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007f27fad67267 in QEventLoop::exec (this=0x7fff7ccb8420, flags=...) at kernel/qeventloop.cpp:204
#26 0x00007f27fad6bdc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00007f27ff9bd486 in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kde-workspace-4.8.3/kwin/main.cpp:541
#28 0x00007f27ff5eb23d in __libc_start_main () from /lib64/libc.so.6
#29 0x0000000000400681 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 295920, bug 290711, bug 289316, bug 277190, bug 276367.

Reported using DrKonqi
Comment 1 Martin Flöser 2012-05-31 18:12:46 UTC

*** This bug has been marked as a duplicate of bug 295940 ***