Bug 295940 - Kill helper should be out of process
Summary: Kill helper should be out of process
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: core (show other bugs)
Version: git master
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: 4.9
Assignee: KWin default assignee
URL:
Keywords:
: 300955 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-13 16:18 UTC by Martin Flöser
Modified: 2012-05-31 18:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.9


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Flöser 2012-03-13 16:18:25 UTC
Users quite often kill the kwin kill helper resulting in a killed kwin. This is bad for the user experience.
Comment 1 Thomas Lübking 2012-04-17 19:28:37 UTC
Git commit e096e86e29f9c267d1e22dfedf1d5cd449958642 by Thomas Lübking.
Committed on 16/04/2012 at 23:52.
Pushed by luebking into branch 'master'.

detach killHelper process from KWin
FIXED-IN: 4.9
REVIEW: 104627

M  +12   -25   kwin/client.cpp
M  +1    -2    kwin/client.h

http://commits.kde.org/kde-workspace/e096e86e29f9c267d1e22dfedf1d5cd449958642
Comment 2 Martin Flöser 2012-05-31 18:12:46 UTC
*** Bug 300955 has been marked as a duplicate of this bug. ***