Bug 300264 - Plasma Desktop Shell crashed
Summary: Plasma Desktop Shell crashed
Status: RESOLVED DUPLICATE of bug 296175
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-18 17:42 UTC by artur.cuvasov
Modified: 2012-05-18 17:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description artur.cuvasov 2012-05-18 17:42:24 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.3.5-2.fc16.i686.PAE i686
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
- What I was doing when the application crashed:

Plasma Desktop Shell crashed right after closing ktorrents' unresponsive window. Ktorrent had an applet running.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb77547c0 (LWP 1849))]

Thread 3 (Thread 0xaf995b40 (LWP 1851)):
#0  0x4454cdcd in clock_gettime () from /lib/librt.so.1
#1  0x452db8f6 in do_gettime (frac=0xaf994f20, sec=0xaf994f18) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x453c2abf in QTimerInfoList::updateCurrentTime (this=0xaf994fa8) at kernel/qeventdispatcher_unix.cpp:343
#4  0xaf0004e0 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xaee41b40 (LWP 1855)):
#0  0xb7799424 in __kernel_vsyscall ()
#1  0x4450a12c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x48d6debd in QTWTF::TCMalloc_PageHeap::scavengerThread (this=this@entry=0x48e7c720) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0x48d6def0 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x48e7c720) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0x44506adf in start_thread () from /lib/libpthread.so.0
#5  0x4443a55e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77547c0 (LWP 1849)):
[KCrash Handler]
#7  0x4584c227 in KJob::isAutoDelete (this=this@entry=0xb025680) at /usr/src/debug/kdelibs-4.8.3/kdecore/jobs/kjob.cpp:361
#8  0x4584c651 in KJob::emitResult (this=0xb025680) at /usr/src/debug/kdelibs-4.8.3/kdecore/jobs/kjob.cpp:320
#9  0x4b063019 in Plasma::ServiceJob::setResult (this=0xb025680, result=...) at /usr/src/debug/kdelibs-4.8.3/plasma/servicejob.cpp:92
#10 0xb4ffccf9 in StatusNotifierItemJob::contextMenuReady (this=0xb025680, menu=0xa7cb460) at /usr/src/debug/kde-workspace-4.8.3/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#11 0x453a80ee in QMetaObject::activate (sender=0xad6ba00, m=0xb5005838, local_signal_index=0, argv=0xbf85b528) at kernel/qobject.cpp:3547
#12 0xb4ff8496 in StatusNotifierItemSource::contextMenuReady (this=this@entry=0xad6ba00, _t1=0xa7cb460) at /usr/src/debug/kde-workspace-4.8.3/i686-redhat-linux-gnu/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:122
#13 0xb4ff84d2 in StatusNotifierItemSource::contextMenuReady (this=this@entry=0xad6ba00) at /usr/src/debug/kde-workspace-4.8.3/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:363
#14 0xb4ffb724 in qt_static_metacall (_a=0xbf85b60c, _id=1, _o=0xad6ba00, _c=<optimized out>) at /usr/src/debug/kde-workspace-4.8.3/i686-redhat-linux-gnu/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:64
#15 StatusNotifierItemSource::qt_static_metacall (_o=0xad6ba00, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf85b60c) at /usr/src/debug/kde-workspace-4.8.3/i686-redhat-linux-gnu/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:57
#16 0x453a80ee in QMetaObject::activate (sender=0xa8fac88, m=0x46c00060, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#17 0x46be29e6 in DBusMenuImporter::menuUpdated() () from /lib/libdbusmenu-qt.so.2
#18 0x46be3184 in DBusMenuImporter::slotMenuAboutToShow() () from /lib/libdbusmenu-qt.so.2
#19 0x46beacb8 in ?? () from /lib/libdbusmenu-qt.so.2
#20 0x453a80ee in QMetaObject::activate (sender=0xa7cb460, m=0x464f17d4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#21 0x4601e576 in QMenu::aboutToShow (this=this@entry=0xa7cb460) at .moc/release-shared/moc_qmenu.cpp:164
#22 0x46025158 in qt_static_metacall (_a=0xbf85b994, _id=0, _o=0xa7cb460, _c=<optimized out>) at .moc/release-shared/moc_qmenu.cpp:73
#23 QMenu::qt_static_metacall (_o=0xa7cb460, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf85b994) at .moc/release-shared/moc_qmenu.cpp:67
#24 0x453984ef in QMetaMethod::invoke (this=0xbf85bac4, object=0xa7cb460, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#25 0x4539abba in QMetaObject::invokeMethod (obj=0xa7cb460, member=0x46bf2d72 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#26 0x46be29a0 in DBusMenuImporter::updateMenu() () from /lib/libdbusmenu-qt.so.2
#27 0xb4ff8054 in StatusNotifierItemSource::contextMenu (this=0xad6ba00, x=1054, y=751) at /usr/src/debug/kde-workspace-4.8.3/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:466
#28 0xb4ffd6c4 in StatusNotifierItemJob::start (this=0xb025680) at /usr/src/debug/kde-workspace-4.8.3/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#29 0x4b062bda in autoStart (this=<optimized out>) at /usr/src/debug/kdelibs-4.8.3/plasma/servicejob.cpp:47
#30 qt_static_metacall (_o=0xb025680, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdelibs-4.8.3/i686-redhat-linux-gnu/plasma/servicejob.moc:60
#31 Plasma::ServiceJob::qt_static_metacall (_o=0xb025680, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xb3101e0) at /usr/src/debug/kdelibs-4.8.3/i686-redhat-linux-gnu/plasma/servicejob.moc:54
#32 0x453a1a5b in QMetaCallEvent::placeMetaCall (this=0xb2360c8, object=0xb025680) at kernel/qobject.cpp:525
#33 0x453a60b3 in QObject::event (this=0xb025680, e=0xb2360c8) at kernel/qobject.cpp:1195
#34 0x45b6dfbc in QApplicationPrivate::notify_helper (this=0x9957680, receiver=0xb025680, e=0xb2360c8) at kernel/qapplication.cpp:4554
#35 0x45b72b2f in QApplication::notify (this=0xb2360c8, receiver=0xb025680, e=0xb2360c8) at kernel/qapplication.cpp:3936
#36 0x46973422 in KApplication::notify (this=0x99426d8, receiver=0xb025680, event=0xb2360c8) at /usr/src/debug/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#37 0x4538fa6e in QCoreApplication::notifyInternal (this=0x99426d8, receiver=0xb025680, event=0xb2360c8) at kernel/qcoreapplication.cpp:876
#38 0x45393a15 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x990d1c8) at kernel/qcoreapplication.cpp:1500
#40 0x45393c9d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#41 0x453c1f25 in sendPostedEvents () at kernel/qcoreapplication.h:236
#42 postEventSourceDispatch (s=s@entry=0x9957f80) at kernel/qeventdispatcher_glib.cpp:279
#43 0x4460ef11 in g_main_dispatch (context=0x9957e90) at gmain.c:2515
#44 g_main_context_dispatch (context=context@entry=0x9957e90) at gmain.c:3052
#45 0x4460f390 in g_main_context_iterate (context=context@entry=0x9957e90, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3123
#46 0x4460f472 in g_main_context_iteration (context=0x9957e90, may_block=1) at gmain.c:3184
#47 0x453c20b2 in QEventDispatcherGlib::processEvents (this=0x990dd30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#48 0x45c2050b in QGuiEventDispatcherGlib::processEvents (this=0x990dd30, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#49 0x4538e80d in QEventLoop::processEvents (this=this@entry=0xbf85c6f8, flags=...) at kernel/qeventloop.cpp:149
#50 0x4538eb09 in QEventLoop::exec (this=0xbf85c6f8, flags=...) at kernel/qeventloop.cpp:204
#51 0x45393d4b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#52 0x45b6bde5 in QApplication::exec () at kernel/qapplication.cpp:3815
#53 0x4773d456 in kdemain (argc=1, argv=0xbf85c8b4) at /usr/src/debug/kde-workspace-4.8.3/plasma/desktop/shell/main.cpp:120
#54 0x0804878c in main (argc=1, argv=0xbf85c8b4) at /usr/src/debug/kde-workspace-4.8.3/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 296175.

Possible duplicates by query: bug 296175, bug 282415.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-18 17:57:22 UTC

*** This bug has been marked as a duplicate of bug 296175 ***