Bug 282415 - plasma crashed after klicking an icon in the control bar
Summary: plasma crashed after klicking an icon in the control bar
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-20 15:55 UTC by erik6350
Modified: 2012-04-04 17:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (12.45 KB, text/plain)
2012-04-04 17:38 UTC, Justin Curtis Mathews
Details

Note You need to log in before you can comment on or make changes to this bug.
Description erik6350 2011-09-20 15:55:49 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.3
Operating System: Linux 3.0-4.slh.3-aptosid-686 i686
Distribution: Debian GNU/Linux 5.0.8 (lenny)

-- Information about the crash:
- What I was doing when the application crashed:

- PackageKit was in the process of removing a packackage

- After I have klicked the information icon in the controlbar (single left klick)
plasma hung up and crashed

- Unusual behavior I noticed:

The Icon didn't react after I have klicked it, the desktop hung up (cursor was still movable) and turned black

-- Backtrace:
Application: Plasma-Desktop-Umgebung (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb2039950 (LWP 3891))]

Thread 4 (Thread 0xafabab70 (LWP 3892)):
#0  0xb3177e11 in *__GI_clock_gettime (clock_id=1, tp=0xafab9fe8) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb631d635 in do_gettime (frac=0xafab9fe0, sec=0xafab9fd8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb63efe46 in QTimerInfoList::updateCurrentTime (this=0x9d513c4) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb63f01aa in QTimerInfoList::timerWait (this=0x9d513c4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb63eea03 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xafaba0fc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb63eea9d in timerSourcePrepare (source=0x9d51390, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb30dd74e in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb30de613 in ?? () from /lib/libglib-2.0.so.0
#9  0xb30dece4 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb63ef4d7 in QEventDispatcherGlib::processEvents (this=0x9d0a280, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb63c024d in QEventLoop::processEvents (this=0xafaba2a0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb63c0491 in QEventLoop::exec (this=0xafaba2a0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb62c369b in QThread::exec (this=0x9d4f478) at thread/qthread.cpp:492
#14 0xb63a0d8d in QInotifyFileSystemWatcherEngine::run (this=0x9d4f478) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb62c6503 in QThreadPrivate::start (arg=0x9d4f478) at thread/qthread_unix.cpp:320
#16 0xb31e0c39 in start_thread (arg=0xafabab70) at pthread_create.c:304
#17 0xb75bc96e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xa7663b70 (LWP 3893)):
#0  0xb3177e11 in *__GI_clock_gettime (clock_id=1, tp=0xa7662fe8) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb631d635 in do_gettime (frac=0xa7662fe0, sec=0xa7662fd8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb63efe46 in QTimerInfoList::updateCurrentTime (this=0xaf1019bc) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb63f01aa in QTimerInfoList::timerWait (this=0xaf1019bc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb63eea03 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xa76630fc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb63eea9d in timerSourcePrepare (source=0xaf101988, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb30dd74e in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb30de613 in ?? () from /lib/libglib-2.0.so.0
#9  0xb30dece4 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb63ef4d7 in QEventDispatcherGlib::processEvents (this=0xa61c968, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb63c024d in QEventLoop::processEvents (this=0xa76632a0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb63c0491 in QEventLoop::exec (this=0xa76632a0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb62c369b in QThread::exec (this=0xa61b280) at thread/qthread.cpp:492
#14 0xb63a0d8d in QInotifyFileSystemWatcherEngine::run (this=0xa61b280) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb62c6503 in QThreadPrivate::start (arg=0xa61b280) at thread/qthread_unix.cpp:320
#16 0xb31e0c39 in start_thread (arg=0xa7663b70) at pthread_create.c:304
#17 0xb75bc96e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xa4f9db70 (LWP 3902)):
#0  0xb76ed424 in __kernel_vsyscall ()
#1  0xb31e520a in __pthread_cond_wait (cond=0xb568be90, mutex=0xb568be78) at pthread_cond_wait.c:153
#2  0xb75c9a5d in __pthread_cond_wait (cond=0xb568be90, mutex=0xb568be78) at forward.c:139
#3  0xb506d51b in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb506d63f in ?? () from /usr/lib/libQtWebKit.so.4
#5  0xb31e0c39 in start_thread (arg=0xa4f9db70) at pthread_create.c:304
#6  0xb75bc96e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb2039950 (LWP 3891)):
[KCrash Handler]
#7  0xb669def7 in KJob::isAutoDelete (this=0xb52c850) at ../../kdecore/jobs/kjob.cpp:355
#8  0xb669e240 in KJob::emitResult (this=0xb52c850) at ../../kdecore/jobs/kjob.cpp:314
#9  0xb7389de8 in Plasma::ServiceJob::setResult (this=0xb52c850, result=...) at ../../plasma/servicejob.cpp:80
#10 0xaea792b6 in StatusNotifierItemJob::contextMenuReady (this=0xb52c850, menu=0xb42a688) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#11 0xaea79347 in StatusNotifierItemJob::qt_metacall (this=0xb52c850, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf897f28) at ./statusnotifieritemjob.moc:75
#12 0xb63c75dd in metacall (argv=0xbf897f28, idx=28, cl=QMetaObject::InvokeMetaMethod, object=0xb52c850) at kernel/qmetaobject.cpp:237
#13 QMetaObject::metacall (object=0xb52c850, cl=QMetaObject::InvokeMetaMethod, idx=28, argv=0xbf897f28) at kernel/qmetaobject.cpp:232
#14 0xb63d6320 in QMetaObject::activate (sender=0xb3a0520, m=0xaea824d8, local_signal_index=0, argv=0xbf897f28) at kernel/qobject.cpp:3278
#15 0xaea74a15 in StatusNotifierItemSource::contextMenuReady (this=0xb3a0520, _t1=0xb42a688) at ./statusnotifieritemsource.moc:109
#16 0xaea74a51 in StatusNotifierItemSource::contextMenuReady (this=0xb3a0520) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:363
#17 0xaea77f4c in StatusNotifierItemSource::qt_metacall (this=0xb3a0520, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf898034) at ./statusnotifieritemsource.moc:90
#18 0xb63c75dd in metacall (argv=0xbf898034, idx=15, cl=QMetaObject::InvokeMetaMethod, object=0xb3a0520) at kernel/qmetaobject.cpp:237
#19 QMetaObject::metacall (object=0xb3a0520, cl=QMetaObject::InvokeMetaMethod, idx=15, argv=0xbf898034) at kernel/qmetaobject.cpp:232
#20 0xb63d6320 in QMetaObject::activate (sender=0xb3ce8c8, m=0xb3272540, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#21 0xb3254ae5 in DBusMenuImporter::menuUpdated() () from /usr/lib/libdbusmenu-qt.so.2
#22 0xb3255394 in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#23 0xb325e04c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#24 0xb63c75dd in metacall (argv=0xbf898264, idx=10, cl=QMetaObject::InvokeMetaMethod, object=0xb3ce8c8) at kernel/qmetaobject.cpp:237
#25 QMetaObject::metacall (object=0xb3ce8c8, cl=QMetaObject::InvokeMetaMethod, idx=10, argv=0xbf898264) at kernel/qmetaobject.cpp:232
#26 0xb63d6320 in QMetaObject::activate (sender=0xb42a688, m=0xb62365cc, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#27 0xb5d8c2f5 in QMenu::aboutToShow (this=0xb42a688) at .moc/release-shared/moc_qmenu.cpp:151
#28 0xb5d91348 in QMenu::qt_metacall (this=0xb42a688, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf8983d8) at .moc/release-shared/moc_qmenu.cpp:97
#29 0xb63c75dd in metacall (argv=0xbf8983d8, idx=27, cl=QMetaObject::InvokeMetaMethod, object=0xb42a688) at kernel/qmetaobject.cpp:237
#30 QMetaObject::metacall (object=0xb42a688, cl=QMetaObject::InvokeMetaMethod, idx=27, argv=0xbf8983d8) at kernel/qmetaobject.cpp:232
#31 0xb63c9030 in QMetaMethod::invoke (this=0xbf898744, object=0xb42a688, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1578
#32 0xb63cb458 in QMetaObject::invokeMethod (obj=0xb42a688, member=0xb3265ff2 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1151
#33 0xb3254a9f in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#34 0xaea745b3 in StatusNotifierItemSource::contextMenu (this=0xb3a0520, x=1034, y=782) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:466
#35 0xaea7a354 in StatusNotifierItemJob::start (this=0xb52c850) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#36 0xb7389c5f in slotStart (this=<optimized out>) at ../../plasma/servicejob.cpp:37
#37 Plasma::ServiceJob::qt_metacall (this=0xb52c850, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xb8bd118) at ./servicejob.moc:82
#38 0xaea79322 in StatusNotifierItemJob::qt_metacall (this=0xb52c850, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0xb8bd118) at ./statusnotifieritemjob.moc:70
#39 0xb63c75dd in metacall (argv=0xb8bd118, idx=26, cl=QMetaObject::InvokeMetaMethod, object=0xb52c850) at kernel/qmetaobject.cpp:237
#40 QMetaObject::metacall (object=0xb52c850, cl=QMetaObject::InvokeMetaMethod, idx=26, argv=0xb8bd118) at kernel/qmetaobject.cpp:232
#41 0xb63d1f25 in QMetaCallEvent::placeMetaCall (this=0xb9ed220, object=0xb52c850) at kernel/qobject.cpp:535
#42 0xb63d943f in QObject::event (this=0xb52c850, e=0xb9ed220) at kernel/qobject.cpp:1217
#43 0xb58ee7a4 in notify_helper (e=0xb9ed220, receiver=0xb52c850, this=0x9cc9728) at kernel/qapplication.cpp:4467
#44 QApplicationPrivate::notify_helper (this=0x9cc9728, receiver=0xb52c850, e=0xb9ed220) at kernel/qapplication.cpp:4439
#45 0xb58f3b32 in QApplication::notify (this=0xb9ed220, receiver=0xb52c850, e=0xb9ed220) at kernel/qapplication.cpp:4214
#46 0xb6a56571 in KApplication::notify (this=0x9cb2270, receiver=0xb52c850, event=0xb9ed220) at ../../kdeui/kernel/kapplication.cpp:311
#47 0xb63c122e in QCoreApplication::notifyInternal (this=0x9cb2270, receiver=0xb52c850, event=0xb9ed220) at kernel/qcoreapplication.cpp:731
#48 0xb63c49f4 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#49 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9c6c4e0) at kernel/qcoreapplication.cpp:1372
#50 0xb63c4b3c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#51 0xb63ef044 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#52 postEventSourceDispatch (s=0x9cd4300) at kernel/qeventdispatcher_glib.cpp:277
#53 0xb30de252 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#54 0xb30dea30 in ?? () from /lib/libglib-2.0.so.0
#55 0xb30dece4 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#56 0xb63ef477 in QEventDispatcherGlib::processEvents (this=0x9c6ebf0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#57 0xb59a372a in QGuiEventDispatcherGlib::processEvents (this=0x9c6ebf0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#58 0xb63c024d in QEventLoop::processEvents (this=0xbf899254, flags=...) at kernel/qeventloop.cpp:149
#59 0xb63c0491 in QEventLoop::exec (this=0xbf899254, flags=...) at kernel/qeventloop.cpp:201
#60 0xb63c4bea in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#61 0xb58ec624 in QApplication::exec () at kernel/qapplication.cpp:3741
#62 0xb76a6c8b in kdemain (argc=1, argv=0xbf899464) at ../../../../plasma/desktop/shell/main.cpp:120
#63 0x0804855b in main (argc=1, argv=0xbf899464) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 260710, bug 259530, bug 257691, bug 257505.

Reported using DrKonqi
Comment 1 Dario Andres 2011-09-29 14:00:22 UTC
[Comment from a bug triager]
This issue is being tracked at bug 241562, merging.
Thanks

*** This bug has been marked as a duplicate of bug 241562 ***
Comment 2 Justin Curtis Mathews 2012-04-04 17:38:24 UTC
Created attachment 70154 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.8.1 (4.8.1) using Qt 4.8.1

- What I was doing when the application crashed: Burning a Data DVD with Brasero and having Dolphin open and the Package manager open.

- Unusual behavior I noticed: froze then crashed to a blue screen.

- Custom settings of the application: none.

-- Backtrace (Reduced):
#6  0x00007fcd708f54f4 in KJob::isAutoDelete (this=0x46b8b70) at ../../kdecore/jobs/kjob.cpp:361
#7  0x00007fcd708f5868 in KJob::emitResult (this=0x46b8b70) at ../../kdecore/jobs/kjob.cpp:320
[...]
#13 0x00007fcd6837b79c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
[...]
#15 0x00007fcd701f6f01 in QMetaMethod::invoke (this=0x7fffbb3a0a40, object=0x257c230, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
[...]
#17 0x00007fcd6837a5a1 in DBusMenuImporter::updateMenu() () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2