Bug 299868 - missing password field in ask password dialog when using wpa2 connections
Summary: missing password field in ask password dialog when using wpa2 connections
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: Wireless (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL:
Keywords:
: 299379 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-12 09:47 UTC by Alin M Elena
Modified: 2013-02-26 21:08 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.9.0.8


Attachments
.xsession-errors attached (50.87 KB, application/octet-stream)
2012-05-12 17:58 UTC, Alin M Elena
Details
Patch to fix wpa2eap ask password dialog (1.67 KB, patch)
2012-05-12 19:47 UTC, Lamarque V. Souza
Details
Fix missing field in password dialog (12.43 KB, patch)
2013-02-17 18:29 UTC, Lamarque V. Souza
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alin M Elena 2012-05-12 09:47:10 UTC
I try to connect to eduroam a wpa2 enterprise network... This worked before...

to eliminate any idiocy related to system connections I created a simple user connection.
I set up all my credentials... and tell it to store my password..
it starts connecting and then after some time presents me a window asking me to introduce secrets (by the way the field is password a good design would be consistent and ask for that) but there is no place to introduce anything... I will add a film with all this.

here is the error log of nm
May 12 10:35:14 abbaton NetworkManager[714]: <warn> No agents were available for this request.
May 12 10:35:14 abbaton NetworkManager[714]: <info> (wlan0): device state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
May 12 10:35:14 abbaton NetworkManager[714]: <warn> Activation (wlan0) failed for access point (eduroam)
May 12 10:35:14 abbaton NetworkManager[714]: <info> Marking connection 'eduroam' invalid.
May 12 10:35:14 abbaton NetworkManager[714]: <warn> Activation (wlan0) failed.
May 12 10:35:14 abbaton NetworkManager[714]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
May 12 10:35:14 abbaton NetworkManager[714]: <info> (wlan0): deactivating device (reason 'none') [0]
May 12 10:35:14 abbaton NetworkManager[714]: <info> Policy set 'wire' (eth0) as default for IPv4 routing and DNS.
May 12 10:35:14 abbaton NetworkManager[714]: <info> Policy set 'wire' (eth0) as default for IPv4 routing and DNS.
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) starting connection 'eduroam'
May 12 10:35:17 abbaton NetworkManager[714]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
May 12 10:35:17 abbaton NetworkManager[714]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0/wireless): access point 'eduroam' has security, but secrets are required.
May 12 10:35:17 abbaton NetworkManager[714]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
May 12 10:35:17 abbaton NetworkManager[714]: <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
May 12 10:35:17 abbaton NetworkManager[714]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0/wireless): connection 'eduroam' has security, and secrets exist.  No new secrets needed.
May 12 10:35:17 abbaton NetworkManager[714]: <info> Config: added 'ssid' value 'eduroam'
May 12 10:35:17 abbaton NetworkManager[714]: <info> Config: added 'scan_ssid' value '1'
May 12 10:35:17 abbaton NetworkManager[714]: <info> Config: added 'key_mgmt' value 'WPA-EAP'
May 12 10:35:17 abbaton NetworkManager[714]: <info> Config: added 'password' value '<omitted>'
May 12 10:35:17 abbaton NetworkManager[714]: <info> Config: added 'eap' value 'TTLS'
May 12 10:35:17 abbaton NetworkManager[714]: <info> Config: added 'fragment_size' value '1300'
May 12 10:35:17 abbaton NetworkManager[714]: <info> Config: added 'phase2' value 'auth=PAP'
May 12 10:35:17 abbaton NetworkManager[714]: <info> Config: added 'ca_cert' value '/home/alin/Personal/UCD.crt'
May 12 10:35:17 abbaton NetworkManager[714]: <info> Config: added 'identity' value 'alin.elena@ucd.ie'
May 12 10:35:17 abbaton NetworkManager[714]: <info> Config: added 'bgscan' value 'simple:30:-45:300'
May 12 10:35:17 abbaton NetworkManager[714]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
May 12 10:35:17 abbaton NetworkManager[714]: <info> Config: set interface ap_scan to 1
May 12 10:35:17 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May 12 10:35:19 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: scanning -> authenticating
May 12 10:35:19 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: authenticating -> associating
May 12 10:35:19 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associating -> associated
May 12 10:35:19 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associated -> disconnected
May 12 10:35:19 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May 12 10:35:20 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: scanning -> authenticating
May 12 10:35:20 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: authenticating -> associated
May 12 10:35:23 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associated -> disconnected
May 12 10:35:23 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May 12 10:35:24 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: scanning -> authenticating
May 12 10:35:24 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: authenticating -> associating
May 12 10:35:24 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associating -> associated
May 12 10:35:24 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associated -> disconnected
May 12 10:35:25 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May 12 10:35:26 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: scanning -> authenticating
May 12 10:35:26 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: authenticating -> associated
May 12 10:35:26 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associated -> disconnected
May 12 10:35:26 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May 12 10:35:27 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: scanning -> authenticating
May 12 10:35:27 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: authenticating -> associating
May 12 10:35:27 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associating -> associated
May 12 10:35:27 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associated -> disconnected
May 12 10:35:27 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May 12 10:35:29 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: scanning -> authenticating
May 12 10:35:29 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: authenticating -> associating
May 12 10:35:29 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associating -> associated
May 12 10:35:29 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associated -> disconnected
May 12 10:35:29 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May 12 10:35:30 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: scanning -> authenticating
May 12 10:35:30 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: authenticating -> associated
May 12 10:35:30 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associated -> disconnected
May 12 10:35:30 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May 12 10:35:32 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: scanning -> authenticating
May 12 10:35:32 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: authenticating -> associating
May 12 10:35:32 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associating -> associated
May 12 10:35:32 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associated -> disconnected
May 12 10:35:32 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May 12 10:35:33 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: scanning -> authenticating
May 12 10:35:33 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: authenticating -> associated
May 12 10:35:42 abbaton NetworkManager[714]: <warn> Activation (wlan0/wireless): association took too long.
May 12 10:35:42 abbaton NetworkManager[714]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
May 12 10:35:42 abbaton NetworkManager[714]: <warn> Activation (wlan0/wireless): asking for new secrets
May 12 10:35:42 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associated -> disconnected
May 12 10:35:42 abbaton NetworkManager[714]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
May 12 10:35:48 abbaton NetworkManager[714]: <warn> No agents were available for this request.
May 12 10:35:48 abbaton NetworkManager[714]: <info> (wlan0): device state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
May 12 10:35:48 abbaton NetworkManager[714]: <warn> Activation (wlan0) failed for access point (eduroam)
May 12 10:35:48 abbaton NetworkManager[714]: <info> Marking connection 'eduroam' invalid.
May 12 10:35:48 abbaton NetworkManager[714]: <warn> Activation (wlan0) failed.
May 12 10:35:48 abbaton NetworkManager[714]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
May 12 10:35:48 abbaton NetworkManager[714]: <info> (wlan0): deactivating device (reason 'none') [0]
May 12 10:35:48 abbaton NetworkManager[714]: <info> Policy set 'wire' (eth0) as default for IPv4 routing and DNS.
May 12 10:35:48 abbaton NetworkManager[714]: <info> Policy set 'wire' (eth0) as default for IPv4 routing and DNS.

Reproducible: Always
Comment 1 Alin M Elena 2012-05-12 09:49:03 UTC
I use kde trunk... just in case...S | Name                        | Type    | Version                    | Arch   | Repository                                              
--+-----------------------------+---------+----------------------------+--------+---------------------------------------------------------
i | NetworkManager              | package | 0.9.4.0-151.5              | x86_64 | rwooninck's Home Project (openSUSE_Factory)             
i | NetworkManager-kde4-lang    | package | 0.9.60git.1336635528-372.1 | noarch | home:rwooninck:UNSTABLE_KDE4 (KDE_Qt48_openSUSE_Factory)
i | NetworkManager-kde4-libs    | package | 0.9.60git.1336635528-372.1 | x86_64 | home:rwooninck:UNSTABLE_KDE4 (KDE_Qt48_openSUSE_Factory)
i | NetworkManager-lang         | package | 0.9.4.0-151.5              | noarch | rwooninck's Home Project (openSUSE_Factory)             
i | NetworkManager-openvpn      | package | 0.9.4.0-1.3                | x86_64 | openSUSE-Factory-Oss                                    
i | NetworkManager-openvpn-kde4 | package | 0.9.60git.1336635528-372.1 | x86_64 | home:rwooninck:UNSTABLE_KDE4 (KDE_Qt48_openSUSE_Factory)
i | NetworkManager-openvpn-lang | package | 0.9.4.0-1.3                | noarch | openSUSE-Factory-Oss                                    
i | NetworkManager-pptp         | package | 0.9.4.0-1.3                | x86_64 | openSUSE-Factory-Oss                                    
i | NetworkManager-pptp-kde4    | package | 0.9.60git.1336635528-372.1 | x86_64 | home:rwooninck:UNSTABLE_KDE4 (KDE_Qt48_openSUSE_Factory)
i | NetworkManager-pptp-lang    | package | 0.9.4.0-1.3                | noarch | openSUSE-Factory-Oss                                    
i | glib-networking             | package | 2.32.1-1.2                 | x86_64 | openSUSE-Factory-Oss                                    
i | glib-networking-lang        | package | 2.32.1-1.2                 | noarch | openSUSE-Factory-Oss                                    
i | kdenetwork4-filesharing     | package | 4.8.42-7.2                 | x86_64 | home:rwooninck:UNSTABLE_KDE4 (KDE_Qt48_openSUSE_Factory)
i | libQtNetworkManager0        | package | 0.5.0git.1332199137-275.1  | x86_64 | home:rwooninck:UNSTABLE_KDE4 (KDE_Qt48_openSUSE_Factory)
i | libproxy1-networkmanager    | package | 0.4.7-12.3                 | x86_64 | openSUSE-Factory-Oss                                    
i | plasmoid-networkmanagement  | package | 0.9.60git.1336635528-372.1 | x86_64 | home:rwooninck:UNSTABLE_KDE4 (KDE_Qt48_openSUSE_Factory)
i | yast2-network               | package | 2.23.0-1.1                 | x86_64 | openSUSE-Factory-Oss
Comment 2 Alin M Elena 2012-05-12 09:56:33 UTC
here is the video showing the bug
http://www.youtube.com/watch?v=SyIhc1qMJog
Comment 3 Lamarque V. Souza 2012-05-12 14:30:31 UTC

*** This bug has been marked as a duplicate of bug 299379 ***
Comment 4 Lamarque V. Souza 2012-05-12 14:57:25 UTC
Enable all debug messages using kdebugdialog, reproduce the bug and send me the file ~/.xsession-errors.
Comment 5 Lamarque V. Souza 2012-05-12 15:09:56 UTC
by the way, which Plasma NM version do you use? I mean, not the package version ( 0.9.60git.1336635528-372.1), which means nothing for me since OpenSuse does not use the official version for Plasma NM (historical reasons). Look at the version in "Settings..." -> "Other".
Comment 6 Alin M Elena 2012-05-12 15:19:17 UTC
deleted my ~/.xsession-errors
recreated it... to be sure is empty
activated all the debugs...
and tried to connect... the .xsession-errors is totally empty.
Alin

I can connect to wpa-psk networks that keep their passwords in kwallet...

the version is 0.9.1_rc1 from 20120506
Comment 7 Lamarque V. Souza 2012-05-12 15:38:04 UTC
You should not have deleted the .xsession-errors, the file is written by kdm and some other processes. The Linux kernel doesl not release the file's data until all process that have it opened close their file handlers. You logout and and login after deleting ~/.xsession-errors. If you compiled Qt or kdelibs without debug messages there will be no usefull messages in ~/.xsession-errors too.
Comment 8 Alin M Elena 2012-05-12 17:58:23 UTC
Created attachment 71048 [details]
.xsession-errors attached

here is the content of the .xsession-errors... before turning wifi on.. I added a ============
so I pasted only after.
Comment 9 Lamarque V. Souza 2012-05-12 18:41:30 UTC
I am starting to think that the real problem is in NetworkManager or wpa_supplicant. The repeated messages like the ones below

May 12 10:35:17 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May 12 10:35:19 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: scanning -> authenticating
May 12 10:35:19 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: authenticating -> associating
May 12 10:35:19 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associating -> associated
May 12 10:35:19 abbaton NetworkManager[714]: <info> (wlan0): supplicant interface state: associated -> disconnected

indicates wpa_supplicant is not able to associate to the access point. The fact that Plasma NM is asking for password is because NetworkManager always ask for *new* password when the connection fails, even if the password is correct and something else is causing the problem. The fact that the password dialog is empty is because the current Plasma NM implementation does not know what secrets it should ask for WPA2EAP connections. I can fix the last problem but if the real problem is in NM or wpa_supplicant then it will not solve the problem with connecting to eduroam.
Comment 10 Lamarque V. Souza 2012-05-12 18:42:43 UTC
*** Bug 299379 has been marked as a duplicate of this bug. ***
Comment 11 Lamarque V. Souza 2012-05-12 19:47:46 UTC
Created attachment 71053 [details]
Patch to fix wpa2eap ask password dialog

Can you try the attached and check if it fixes the empty password dialog? There should be from one to three widgets in the dialog with this patch.
Comment 12 Alin M Elena 2012-05-12 20:27:47 UTC
Hi,

First I will try to see if the issue is the disconnection... I will change to the wl driver instead of the opensouce b43 one.

I will  generate a package, probably tomorrow.

Alin
Comment 13 Lamarque V. Souza 2012-05-12 20:37:06 UTC
If you fix the problem with eduroam probably the ask password dialog will not show up anymore.
Comment 14 Alin M Elena 2012-05-14 08:11:07 UTC
the good news which is bad forme is that I get the same issues with the wl driver too.

I still did not have time to test the patch on the secrets issue... maybe sometime today. I will keep you posted.

Alin
Comment 15 Lamarque V. Souza 2012-06-22 00:18:05 UTC
Git commit 6b8aaf68dddc1214c49d8201dafbbef44748b035 by Lamarque V. Souza.
Committed on 22/06/2012 at 02:16.
Pushed by lvsouza into branch 'master'.

Try to fix ask password dialog for WPA2 connections.

M  +14   -0    libs/service/secretstorage.cpp

http://commits.kde.org/networkmanagement/6b8aaf68dddc1214c49d8201dafbbef44748b035
Comment 16 Lamarque V. Souza 2012-06-22 00:24:26 UTC
Git commit 244649c4760794a340bfa4bfe2234b7a08e03f90 by Lamarque V. Souza.
Committed on 22/06/2012 at 02:16.
Pushed by lvsouza into branch 'nm09'.

Try to fix ask password dialog for WPA2 connections.
(cherry picked from commit 6b8aaf68dddc1214c49d8201dafbbef44748b035)

M  +14   -0    libs/service/secretstorage.cpp

http://commits.kde.org/networkmanagement/244649c4760794a340bfa4bfe2234b7a08e03f90
Comment 17 marcnesium 2012-07-30 16:49:35 UTC
I compiled and installed Plasma NM 0.9.0.4 since you mentioned eduroam in this post http://lamarque-lvs.blogspot.de/2012/07/plasma-nm-0904.html on my T400 with Ubuntu 12.04 and KDE 4.8.4.
Unfortunately my personal situation has not improved. Since i'm not a kde developer (but i guess quite an advanced kde user) i would like to "help". By testing or sending logs or whatever.
Every time i use an eduroam connection it will break in an random amount of time. Only way to get it working again is to "Disable wireless" (button to the left button). Sometimes a connection stays for an hour, sometime just a minute or two. Please tell me how to help you the help me ; )
Comment 18 Lamarque V. Souza 2012-07-30 18:08:46 UTC
@marcnesium, the problem reported here is about the missing password field when trying to activate a wpa2 enterprise connection. Once the connection is made then it is up to NetworkManager and the wifi driver to sustain the connection until you choose to disconnect.

By what you wrote there seems to be an instabiligy in your wifi driver or access point. You should check if there are too many packet loss using the command below:

ping -s 1000 - c 60 <ip of your access point>

the '-s 1000" uses 1000 bytes packets for testing, that's overkill, but if it works ok with that packet size then it should be ok with smaller packets too. If there are more 5% of packet loss then your problem is probably related to instability in your network and there is nothing I can do about it.
Comment 19 marcnesium 2012-07-30 19:04:54 UTC
@Lamarque: Thanks for answering that quickly!
Just did that test. Result: 60 packets transmitted, 60 received, 0% packet loss, time 59080ms
Perhaps i can provide some more infos: My guess is: that problem is not access point related, because that happens in two different cities at different universities (i guess different hardware, but i don't know).
I have also a problem with password entering: my password is stored by networkmanager. And when i connect for the first time every thing works fine - i don't have to enter my password and there is not dialogue popping up. But when the connection goes down after a random amount of time, a tiny little window popps up. it wants me to enter my pw, but there is no text field for that (nothing else in there, but a show the pw button). Whatever i do with this dialogue, the connection does not come up again. Like i said, disabling wireless is the only way.
What this eduroam connection uses:
WPA2 Enterprise, EAP (PEAP), PEAP version: auto, MSCHAPv2.
Wifi driver is iwlwifi.
I try to debug this connection since days... it is really frustrating. I don't know where to start.
http://pastebin.com/b5vz761Y Here is a piece of my syslog.
Any further ideas? Thanks in advance!
Comment 20 Lamarque V. Souza 2012-07-30 19:46:13 UTC
Ok, so your connection is rock solid in terms of packet loss. If the problem happens in more than one city then it is not a problem with access points indeed.

That "tiny little window popup" is the password dialog, the missing text field is the problem I tried to solve and that I mentioned in Plasma NM 0.9.0.4's release announcement. So the problem is not fixed, that's bad.

Even if I fix this bug with the password field you will still have to type the password everytime the connection drops or NetworkManager will never try to reconnect.

Please enable all debug messages using kdebugdialog program, reproduce the problem and send me the file ~/.xsession-errors. If you can "git pull" the repo and recompile it would be better since I added a couple of debug messages that could help me debug the problem.
Comment 21 Lamarque V. Souza 2012-07-30 19:51:49 UTC
Git commit 96246a4aa370873dee982846cde543091be086b6 by Lamarque V. Souza.
Committed on 30/07/2012 at 21:43.
Pushed by lvsouza into branch 'master'.

Add kDebug() calls to debug problem with missing password field with
WPA2 enterprise connections.

M  +2    -0    libs/service/secretstorage.cpp
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/96246a4aa370873dee982846cde543091be086b6
Comment 22 Lamarque V. Souza 2012-07-30 19:53:47 UTC
Git commit 4655cac5d7e06594d56b69c08256a69e38a43dda by Lamarque V. Souza.
Committed on 30/07/2012 at 21:44.
Pushed by lvsouza into branch 'nm09'.

Add kDebug() calls to debug problem with missing password field with
WPA2 enterprise connections.

M  +2    -0    libs/service/secretstorage.cpp
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/4655cac5d7e06594d56b69c08256a69e38a43dda
Comment 23 Erik Quaeghebeur 2013-02-07 08:59:05 UTC
I get hit by this bug in KDE 4.9.5 on Gentoo, with NetworkManager 0.9.6.4.
My eduroam settings, see http://helpdesk.ugent.be/eduroam/eduroam_ubuntu.php
I've input my username and password, but nevertheless get a dialog to provide 'secrets' with only a selection box, but no input fields. However, I sometimes do get connected...
Comment 24 Jan Grulich 2013-02-12 10:29:34 UTC
Yes, this bug is still present. I tried to fix it but I cannot find where is the problem. I will try to fix this problem at school where we also have eduroam.
Comment 25 Jan Grulich 2013-02-13 11:04:05 UTC
I have fix for this problem and I hope that it works. Check https://git.reviewboard.kde.org/r/108941/
Comment 26 JantarMantar 2013-02-13 15:04:28 UTC
I am now up to KDE 4.10 (Using stock Chakra Benz). I have never been able to connect to my employer's wifi network working with KDE. I have no problems connecting using windows (of course) and even my android phone can connect every single time with no problems. This is definitely a bug that is still present in KDE. If anyone has a workaround please let me know. 

Thanks
Comment 27 Lamarque V. Souza 2013-02-17 18:29:48 UTC
Created attachment 77385 [details]
Fix missing field in password dialog

Can someone test if the attached patch fixes this problem?
Comment 28 Lamarque V. Souza 2013-02-19 20:02:34 UTC
Git commit 732dc9b929e3f7f5fa8691e711b2ee29195f94fe by Lamarque V. Souza.
Committed on 17/02/2013 at 19:28.
Pushed by lvsouza into branch 'nm09'.

Fix missing password field in wpa2 password dialog.
(cherry picked from commit e8726711de16f792ed4e96f5896361da0eef7d66)

M  +1    -1    libs/internals/setting.cpp
M  +1    -1    libs/internals/setting.h
M  +7    -7    libs/internals/settings/802-11-wireless-security.cpp
M  +1    -1    libs/internals/settings/802-11-wireless-security.h
M  +4    -4    libs/internals/settings/802-1x.cpp
M  +1    -1    libs/internals/settings/802-1x.h
M  +2    -2    libs/internals/settings/cdma.cpp
M  +1    -1    libs/internals/settings/cdma.h
M  +3    -3    libs/internals/settings/gsm.cpp
M  +1    -1    libs/internals/settings/gsm.h
M  +2    -2    libs/internals/settings/pppoe.cpp
M  +1    -1    libs/internals/settings/pppoe.h
M  +1    -1    libs/internals/settings/vpn.cpp
M  +1    -1    libs/internals/settings/vpn.h
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/732dc9b929e3f7f5fa8691e711b2ee29195f94fe
Comment 29 Alex Fiestas 2013-02-26 20:52:51 UTC
Shouldn't this bug be set as resolved?
Comment 30 Lamarque V. Souza 2013-02-26 21:08:22 UTC
(In reply to comment #29)
> Shouldn't this bug be set as resolved?

I was just waiting for someone to confirm the fix since I cannot reproduce it here. jgrulich has just confirmed to me that it is fixed.