Bug 299379 - The networkmanagement widget opens an empty dialog box for a Wifi WPA-EAP network
Summary: The networkmanagement widget opens an empty dialog box for a Wifi WPA-EAP net...
Status: RESOLVED DUPLICATE of bug 299868
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: 0.9
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-04 16:19 UTC by Laurent Bonnaud
Modified: 2012-05-12 18:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (10.95 KB, image/png)
2012-05-04 16:21 UTC, Laurent Bonnaud
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Bonnaud 2012-05-04 16:19:02 UTC
I try to use a Wifi network that is protected by WPA-EAP (also called "WPA entreprise"). When I select this network, the KDE networkmanagement widget opens a dialog box where a password seems to be expected, but this dialog box contains no text field.
I will attach a screenshot when the KDE BTS will let me...

BTW, the networkmanagement widget does not appear as a plasma component in this bug reporting tool.


Reproducible: Always

Steps to Reproduce:
1. Try to connect to a WPA-EAP Wifi network.

Actual Results:  
A dialog box appears with no text field.


Expected Results:  
A dialog box that let me input my password.


I also tried to enter my password in the Wifi network properties, but the connection still fails and the dialog box appears every few minutes, which is very annoying.
Comment 1 Laurent Bonnaud 2012-05-04 16:21:14 UTC
Created attachment 70857 [details]
screenshot
Comment 2 Laurent Bonnaud 2012-05-04 16:33:46 UTC
This is with KDE 4.8.3 from the Kubuntu PPA.

Package: plasma-widget-networkmanagement
Version: 0.9.0.1-0ubuntu2
Comment 3 Lamarque V. Souza 2012-05-06 03:30:31 UTC
Please send me your ~/.xsession-errors. This bug is probably a consequence of the problem in #291874.

*** This bug has been marked as a duplicate of bug 291874 ***
Comment 4 Lamarque V. Souza 2012-05-12 14:30:31 UTC
*** Bug 299868 has been marked as a duplicate of this bug. ***
Comment 5 Lamarque V. Souza 2012-05-12 18:42:43 UTC
Marking as duplicate of #299868 because the latter contains more useful information about this bug.

*** This bug has been marked as a duplicate of bug 299868 ***