Bug 299674 - Transferred message
Summary: Transferred message
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-09 07:58 UTC by Szczepan
Modified: 2012-05-09 08:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Szczepan 2012-05-09 07:58:11 UTC
Application: kmail (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I transferred spam message from a folder to the Inbox and the program then crashed. This often happens even when deleting messages

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb14fa740 (LWP 3358))]

Thread 4 (Thread 0xae74bb40 (LWP 3362)):
#0  0xb77c6424 in __kernel_vsyscall ()
#1  0xb58cb96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb5f333dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb38dc263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb38dc37f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb58c7d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb5f25ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xade22b40 (LWP 3363)):
#0  0xb43b0dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb61aa315 in do_gettime (frac=0xade22040, sec=0xade22038) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6294226 in QTimerInfoList::updateCurrentTime (this=0xad402074) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb6293e16 in timerSourceCheckHelper (src=0xad402040) at kernel/qeventdispatcher_glib.cpp:150
#5  timerSourceCheckHelper (src=0xad402040) at kernel/qeventdispatcher_glib.cpp:144
#6  0xb4537a6b in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb4538002 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb45381c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb62938e7 in QEventDispatcherGlib::processEvents (this=0xad400468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#10 0xb625f50d in QEventLoop::processEvents (this=0xade22270, flags=...) at kernel/qeventloop.cpp:149
#11 0xb625f7a9 in QEventLoop::exec (this=0xade22270, flags=...) at kernel/qeventloop.cpp:204
#12 0xb614894c in QThread::exec (this=0x88e0fb0) at thread/qthread.cpp:501
#13 0xb6148a3b in QThread::run (this=0x88e0fb0) at thread/qthread.cpp:568
#14 0xb614bde0 in QThreadPrivate::start (arg=0x88e0fb0) at thread/qthread_unix.cpp:298
#15 0xb58c7d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#16 0xb5f25ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xac1bfb40 (LWP 3415)):
#0  0xb58cac64 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb5f33634 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb45773d0 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4537755 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4537f6f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb45381c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb62938e7 in QEventDispatcherGlib::processEvents (this=0x8c2ba58, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb625f50d in QEventLoop::processEvents (this=0xac1bf240, flags=...) at kernel/qeventloop.cpp:149
#8  0xb625f7a9 in QEventLoop::exec (this=0xac1bf240, flags=...) at kernel/qeventloop.cpp:204
#9  0xb614894c in QThread::exec (this=0x8c35e98) at thread/qthread.cpp:501
#10 0xb623cb5d in QInotifyFileSystemWatcherEngine::run (this=0x8c35e98) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb614bde0 in QThreadPrivate::start (arg=0x8c35e98) at thread/qthread_unix.cpp:298
#12 0xb58c7d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb5f25ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb14fa740 (LWP 3358)):
[KCrash Handler]
#7  ref (this=0xb6293c7b) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:120
#8  QSharedDataPointer (o=..., this=0xbfded018) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:93
#9  QNetworkCacheMetaData::QNetworkCacheMetaData (this=0xbfded018, other=...) at access/qabstractnetworkcache.cpp:137
#10 0xb5acda4f in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x94c4410, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1016
#11 0xb5acf27e in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x94c4410, hm=..., sc=-1238811525, rp=..., pu=255, db=..., contentLength=-5352860498647121903) at access/qnetworkaccesshttpbackend.cpp:828
#12 0xbfded078 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Possible duplicates by query: bug 286708.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-05-09 08:33:23 UTC

*** This bug has been marked as a duplicate of bug 286307 ***