Bug 286708 - Kmail crashes while adding/removing old emails to/from inbox
Summary: Kmail crashes while adding/removing old emails to/from inbox
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.7
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-15 16:56 UTC by abenson
Modified: 2011-12-04 10:55 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abenson 2011-11-15 16:56:24 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.0-7.fc16.i686.PAE i686
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed: Attempting to delete an e-mail. When I do anything (get new mail, delete mail, move an email to a diffrent folder), KMail seems to reload 30-40 old emails (ones which I've either deleted before or moved to other folders) back into the inbox. These then gradually disappear from the inbox again (although not always). Usually this just slows down KMail but it eventually does what I asked it, but some times it causes a crash.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x4004b600 (LWP 14792))]

Thread 3 (Thread 0x411e1b40 (LWP 14793)):
#0  0x40000424 in __kernel_vsyscall ()
#1  0x4813984c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:172
#2  0x4317f2b3 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x438d2c40) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#3  0x4317f3d0 in WTF::TCMalloc_PageHeap::runScavengerThread (context=0x438d2c40) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#4  0x48135cd3 in start_thread (arg=0x411e1b40) at pthread_create.c:309
#5  0x480404de in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0x4150ab40 (LWP 14794)):
#0  0x4816f001 in __GI_clock_gettime (clock_id=1, tp=0x41509ff8) at ../sysdeps/unix/clock_gettime.c:116
#1  0x48d16056 in do_gettime (frac=0x41509ff0, sec=0x41509fe8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x48dfeaa7 in QTimerInfoList::updateCurrentTime (this=0x41601abc) at kernel/qeventdispatcher_unix.cpp:343
#4  0x48dfe6fe in timerSourceCheckHelper (src=0x41601a88) at kernel/qeventdispatcher_glib.cpp:150
#5  timerSourceCheckHelper (src=0x41601a88) at kernel/qeventdispatcher_glib.cpp:144
#6  0x4844427c in g_main_context_check (context=0x416004e0, max_priority=2147483647, fds=0x41600de8, n_fds=1) at gmain.c:2943
#7  0x48444c60 in g_main_context_iterate (context=0x416004e0, block=1212495776, dispatch=1, self=0x41600d70) at gmain.c:3070
#8  0x48444faf in g_main_context_iteration (context=0x416004e0, may_block=1) at gmain.c:3136
#9  0x48dfe1c7 in QEventDispatcherGlib::processEvents (this=0x41600468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#10 0x48dca3ae in QEventLoop::processEvents (this=0x4150a230, flags=...) at kernel/qeventloop.cpp:149
#11 0x48dca659 in QEventLoop::exec (this=0x4150a230, flags=...) at kernel/qeventloop.cpp:204
#12 0x48cb403c in QThread::exec (this=0x85218e0) at thread/qthread.cpp:501
#13 0x48cb412c in QThread::run (this=0x85218e0) at thread/qthread.cpp:568
#14 0x48cb75c1 in QThreadPrivate::start (arg=0x85218e0) at thread/qthread_unix.cpp:298
#15 0x48135cd3 in start_thread (arg=0x4150ab40) at pthread_create.c:309
#16 0x480404de in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0x4004b600 (LWP 14792)):
[KCrash Handler]
#7  ref (this=0x48de31fb) at ../../src/corelib/arch/qatomic_i386.h:120
#8  QSharedDataPointer (o=..., this=0xbfbeee28) at ../../src/corelib/tools/qshareddata.h:93
#9  QNetworkCacheMetaData::QNetworkCacheMetaData (this=0xbfbeee28, other=...) at access/qabstractnetworkcache.cpp:137
#10 0x4a9c1260 in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x103cdee0, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1016
#11 0x4a9c2b14 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x103cdee0, hm=..., sc=1222521339, rp=..., pu=255, db=..., contentLength=5378894292566361345) at access/qnetworkaccesshttpbackend.cpp:828
#12 0xbfbeee88 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-04 10:55:59 UTC

*** This bug has been marked as a duplicate of bug 286307 ***