Bug 299607 - Unreadable Tooltips - fore- and background colors don't fit
Summary: Unreadable Tooltips - fore- and background colors don't fit
Status: RESOLVED UPSTREAM
Alias: None
Product: Oxygen
Classification: Unclassified
Component: gtk3-engine (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-08 08:12 UTC by Lars Noschinski
Modified: 2013-09-06 11:55 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
unreadable tooltip (15.34 KB, image/png)
2012-12-31 15:08 UTC, Bruno (France)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Noschinski 2012-05-08 08:12:49 UTC
In Digikam 2.6.0 beta 3 with Debian's default Gnome 3 theme, tooltips are displayed in white on light blue, rendering them unreadable. Gnome applications like nautilus and gedit display tooltips in white on black; the QT applications like keepassx and kdiff3 use black on white blue, so maybe Digikam mixes up the two different color schemes?

Reproducible: Always
Comment 1 Lars Noschinski 2012-05-08 22:51:56 UTC
It should be "black on light blue", not "black on white blue".
Comment 2 Bruno (France) 2012-12-31 15:08:58 UTC
Created attachment 76115 [details]
unreadable tooltip

Hi all,
env: LinuxMint 13 Maya. Kernel 3.2.0-23-generic #36-Ubuntu
digikam v 2.5.0 (default package)

package list (from default repo)
digikam_4%3a2.5.0-1ubuntu2_amd64.deb
digikam-data_4%3a2.5.0-1ubuntu2_all.deb
libkface1_1.0~digikam2.5.0-1ubuntu2_amd64.deb
libkface-data_1.0~digikam2.5.0-1ubuntu2_all.deb
libkgeomap1_1.0~digikam2.5.0-1ubuntu2_amd64.deb
libkgeomap-data_1.0~digikam2.5.0-1ubuntu2_all.deb
libkvkontakte1_1.0~digikam2.5.0-1ubuntu2_amd64.deb

I hope that it will be helpful.

Can we change the background color of the tooltip with ~/.kde/share/apps/digikam/<Themes>.xml file ?
If yes, which XML Markers ?
Many thanks ;-)

Bruno.
Comment 3 caulier.gilles 2013-01-01 14:12:03 UTC
No. digiKam use KDE color scheme now. All digiKam xml color scheme are obsolete.

Go to KDE control panel and manage colors from selected theme as you need.

Gilles Caulier
Comment 4 Otto Hirr 2013-07-08 22:43:59 UTC
(In reply to comment #3)
> No. digiKam use KDE color scheme now. All digiKam xml color scheme are
> obsolete.
> Go to KDE control panel and manage colors from selected theme as you need.

So where is this for a MSWindows environment?

The
  Windows-Start-Button=>DigiKam 3.1.0=>SystemsSettings
brings up a 'System Settings' window, which under the 'Common Appearance and Behavior'
section, clicking on 'Application Appearance' redraws its window with a selection for
Style, Colors, Icons, Fonts, Emoticons. Clicking on the Colors brings up a color scheme with the same options as from within digiKam=>Settings=>Settings=>Themes=>Configuration...
In fact if one has it open from the SystemsSetting, it complains that it is already open.
Even from the SystemsSettings, the ToolTip background shows a dark color background with a light color font.

So it is not just solved by the suggested KDE Control Panel. At least not in the MS Windows environment.

Some of the colors for a given theme seem to be correct.
However the tooltip for many themes have a yellow background (which per the theme tooltip should be something like a darkblue) with a near white, or light grey letter color, which is nearly unreadable. Looks like the attachment someone else supplied 'unreadable tooltip'.

(digiKam 3.1.0, kde dev plat 4.10.2, build jun 07, 2013)

Regards,

..Otto
Comment 5 caulier.gilles 2013-09-06 11:31:25 UTC
After investiguations, i can reproduce this problem with a non KDE desktop, under Fedora 19 (Gnome 3).

This is due to a side effect between color theme and widget style settings used in digiKam.

GTK + style for ex, is completly broken, where Oxygen work as expected.

Solution : use Oxygen widget style in digiKam. Look my screenshot for details :

GTK+ : http://www.flickr.com/photos/digikam/9685638656/
Oxygen : http://www.flickr.com/photos/digikam/9682396803/

Note : Widget style can be configured in digiKam through Settings/Configure/Miscs dialog page.

Gilles Caulier
Comment 6 caulier.gilles 2013-09-06 11:36:13 UTC
Hi KDE Oxygen team,

I re-assign this file here. There is typically a bug somewhere in GTK+ widget style engine. I don't know if it's the right place in bugzilla... See my comment #5 for details.

Gilles Caulier
Comment 7 caulier.gilles 2013-09-06 11:43:33 UTC
Same problem reported in this file :
https://bugs.kde.org/show_bug.cgi?id=318953

Gilles Caulier
Comment 8 Hugo Pereira Da Costa 2013-09-06 11:55:55 UTC
oxygen-gtk running on gtk+ style for Qt applications is not supported, and is buggy, because of limitations of gtk+ Qt style. Should use oxygen@kde, or any other *native* (qt) widget style. 

I know oxygen@kde comes with quite some dependencies (on kdelibs notably) but this will improve in the future.

Other solution is to "fix" gtk+ style in Qt, but I doubt it is even feasible, of oxygen-gtk to work properly. And in any case this would be an upstream (qt) issue ... 

Closing as upstream, so. Sorry.
Sorry.