Bug 299575 - Kwin crash after alt+tab
Summary: Kwin crash after alt+tab
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2012-05-07 18:04 UTC by Raphael
Modified: 2018-10-27 03:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael 2012-05-07 18:04:11 UTC
Application: kwin (4.8.2 (4.8.2))
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.1-030201-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
When I switch with alt+tab kwin crash and nothing other.....

-- Backtrace:
Application: KWin (kwin), signal: Illegal instruction
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe1b97af780 (LWP 7495))]

Thread 3 (Thread 0x7fe1b1b7c700 (LWP 7500)):
#0  0x0000003d7d4eb823 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x0000003d835a7366 in qt_safe_select (nfds=20, fdread=0x7fe1a4000ac8, fdwrite=0x7fe1a4000d60, fdexcept=0x7fe1a4000ff8, orig_timeout=<optimized out>) at kernel/qcore_unix.cpp:83
#2  0x0000003d835ac7b2 in QEventDispatcherUNIXPrivate::doSelect (this=0x7fe1a4000910, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#3  0x0000003d835acca3 in QEventDispatcherUNIX::processEvents (this=0x7fe1a40008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#4  0x0000003d83579c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x0000003d83579ed7 in QEventLoop::exec (this=0x7fe1b1b7bdd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x0000003d83478fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x0000003d835599ff in QInotifyFileSystemWatcherEngine::run (this=0xfabc70) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x0000003d8347bfcb in QThreadPrivate::start (arg=0xfabc70) at thread/qthread_unix.cpp:298
#9  0x0000003d7dc07e9a in start_thread (arg=0x7fe1b1b7c700) at pthread_create.c:308
#10 0x0000003d7d4f24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe1b0fd3700 (LWP 7501)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x0000003d8b785222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x0000003d8b785259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x0000003d7dc07e9a in start_thread (arg=0x7fe1b0fd3700) at pthread_create.c:308
#4  0x0000003d7d4f24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe1b97af780 (LWP 7495)):
[KCrash Handler]
#6  0x00007fe1aa2643a2 in qmlRegisterType<Plasma::FrameSvg> (uri=0xf399d8 "org.kde.plasma.core", versionMajor=0, versionMinor=1, qmlName=0x7fe1aa274232 "FrameSvg") at /usr/include/qt4/QtDeclarative/qdeclarative.h:162
#7  0x0000000000efa990 in ?? ()
#8  0x00007fe1aa2629d0 in CoreBindingsPlugin::registerTypes (this=<optimized out>, uri=0xf85aa0 "0\320G\252\341\177") at ../../../../plasma/declarativeimports/core/corebindingsplugin.cpp:70
#9  0x0000003d8be7129c in QDeclarativeImportDatabase::importPlugin (this=0xffffffff, filePath=..., uri=..., errorString=0x7fffd83e63a8) at qml/qdeclarativeimport.cpp:1060
#10 0x0000003d8be71809 in QDeclarativeImportsPrivate::importExtension (this=0xed99b0, absoluteFilePath=..., uri=..., database=0xefa990, components=0x7fffd83e6750, errorString=0x7fffd83e6ff0) at qml/qdeclarativeimport.cpp:388
#11 0x0000003d8be72289 in QDeclarativeImportsPrivate::add (this=0xed99b0, qmldircomponentsnetwork=..., uri_arg=..., prefix=..., vmaj=0, vmin=1, importType=QDeclarativeScriptParser::Import::Library, database=0xefa990, errorString=0x7fffd83e6ff0) at qml/qdeclarativeimport.cpp:515
#12 0x0000003d8be74f56 in QDeclarativeImports::addImport (this=0xf6cfa0, importDb=0xefa990, uri=..., prefix=..., vmaj=0, vmin=1, importType=QDeclarativeScriptParser::Import::Library, qmldircomponentsnetwork=..., errorString=0x7fffd83e6ff0) at qml/qdeclarativeimport.cpp:805
#13 0x0000003d8be1396b in QDeclarativeTypeData::resolveTypes (this=0xf6cf10) at qml/qdeclarativetypeloader.cpp:1080
#14 0x0000003d8be147a5 in QDeclarativeTypeData::allDependenciesDone (this=0xf6cf10) at qml/qdeclarativetypeloader.cpp:1003
#15 0x0000003d8be0f96a in QDeclarativeDataLoader::setData (this=<optimized out>, blob=0xf6cf10, data=...) at qml/qdeclarativetypeloader.cpp:642
#16 0x0000003d8be10ca9 in QDeclarativeDataLoader::load (this=0xefa948, blob=0xf6cf10) at qml/qdeclarativetypeloader.cpp:546
#17 0x0000003d8be11881 in QDeclarativeTypeLoader::get (this=0xefa948, url=...) at qml/qdeclarativetypeloader.cpp:694
#18 0x0000003d8bdd15a1 in QDeclarativeComponent::loadUrl (this=0xf0f770, url=...) at qml/qdeclarativecomponent.cpp:536
#19 0x0000003d8bdd1af8 in QDeclarativeComponent::QDeclarativeComponent (this=0xf0f770, engine=0x106c000, url=..., parent=0xebde50) at qml/qdeclarativecomponent.cpp:437
#20 0x0000003d8bd64888 in QDeclarativeLoader::setSource (this=0xebde50, url=...) at graphicsitems/qdeclarativeloader.cpp:284
#21 0x0000003d8bd64a28 in QDeclarativeLoader::qt_metacall (this=0xebde50, _c=QMetaObject::WriteProperty, _id=0, _a=0x7fffd83e7510) at .moc/release-shared/moc_qdeclarativeloader_p.cpp:151
#22 0x0000003d8bdb2e7c in QDeclarativeVMEMetaObject::metaCall (this=0xf79a70, c=QMetaObject::WriteProperty, _id=43, a=0x7fffd83e7510) at qml/qdeclarativevmemetaobject.cpp:673
#23 0x0000003d835846e6 in QMetaProperty::write (this=0x7fffd83e7600, object=0xebde50, value=...) at kernel/qmetaobject.cpp:2364
#24 0x0000003d83594f33 in QObject::setProperty (this=0xebde50, name=0x3d8e91e362 "source", value=...) at kernel/qobject.cpp:3725
#25 0x0000003d8e8f67f5 in KWin::TabBox::DeclarativeView::updateQmlSource (this=0x10ff470) at ../../kwin/tabbox/declarative.cpp:224
#26 0x0000003d8e8f6968 in KWin::TabBox::DeclarativeView::showEvent (this=0x10ff470, event=0x7fffd83e8070) at ../../kwin/tabbox/declarative.cpp:138
#27 0x0000003d8481c3f5 in QWidget::event (this=0x10ff470, event=0x7fffd83e8070) at kernel/qwidget.cpp:8569
#28 0x0000003d84bdc3c6 in QFrame::event (this=0x10ff470, e=0x7fffd83e8070) at widgets/qframe.cpp:557
#29 0x0000003d84c5e4d3 in QAbstractScrollArea::event (this=0x10ff470, e=0x7fffd83e8070) at widgets/qabstractscrollarea.cpp:996
#30 0x0000003d847cb894 in notify_helper (e=0x7fffd83e8070, receiver=0x10ff470, this=0xcc9430) at kernel/qapplication.cpp:4559
#31 QApplicationPrivate::notify_helper (this=0xcc9430, receiver=0x10ff470, e=0x7fffd83e8070) at kernel/qapplication.cpp:4531
#32 0x0000003d847d0713 in QApplication::notify (this=0x7fffd83e8d40, receiver=0x10ff470, e=0x7fffd83e8070) at kernel/qapplication.cpp:4420
#33 0x0000003d89436b46 in KApplication::notify (this=0x7fffd83e8d40, receiver=0x10ff470, event=0x7fffd83e8070) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x0000003d8357ae9c in QCoreApplication::notifyInternal (this=0x7fffd83e8d40, receiver=0x10ff470, event=0x7fffd83e8070) at kernel/qcoreapplication.cpp:876
#35 0x0000003d8481e810 in sendEvent (event=0x7fffd83e8070, receiver=0x10ff470) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 QWidgetPrivate::show_helper (this=0xfc1470) at kernel/qwidget.cpp:7542
#37 0x0000003d8481eb02 in QWidget::setVisible (this=0x10ff470, visible=<optimized out>) at kernel/qwidget.cpp:7764
#38 0x0000003d8e9002d5 in show (this=0x10ff470) at /usr/include/qt4/QtGui/qwidget.h:494
#39 KWin::TabBox::TabBoxHandler::show (this=0xdf59b0) at ../../kwin/tabbox/tabboxhandler.cpp:419
#40 0x0000003d8358f281 in QMetaObject::activate (sender=0xe6c248, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#41 0x0000003d83594179 in QObject::event (this=0xe6c248, e=<optimized out>) at kernel/qobject.cpp:1157
#42 0x0000003d847cb894 in notify_helper (e=0x7fffd83e8920, receiver=0xe6c248, this=0xcc9430) at kernel/qapplication.cpp:4559
#43 QApplicationPrivate::notify_helper (this=0xcc9430, receiver=0xe6c248, e=0x7fffd83e8920) at kernel/qapplication.cpp:4531
#44 0x0000003d847d0713 in QApplication::notify (this=0x7fffd83e8d40, receiver=0xe6c248, e=0x7fffd83e8920) at kernel/qapplication.cpp:4420
#45 0x0000003d89436b46 in KApplication::notify (this=0x7fffd83e8d40, receiver=0xe6c248, event=0x7fffd83e8920) at ../../kdeui/kernel/kapplication.cpp:311
#46 0x0000003d8357ae9c in QCoreApplication::notifyInternal (this=0x7fffd83e8d40, receiver=0xe6c248, event=0x7fffd83e8920) at kernel/qcoreapplication.cpp:876
#47 0x0000003d835ac1f2 in sendEvent (event=0x7fffd83e8920, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#48 QTimerInfoList::activateTimers (this=0xcc9fe8) at kernel/qeventdispatcher_unix.cpp:611
#49 0x0000003d835accb4 in QEventDispatcherUNIX::processEvents (this=0xc75ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#50 0x0000003d84874c08 in QEventDispatcherX11::processEvents (this=0xc75ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#51 0x0000003d83579c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#52 0x0000003d83579ed7 in QEventLoop::exec (this=0x7fffd83e8c80, flags=...) at kernel/qeventloop.cpp:204
#53 0x0000003d8357ef67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#54 0x0000003d8e860a06 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../kwin/main.cpp:541
#55 0x0000003d7d42176d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=3, ubp_av=0x7fffd83e9468, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffd83e9458) at libc-start.c:226
#56 0x0000000000400671 in _start ()

Reported using DrKonqi
Comment 1 Martin Flöser 2012-05-07 18:20:00 UTC
> #9 0x0000003d8be7129c in QDeclarativeImportDatabase::importPlugin (this=0xffffffff, filePath=..., uri=..., errorString=0x7fffd83e63a8) at qml/qdeclarativeimport.cpp:1060
the this pointer looks funny.

Are you able to reproduce this crash at will? Any pattern you can observe?
Comment 2 Thomas Lübking 2012-05-07 18:37:20 UTC
(In reply to comment #1)
> the this pointer looks funny.

It looks like a clear SIGILL trigger to me ;-)
-> "Application: KWin (kwin), signal: Illegal instruction"

The question is however
how
#10 0x0000003d8be71809 in QDeclarativeImportsPrivate::importExtension (.., database=0xefa990 ...)

turns
#9  0x0000003d8be7129c in QDeclarativeImportDatabase::importPlugin (this=0xffffffff, ...)

-> memory corruption (or broken HW)

Given the depth, rather an issue in Qt?!

@Raphael
keep posting traces whenever you can re-cause this
Comment 3 Thomas Lübking 2012-08-26 11:06:22 UTC
Also see bug #305718
Comment 4 Martin Flöser 2013-01-17 16:14:32 UTC
waiting for further backtraces
Comment 5 Andrew Crouthamel 2018-09-24 02:01:48 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 6 Andrew Crouthamel 2018-10-27 03:44:38 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!