Bug 299292 - Run filters in order
Summary: Run filters in order
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: text-ui-message-filters (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist
Target Milestone: Future
Assignee: Lasath Fernando
URL:
Keywords:
: 306066 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-03 11:48 UTC by Lasath Fernando
Modified: 2013-03-10 21:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lasath Fernando 2012-05-03 11:48:32 UTC
Currently all the message filters are run in the order they are loaded, which is totally random and unpredictable. 

This is not good as some of them depend on others. 

Must figure out how to load data from a service file, and write priorities into them.
Comment 1 Daniele E. Domenichelli 2012-08-31 22:43:54 UTC
*** Bug 306066 has been marked as a duplicate of this bug. ***
Comment 2 David Edmundson 2013-03-10 21:22:10 UTC
Git commit 44b04ed15462ef0a47cf062ea7d3aca126d3a348 by David Edmundson.
Committed on 10/03/2013 at 05:33.
Pushed by davidedmundson into branch 'master'.

Sort filtering plugins by X-KDE-PluginInfo-Weight
REVIEW: 109383

M  +20   -1    KTp/message-processor.cpp

http://commits.kde.org/telepathy-common-internals/44b04ed15462ef0a47cf062ea7d3aca126d3a348