Bug 299105 - KMail crashes when switching to HTML layout of a mail
Summary: KMail crashes when switching to HTML layout of a mail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-30 13:47 UTC by Christian Bayer
Modified: 2012-05-02 07:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Bayer 2012-04-30 13:47:11 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I can reproduce this when either clicking the "display HTML mail" link in the message window or enabling "prefer HTML layout" and clicking a HTML mail in the message list.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2419f9c7c0 (LWP 4356))]

Thread 5 (Thread 0x7f23fd3c8700 (LWP 4357)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f241679fdec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f241679ff19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f2411c66e9a in start_thread (arg=0x7f23fd3c8700) at pthread_create.c:308
#4  0x00007f24174d14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f23fcac7700 (LWP 4358)):
#0  0x00007f2411799262 in g_main_context_release () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f2411799fa9 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f241179a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2417c46426 in QEventDispatcherGlib::processEvents (this=0x7f23f80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f2417c15c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2417c15ed7 in QEventLoop::exec (this=0x7f23fcac6dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f2417b14fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f2417b17fcb in QThreadPrivate::start (arg=0x254e220) at thread/qthread_unix.cpp:298
#8  0x00007f2411c66e9a in start_thread (arg=0x7f23fcac7700) at pthread_create.c:308
#9  0x00007f24174d14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f23ade14700 (LWP 4364)):
#0  0x00007f2411c68f69 in __pthread_mutex_lock (mutex=0x7f23a0000a60) at pthread_mutex_lock.c:92
#1  0x00007f24117d5561 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2411799fdb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f241179a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2417c46426 in QEventDispatcherGlib::processEvents (this=0x7f23a00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f2417c15c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f2417c15ed7 in QEventLoop::exec (this=0x7f23ade13d90, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f2417b14fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f2417bf59ff in QInotifyFileSystemWatcherEngine::run (this=0x2a3a750) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f2417b17fcb in QThreadPrivate::start (arg=0x2a3a750) at thread/qthread_unix.cpp:298
#10 0x00007f2411c66e9a in start_thread (arg=0x7f23ade14700) at pthread_create.c:308
#11 0x00007f24174d14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f239f1cb700 (LWP 4403)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2417b184db in wait (time=18446744073709551615, this=0x7f2390206bc0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f2390030e30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2417b14314 in QSemaphore::acquire (this=0x7f239f1c8a70, n=1) at thread/qsemaphore.cpp:144
#4  0x00007f2417c2b77c in QMetaObject::activate (sender=0x58e1140, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f239f1c8ae0) at kernel/qobject.cpp:3525
#5  0x00007f2412b3d294 in QHttpThreadDelegate::authenticationRequired (this=<optimized out>, _t1=..., _t2=0x7f2390003248) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:178
#6  0x00007f2412b3d7d8 in QHttpThreadDelegate::qt_static_metacall (_o=0x58e1140, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:104
#7  0x00007f2417c2b281 in QMetaObject::activate (sender=0x7f2390008b20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f239f1c8d10) at kernel/qobject.cpp:3547
#8  0x00007f2412b3be47 in QHttpNetworkReply::authenticationRequired (this=<optimized out>, _t1=..., _t2=0x7f2390003248) at .moc/release-shared/moc_qhttpnetworkreply_p.cpp:192
#9  0x00007f2412a965d3 in QHttpNetworkConnectionPrivate::handleAuthenticateChallenge (this=0x7f2390002fa0, socket=0x7f2390003d80, reply=0x7f2390008b20, isProxy=false, resend=@0x7f239f1c8faf: false) at access/qhttpnetworkconnection.cpp:385
#10 0x00007f2412a9bea4 in QHttpNetworkConnectionChannel::handleStatus (this=0x7f23900031e8) at access/qhttpnetworkconnectionchannel.cpp:834
#11 0x00007f2412a9c64a in QHttpNetworkConnectionChannel::allDone (this=0x7f23900031e8) at access/qhttpnetworkconnectionchannel.cpp:709
#12 0x00007f2412a9d15b in QHttpNetworkConnectionChannel::_q_receiveReply (this=0x7f23900031e8) at access/qhttpnetworkconnectionchannel.cpp:506
#13 0x00007f2412a9dc42 in QHttpNetworkConnectionChannel::_q_readyRead (this=0x7f23900031e8) at access/qhttpnetworkconnectionchannel.cpp:981
#14 0x00007f2417c2b281 in QMetaObject::activate (sender=0x7f2390003d80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#15 0x00007f2412b34b64 in QSslSocketBackendPrivate::transmit (this=0x7f2390004d00) at ssl/qsslsocket_openssl.cpp:1149
#16 0x00007f2412b2ef89 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qsslsocket.cpp:98
#17 QSslSocket::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qsslsocket.cpp:77
#18 0x00007f2417c2b281 in QMetaObject::activate (sender=0x7f2390009680, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#19 0x00007f2412b0e68f in QAbstractSocketPrivate::canReadNotification (this=0x7f2390009ab0) at socket/qabstractsocket.cpp:654
#20 0x00007f2412b16201 in event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1151
#21 QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1148
#22 0x00007f241860b894 in notify_helper (e=0x7f239f1cabe0, receiver=0x7f239000c980, this=0x23af900) at kernel/qapplication.cpp:4559
#23 QApplicationPrivate::notify_helper (this=0x23af900, receiver=0x7f239000c980, e=0x7f239f1cabe0) at kernel/qapplication.cpp:4531
#24 0x00007f2418610713 in QApplication::notify (this=0x7fff788adc40, receiver=0x7f239000c980, e=0x7f239f1cabe0) at kernel/qapplication.cpp:4420
#25 0x00007f2419344b46 in KApplication::notify (this=0x7fff788adc40, receiver=0x7f239000c980, event=0x7f239f1cabe0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f2417c16e9c in QCoreApplication::notifyInternal (this=0x7fff788adc40, receiver=0x7f239000c980, event=0x7f239f1cabe0) at kernel/qcoreapplication.cpp:876
#27 0x00007f2417c45a97 in sendEvent (event=0x7f239f1cabe0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#28 socketNotifierSourceDispatch (source=0x7f2390001350) at kernel/qeventdispatcher_glib.cpp:110
#29 0x00007f2411799c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f241179a060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f241179a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f2417c46426 in QEventDispatcherGlib::processEvents (this=0x7f23900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#33 0x00007f2417c15c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f2417c15ed7 in QEventLoop::exec (this=0x7f239f1cadc0, flags=...) at kernel/qeventloop.cpp:204
#35 0x00007f2417b14fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#36 0x00007f2417b17fcb in QThreadPrivate::start (arg=0x4bcf460) at thread/qthread_unix.cpp:298
#37 0x00007f2411c66e9a in start_thread (arg=0x7f239f1cb700) at pthread_create.c:308
#38 0x00007f24174d14bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#39 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2419f9c7c0 (LWP 4356)):
[KCrash Handler]
#6  0x00007f2412a9f36d in lockInline (this=0x7f23ae6fa030) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:187
#7  QMutexLocker (m=0x7f23ae6fa030, this=0x7fff788ad110) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:109
#8  QNetworkAccessAuthenticationManager::fetchCachedCredentials (this=0x7f23ae6fa000, url=..., authentication=<optimized out>) at access/qnetworkaccessauthenticationmanager.cpp:285
#9  0x00007f2412aa2587 in QNetworkAccessManagerPrivate::authenticationRequired (this=0x58dd9a0, backend=0x564d9e0, authenticator=0x7f2390003248) at access/qnetworkaccessmanager.cpp:1081
#10 0x00007f2412b3c790 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x564d9e0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:93
#11 0x00007f2417c30446 in QObject::event (this=0x564d9e0, e=<optimized out>) at kernel/qobject.cpp:1195
#12 0x00007f241860b894 in notify_helper (e=0x7f23900550b0, receiver=0x564d9e0, this=0x23af900) at kernel/qapplication.cpp:4559
#13 QApplicationPrivate::notify_helper (this=0x23af900, receiver=0x564d9e0, e=0x7f23900550b0) at kernel/qapplication.cpp:4531
#14 0x00007f2418610713 in QApplication::notify (this=0x7fff788adc40, receiver=0x564d9e0, e=0x7f23900550b0) at kernel/qapplication.cpp:4420
#15 0x00007f2419344b46 in KApplication::notify (this=0x7fff788adc40, receiver=0x564d9e0, event=0x7f23900550b0) at ../../kdeui/kernel/kapplication.cpp:311
#16 0x00007f2417c16e9c in QCoreApplication::notifyInternal (this=0x7fff788adc40, receiver=0x564d9e0, event=0x7f23900550b0) at kernel/qcoreapplication.cpp:876
#17 0x00007f2417c1ac6a in sendEvent (event=0x7f23900550b0, receiver=0x564d9e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x237e380) at kernel/qcoreapplication.cpp:1500
#19 0x00007f2417c45f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007f2411799c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f241179a060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f241179a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f2417c463bf in QEventDispatcherGlib::processEvents (this=0x237fc10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007f24186b3d6e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f2417c15c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007f2417c15ed7 in QEventLoop::exec (this=0x7fff788adbd0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007f2417c1af67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000403629 in main (argc=1, argv=0x7fff788ae268) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 286806.

Reported using DrKonqi
Comment 1 Christian Bayer 2012-04-30 14:52:16 UTC
This only applies to mails with HTML which references content that requires authentication, ordinary HTML mails work. In particular this applies to mails generated by a JIRA system which is probably protected by a .htaccess file (I get a username/password prompt in an extra window, it is HTTPauth stuff).
Comment 2 Laurent Montel 2012-05-02 07:58:54 UTC

*** This bug has been marked as a duplicate of bug 286307 ***