Bug 286806 - kmail crash
Summary: kmail crash
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-16 22:03 UTC by Sérgio Basto
Modified: 2011-11-29 17:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (11.12 KB, text/plain)
2011-11-16 23:47 UTC, Sérgio Basto
Details
well kontact and kmail crash every time I try to read this email (5.05 KB, text/plain)
2011-11-17 00:12 UTC, Sérgio Basto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sérgio Basto 2011-11-16 22:03:24 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.1-1.bz590880.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

I am selecting a few email to apply filters , happens for the third time

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fa1e4b8a840 (LWP 13489))]

Thread 4 (Thread 0x7fa1d9acf700 (LWP 13490)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000036389973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3639390f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00000036389974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003185c07d90 in start_thread (arg=0x7fa1d9acf700) at pthread_create.c:309
#4  0x00000031854eeddd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fa1d91ce700 (LWP 13491)):
#0  0x00000031854e6443 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003188044f88 in g_main_context_poll (n_fds=1, fds=0x7fa1d40013e0, priority=<optimized out>, timeout=5781, context=0x7fa1d40009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7fa1d40009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x000000318804544c in g_main_context_iteration (context=0x7fa1d40009a0, may_block=1) at gmain.c:3136
#4  0x0000003628ba6896 in QEventDispatcherGlib::processEvents (this=0x7fa1d40008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003628b76c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003628b76ed7 in QEventLoop::exec (this=0x7fa1d91cdd40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003628a78ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x0000003628a7bb1b in QThreadPrivate::start (arg=0xed9f80) at thread/qthread_unix.cpp:298
#9  0x0000003185c07d90 in start_thread (arg=0x7fa1d91ce700) at pthread_create.c:309
#10 0x00000031854eeddd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fa18db43700 (LWP 13503)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003628a7c02b in wait (time=18446744073709551615, this=0x7fa188007c40) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fa188005e80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003628a77e44 in QSemaphore::acquire (this=0x7fa18db41cc0, n=1) at thread/qsemaphore.cpp:144
#4  0x0000003628b8bcb5 in QMetaObject::activate (sender=0x2835f20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fa18db41d30) at kernel/qobject.cpp:3524
#5  0x000000362aaf59c4 in QHttpThreadDelegate::authenticationRequired (this=<optimized out>, _t1=<optimized out>, _t2=0x7fa188002958) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:178
#6  0x000000362aaf5f08 in QHttpThreadDelegate::qt_static_metacall (_o=0x2835f20, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:104
#7  0x0000003628b8b7d1 in QMetaObject::activate (sender=0x7fa188005b30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fa18db41f60) at kernel/qobject.cpp:3546
#8  0x000000362aaf46f7 in QHttpNetworkReply::authenticationRequired (this=<optimized out>, _t1=<optimized out>, _t2=0x7fa188002958) at .moc/release-shared/moc_qhttpnetworkreply_p.cpp:192
#9  0x000000362aa558d7 in QHttpNetworkConnectionPrivate::handleAuthenticateChallenge (this=0x7fa1880027d0, socket=0x7fa188001310, reply=0x7fa188005b30, isProxy=false, resend=@0x7fa18db421ef) at access/qhttpnetworkconnection.cpp:378
#10 0x000000362aa5bb44 in QHttpNetworkConnectionChannel::handleStatus (this=0x7fa1880028f8) at access/qhttpnetworkconnectionchannel.cpp:824
#11 0x000000362aa5c2ba in QHttpNetworkConnectionChannel::allDone (this=0x7fa1880028f8) at access/qhttpnetworkconnectionchannel.cpp:700
#12 0x000000362aa5cdcb in QHttpNetworkConnectionChannel::_q_receiveReply (this=0x7fa1880028f8) at access/qhttpnetworkconnectionchannel.cpp:505
#13 0x000000362aa5d8b2 in QHttpNetworkConnectionChannel::_q_readyRead (this=0x7fa1880028f8) at access/qhttpnetworkconnectionchannel.cpp:968
#14 0x0000003628b8b7d1 in QMetaObject::activate (sender=0x7fa188001310, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3546
#15 0x000000362aacc8bf in QAbstractSocketPrivate::canReadNotification (this=0x7fa188003160) at socket/qabstractsocket.cpp:651
#16 0x000000362aad4391 in event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1151
#17 QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1148
#18 0x00000036295c96f4 in notify_helper (e=0x7fa18db42b30, receiver=0x7fa188006210, this=0xebc620) at kernel/qapplication.cpp:4518
#19 QApplicationPrivate::notify_helper (this=0xebc620, receiver=0x7fa188006210, e=0x7fa18db42b30) at kernel/qapplication.cpp:4490
#20 0x00000036295ce573 in QApplication::notify (this=0x7fff9cfd6df0, receiver=0x7fa188006210, e=0x7fa18db42b30) at kernel/qapplication.cpp:4379
#21 0x000000362ce50396 in KApplication::notify (this=0x7fff9cfd6df0, receiver=0x7fa188006210, event=0x7fa18db42b30) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#22 0x0000003628b77b4c in QCoreApplication::notifyInternal (this=0x7fff9cfd6df0, receiver=0x7fa188006210, event=0x7fa18db42b30) at kernel/qcoreapplication.cpp:876
#23 0x0000003628ba5e87 in sendEvent (event=0x7fa18db42b30, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#24 socketNotifierSourceDispatch (source=0x7fa188002000) at kernel/qeventdispatcher_glib.cpp:110
#25 0x0000003188044a7d in g_main_dispatch (context=0x7fa1880009a0) at gmain.c:2425
#26 g_main_context_dispatch (context=0x7fa1880009a0) at gmain.c:2995
#27 0x0000003188045278 in g_main_context_iterate (context=0x7fa1880009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#28 0x000000318804544c in g_main_context_iteration (context=0x7fa1880009a0, may_block=1) at gmain.c:3136
#29 0x0000003628ba682f in QEventDispatcherGlib::processEvents (this=0x7fa1880008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#30 0x0000003628b76c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x0000003628b76ed7 in QEventLoop::exec (this=0x7fa18db42d40, flags=...) at kernel/qeventloop.cpp:204
#32 0x0000003628a78ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#33 0x0000003628a7bb1b in QThreadPrivate::start (arg=0x279ce50) at thread/qthread_unix.cpp:298
#34 0x0000003185c07d90 in start_thread (arg=0x7fa18db43700) at pthread_create.c:309
#35 0x00000031854eeddd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fa1e4b8a840 (LWP 13489)):
[KCrash Handler]
#6  lockInline (this=0x730075002fb5d0) at ../../src/corelib/thread/qmutex.h:187
#7  QMutexLocker (m=0x730075002fb5d0, this=0x7fff9cfd62d0) at ../../src/corelib/thread/qmutex.h:109
#8  QNetworkAccessAuthenticationManager::fetchCachedCredentials (this=0x730075002fb5a0, url=..., authentication=<optimized out>) at access/qnetworkaccessauthenticationmanager.cpp:280
#9  0x000000362aa62019 in QNetworkAccessManagerPrivate::authenticationRequired (this=0x2715bc0, backend=0x27eb140, authenticator=0x7fa188002958) at access/qnetworkaccessmanager.cpp:1071
#10 0x000000362aaf4f80 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x27eb140, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:93
#11 0x0000003628b909e6 in QObject::event (this=0x27eb140, e=<optimized out>) at kernel/qobject.cpp:1194
#12 0x00000036295c96f4 in notify_helper (e=0x7fa188007780, receiver=0x27eb140, this=0xebc620) at kernel/qapplication.cpp:4518
#13 QApplicationPrivate::notify_helper (this=0xebc620, receiver=0x27eb140, e=0x7fa188007780) at kernel/qapplication.cpp:4490
#14 0x00000036295ce573 in QApplication::notify (this=0x7fff9cfd6df0, receiver=0x27eb140, e=0x7fa188007780) at kernel/qapplication.cpp:4379
#15 0x000000362ce50396 in KApplication::notify (this=0x7fff9cfd6df0, receiver=0x27eb140, event=0x7fa188007780) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#16 0x0000003628b77b4c in QCoreApplication::notifyInternal (this=0x7fff9cfd6df0, receiver=0x27eb140, event=0x7fa188007780) at kernel/qcoreapplication.cpp:876
#17 0x0000003628b7b5da in sendEvent (event=0x7fa188007780, receiver=0x27eb140) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xe91050) at kernel/qcoreapplication.cpp:1500
#19 0x0000003628ba6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0xed0a70) at kernel/qeventdispatcher_glib.cpp:279
#21 0x0000003188044a7d in g_main_dispatch (context=0xecfe70) at gmain.c:2425
#22 g_main_context_dispatch (context=0xecfe70) at gmain.c:2995
#23 0x0000003188045278 in g_main_context_iterate (context=0xecfe70, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#24 0x000000318804544c in g_main_context_iteration (context=0xecfe70, may_block=1) at gmain.c:3136
#25 0x0000003628ba682f in QEventDispatcherGlib::processEvents (this=0xe92510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#26 0x000000362966c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#27 0x0000003628b76c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x0000003628b76ed7 in QEventLoop::exec (this=0x7fff9cfd6d80, flags=...) at kernel/qeventloop.cpp:204
#29 0x0000003628b7b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0x00000000004037b9 in main (argc=1, argv=0x7fff9cfd7418) at /usr/src/debug/kdepim-4.7.3/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Sérgio Basto 2011-11-16 23:47:55 UTC
Created attachment 65766 [details]
New crash information added by DrKonqi

kontact (4.7.3) on KDE Platform 4.7.3 (4.7.3) using Qt 4.8.0

- What I was doing when the application crashed:

I try to open the email that had crash me to times ago,
I restart laptop to ensure that is not an update problem.

-- Backtrace (Reduced):
#6  lockInline (this=0x65646b3a3a010030) at ../../src/corelib/thread/qmutex.h:187
#7  QMutexLocker (m=0x65646b3a3a010030, this=0x7fffeaed21e0) at ../../src/corelib/thread/qmutex.h:109
#8  QNetworkAccessAuthenticationManager::fetchCachedCredentials (this=0x65646b3a3a010000, url=..., authentication=<optimized out>) at access/qnetworkaccessauthenticationmanager.cpp:280
#9  0x000000362aa62019 in QNetworkAccessManagerPrivate::authenticationRequired (this=0x36b37a0, backend=0x36fd110, authenticator=0x7f0c64002758) at access/qnetworkaccessmanager.cpp:1071
#10 0x000000362aaf4f80 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x36fd110, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:93
Comment 2 Sérgio Basto 2011-11-17 00:12:24 UTC
Created attachment 65767 [details]
well kontact and kmail crash every time I try to read this email 

hope that can help you
Comment 3 Sérgio Basto 2011-11-19 03:32:23 UTC
after back to default browser engine KHTML, kmail mail don't crash reading this message.
the fault was kwebkitpart when using as default browser engine kwebkitpart
Comment 4 Christophe Giboudeaux 2011-11-29 17:14:58 UTC

*** This bug has been marked as a duplicate of bug 286307 ***