Bug 298994 - Layers loaded from XCF files with unicode names look broken
Summary: Layers loaded from XCF files with unicode names look broken
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: File formats (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
: 298667 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-28 19:40 UTC by Oded Arbel
Modified: 2012-05-08 09:08 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oded Arbel 2012-04-28 19:40:03 UTC
When loading an XCF file with layers named with unicode characters (for example, Hebrew), the layer names in Krita look broken - shows the ASCII characters for each byte in the UTF-8 sequence. For example, the layer named "בדיקה" looks "בדיקה".

When using the Krita native file format for saving and loading images with layers that have unicode names, everything works fine.

Reproducible: Always

Steps to Reproduce:
1. Open GIMP and create a new image, name the layer something which uses multi-byte characters in UTF-8. For example, some Hebrew (you can copy the text from the description above)
2. Save the file as XCF
3. Load the file in Krita
Actual Results:  
The layer name is not shown correctly

Expected Results:  
The layer name should be shown exactly like in the GIMP
Comment 1 Halla Rempt 2012-04-29 10:53:05 UTC
Hi Oded,

Thanks for your report, I can confirm indeed.
Comment 2 Halla Rempt 2012-04-29 10:56:12 UTC
Git commit b3544539fdee99f954fe32c147b8edc241f2857f by Boudewijn Rempt.
Committed on 29/04/2012 at 12:56.
Pushed by rempt into branch 'master'.

layer names in gimp are in utf8

M  +1    -1    krita/plugins/formats/xcf/kis_xcf_import.cpp

http://commits.kde.org/calligra/b3544539fdee99f954fe32c147b8edc241f2857f
Comment 3 Halla Rempt 2012-04-29 10:56:37 UTC
Git commit 64e449ede5b67dc03a3104552dc3cd6ea49adc3f by Boudewijn Rempt.
Committed on 29/04/2012 at 12:56.
Pushed by rempt into branch 'calligra/2.4'.

layer names in gimp are in utf8

M  +1    -1    krita/plugins/formats/xcf/kis_xcf_import.cpp

http://commits.kde.org/calligra/64e449ede5b67dc03a3104552dc3cd6ea49adc3f
Comment 4 Halla Rempt 2012-05-08 09:08:55 UTC
*** Bug 298667 has been marked as a duplicate of this bug. ***