Bug 298667 - Krita does not support non-english (Chinese) layer names from gimp .xcf
Summary: Krita does not support non-english (Chinese) layer names from gimp .xcf
Status: RESOLVED DUPLICATE of bug 298994
Alias: None
Product: krita
Classification: Applications
Component: Filter Layers (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-23 14:27 UTC by margueritesu
Modified: 2012-05-08 09:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
gimp source .xcf (170.11 KB, image/x-xcf)
2012-04-23 14:28 UTC, margueritesu
Details
layer screenshot (38.55 KB, image/png)
2012-04-23 14:31 UTC, margueritesu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description margueritesu 2012-04-23 14:27:06 UTC
Hi, I opened a .xcf gimp source with krita, everything is okay except for the layer name. 
I stored them using Chinese characters, but in krita they're displayed as random ugly characters.



Reproducible: Always

Steps to Reproduce:
1. open my gimp file
2. you'll see
Actual Results:  
show random strings

Expected Results:  
show correct name

attachment 1 [details]: gimp source .xcf
attachment 2 [details]: screenshots of that.
Comment 1 margueritesu 2012-04-23 14:28:47 UTC
Created attachment 70594 [details]
gimp source .xcf
Comment 2 margueritesu 2012-04-23 14:31:36 UTC
Created attachment 70595 [details]
layer screenshot
Comment 3 Halla Rempt 2012-04-23 15:09:05 UTC
Thank you for your report! I can indeed confirm the issue. Should be easy to fix, though :-)
Comment 4 margueritesu 2012-04-24 14:20:59 UTC
okay, thanks for the quick reaction, I mark it resolved.
Comment 5 Halla Rempt 2012-04-24 14:29:05 UTC
Oh, no, please keep it open, otherwise I will forget to actually fix it. I'm in the middle of a tricky bit of coding after that I'll look into it.
Comment 6 Halla Rempt 2012-05-08 09:08:55 UTC
Ah, I fixed this already... For bug https://bugs.kde.org/show_bug.cgi?id=298994

*** This bug has been marked as a duplicate of bug 298994 ***