Bug 298810 - KDevelop crashed when opening a recent C++ header file [Cpp::AdaptDefinitionSignatureAssistant::parseJobFinished]
Summary: KDevelop crashed when opening a recent C++ header file [Cpp::AdaptDefinitionS...
Status: RESOLVED DUPLICATE of bug 298676
Alias: None
Product: kdevelop
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: 4.3.0
Assignee: kdevelop-bugs-null
URL:
Keywords:
: 303644 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-25 14:17 UTC by Bartosz Brachaczek
Modified: 2012-12-01 20:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz Brachaczek 2012-04-25 14:17:11 UTC
Application: kdevelop (4.3.1)
KDE Platform Version: 4.8.2 (4.8.2) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.3.0-gentoo x86_64
Distribution: "Gentoo Base System release 2.1"

-- Information about the crash:
- What I was doing when the application crashed:

I had a couple of tabs opened with a large C++/Qt project (Kadu). Accidentally I closed one which I needed (it was a header with class definition), and opened it again through the Recent files menu. Then KDevelop crashed.

-- Backtrace:
Application: KDevelop (kdevelop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa99e256760 (LWP 11565))]

Thread 10 (Thread 0x7fa983342700 (LWP 11566)):
#0  0x00007fa99aee8a0b in pthread_cond_timedwait () from /lib64/libpthread.so.0
#1  0x00007fa99c62f3e5 in wait (time=1000, this=0x3a9adc0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x3aa0420, time=1000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fa99881d4fb in KDevelop::DUChainPrivate::CleanupThread::run (this=0x3aa0400) at /var/tmp/portage/dev-util/kdevplatform-1.3.1/work/kdevplatform-1.3.1/language/duchain/duchain.cpp:282
#4  0x00007fa99c62e2b5 in QThreadPrivate::start (arg=0x3aa0400) at thread/qthread_unix.cpp:298
#5  0x00007fa99aee3e0c in start_thread (arg=0x7fa983342700) at pthread_create.c:301
#6  0x00007fa99b1d296d in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7fa978681700 (LWP 11567)):
#0  0x00007fa99b1cc103 in select () from /lib64/libc.so.6
#1  0x00007fa99c72b45d in QProcessManager::run (this=0x7fa99cac4440) at io/qprocess_unix.cpp:245
#2  0x00007fa99c62e2b5 in QThreadPrivate::start (arg=0x7fa99cac4440) at thread/qthread_unix.cpp:298
#3  0x00007fa99aee3e0c in start_thread (arg=0x7fa978681700) at pthread_create.c:301
#4  0x00007fa99b1d296d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7fa9734f1700 (LWP 11569)):
#0  0x00007fa99b1c9a93 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa995e07c16 in g_main_context_poll (n_fds=1, fds=0x7fa97c004010, timeout=-1, context=0x45529a0, priority=<optimized out>) at gmain.c:3417
#2  g_main_context_iterate (context=0x45529a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3118
#3  0x00007fa995e07d34 in g_main_context_iteration (context=0x45529a0, may_block=1) at gmain.c:3184
#4  0x00007fa99c788f5b in QEventDispatcherGlib::processEvents (this=0x45502f0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fa99c752720 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa99c7529d5 in QEventLoop::exec (this=0x7fa9734f0e20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fa99c62b915 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fa99c62e2b5 in QThreadPrivate::start (arg=0x454f7a0) at thread/qthread_unix.cpp:298
#9  0x00007fa99aee3e0c in start_thread (arg=0x7fa9734f1700) at pthread_create.c:301
#10 0x00007fa99b1d296d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7fa972cf0700 (LWP 11570)):
#0  0x00007fa99b1c9a93 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa995e07c16 in g_main_context_poll (n_fds=1, fds=0x4556a80, timeout=-1, context=0x45548c0, priority=<optimized out>) at gmain.c:3417
#2  g_main_context_iterate (context=0x45548c0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3118
#3  0x00007fa995e07d34 in g_main_context_iteration (context=0x45548c0, may_block=1) at gmain.c:3184
#4  0x00007fa99c788f5b in QEventDispatcherGlib::processEvents (this=0x45533b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fa99c752720 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa99c7529d5 in QEventLoop::exec (this=0x7fa972cefe20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fa99c62b915 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fa99c62e2b5 in QThreadPrivate::start (arg=0x4537e70) at thread/qthread_unix.cpp:298
#9  0x00007fa99aee3e0c in start_thread (arg=0x7fa972cf0700) at pthread_create.c:301
#10 0x00007fa99b1d296d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fa9713bf700 (LWP 11580)):
#0  0x00007fa99b1c9a93 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa995e07c16 in g_main_context_poll (n_fds=2, fds=0x63b2da0, timeout=-1, context=0x63c1e30, priority=<optimized out>) at gmain.c:3417
#2  g_main_context_iterate (context=0x63c1e30, block=1, dispatch=1, self=<optimized out>) at gmain.c:3118
#3  0x00007fa995e07d34 in g_main_context_iteration (context=0x63c1e30, may_block=1) at gmain.c:3184
#4  0x00007fa99c788f5b in QEventDispatcherGlib::processEvents (this=0x63c19d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fa99c752720 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa99c7529d5 in QEventLoop::exec (this=0x7fa9713bede0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fa99c62b915 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fa99c72d2a0 in QInotifyFileSystemWatcherEngine::run (this=0x63b1e70) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fa99c62e2b5 in QThreadPrivate::start (arg=0x63b1e70) at thread/qthread_unix.cpp:298
#10 0x00007fa99aee3e0c in start_thread (arg=0x7fa9713bf700) at pthread_create.c:301
#11 0x00007fa99b1d296d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fa96f901700 (LWP 11635)):
#0  0x00007fa99aee868c in pthread_cond_wait () from /lib64/libpthread.so.0
#1  0x00007fa9930a5904 in ?? () from /usr/lib64/qt4/libQtWebKit.so.4
#2  0x00007fa9930a5939 in ?? () from /usr/lib64/qt4/libQtWebKit.so.4
#3  0x00007fa99aee3e0c in start_thread (arg=0x7fa96f901700) at pthread_create.c:301
#4  0x00007fa99b1d296d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fa970102700 (LWP 11636)):
#0  0x00007fa99b1c9a93 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa995e07c16 in g_main_context_poll (n_fds=1, fds=0x7fa96803b900, timeout=-1, context=0x6406490, priority=<optimized out>) at gmain.c:3417
#2  g_main_context_iterate (context=0x6406490, block=1, dispatch=1, self=<optimized out>) at gmain.c:3118
#3  0x00007fa995e07d34 in g_main_context_iteration (context=0x6406490, may_block=1) at gmain.c:3184
#4  0x00007fa99c788f5b in QEventDispatcherGlib::processEvents (this=0x720bbf0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fa99c752720 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa99c7529d5 in QEventLoop::exec (this=0x7fa970101e20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fa99c62b915 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fa99c62e2b5 in QThreadPrivate::start (arg=0x720b570) at thread/qthread_unix.cpp:298
#9  0x00007fa99aee3e0c in start_thread (arg=0x7fa970102700) at pthread_create.c:301
#10 0x00007fa99b1d296d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fa927fff700 (LWP 12289)):
#0  0x00007fa99aee868c in pthread_cond_wait () from /lib64/libpthread.so.0
#1  0x00007fa99c62f534 in wait (time=18446744073709551615, this=0x2a89aa0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x297deb0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fa993af4b6e in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2a87800, th=0x847bf40) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa993af778b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a1ef20, th=0x847bf40) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa993af648f in ThreadWeaver::ThreadRunHelper::run (this=0x7fa927ffee30, parent=0x2a87800, th=0x847bf40) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:87
#6  0x00007fa993af6518 in ThreadWeaver::Thread::run (this=0x847bf40) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:142
#7  0x00007fa99c62e2b5 in QThreadPrivate::start (arg=0x847bf40) at thread/qthread_unix.cpp:298
#8  0x00007fa99aee3e0c in start_thread (arg=0x7fa927fff700) at pthread_create.c:301
#9  0x00007fa99b1d296d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fa9277fe700 (LWP 12290)):
#0  0x00007fa99aee868c in pthread_cond_wait () from /lib64/libpthread.so.0
#1  0x00007fa99c62f534 in wait (time=18446744073709551615, this=0x2a89aa0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x297deb0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fa993af4b6e in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2a87800, th=0x8cc3670) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa993af778b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a1ef20, th=0x8cc3670) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa993af77a4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a1ef20, th=0x8cc3670) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fa993af648f in ThreadWeaver::ThreadRunHelper::run (this=0x7fa9277fde30, parent=0x2a87800, th=0x8cc3670) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:87
#7  0x00007fa993af6518 in ThreadWeaver::Thread::run (this=0x8cc3670) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2/threadweaver/Weaver/Thread.cpp:142
#8  0x00007fa99c62e2b5 in QThreadPrivate::start (arg=0x8cc3670) at thread/qthread_unix.cpp:298
#9  0x00007fa99aee3e0c in start_thread (arg=0x7fa9277fe700) at pthread_create.c:301
#10 0x00007fa99b1d296d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fa99e256760 (LWP 11565)):
[KCrash Handler]
#6  0x0000020000000200 in ?? ()
#7  0x00007fa973d62ae0 in Cpp::AdaptDefinitionSignatureAssistant::parseJobFinished (this=0x95c7650, job=0x9608d90) at /var/tmp/portage/dev-util/kdevelop-4.3.1/work/kdevelop-4.3.1/languages/cpp/codegen/signatureassistant.cpp:321
#8  0x00007fa99c76e039 in QMetaObject::activate (sender=0x2a86ce0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff9190fcb0) at kernel/qobject.cpp:3547
#9  0x00007fa9987e155f in KDevelop::BackgroundParser::parseJobFinished (this=<optimized out>, _t1=0x9608d90) at /var/tmp/portage/dev-util/kdevplatform-1.3.1/work/kdevplatform-1.3.1_build/language/backgroundparser.moc:241
#10 0x00007fa9987e1ec0 in KDevelop::BackgroundParser::parseComplete (this=0x2a86ce0, job=<optimized out>) at /var/tmp/portage/dev-util/kdevplatform-1.3.1/work/kdevplatform-1.3.1/language/backgroundparser/backgroundparser.cpp:524
#11 0x00007fa9987e5ee3 in KDevelop::BackgroundParser::qt_static_metacall (_o=0x2a86ce0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /var/tmp/portage/dev-util/kdevplatform-1.3.1/work/kdevplatform-1.3.1_build/language/backgroundparser.moc:171
#12 0x00007fa99c76e039 in QMetaObject::activate (sender=0x9608d90, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff91910040) at kernel/qobject.cpp:3547
#13 0x00007fa993af6852 in ThreadWeaver::Job::done (this=<optimized out>, _t1=0x9608d90) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2_build/threadweaver/Weaver/Job.moc:111
#14 0x00007fa99c76e039 in QMetaObject::activate (sender=0x2830a20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff919101b0) at kernel/qobject.cpp:3547
#15 0x00007fa993af6852 in ThreadWeaver::Job::done (this=<optimized out>, _t1=0x2830a20) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2_build/threadweaver/Weaver/Job.moc:111
#16 0x00007fa99c76bf96 in QObject::event (this=0x2830a20, e=<optimized out>) at kernel/qobject.cpp:1195
#17 0x00007fa99b94d53d in QApplicationPrivate::notify_helper (this=0x235ace0, receiver=0x2830a20, e=0x9df2730) at kernel/qapplication.cpp:4554
#18 0x00007fa99b952de8 in QApplication::notify (this=<optimized out>, receiver=0x2830a20, e=0x9df2730) at kernel/qapplication.cpp:4415
#19 0x00007fa99cfb5dc6 in KApplication::notify (this=0x7fff91910ed0, receiver=0x2830a20, event=0x9df2730) at /var/tmp/portage/kde-base/kdelibs-4.8.2/work/kdelibs-4.8.2/kdeui/kernel/kapplication.cpp:311
#20 0x00007fa99c75411c in QCoreApplication::notifyInternal (this=0x7fff91910ed0, receiver=0x2830a20, event=0x9df2730) at kernel/qcoreapplication.cpp:876
#21 0x00007fa99c757c3d in sendEvent (event=0x9df2730, receiver=0x2830a20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x2324670) at kernel/qcoreapplication.cpp:1500
#23 0x00007fa99c788dc3 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#24 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#25 0x00007fa995e078ba in g_main_dispatch (context=0x235ab00) at gmain.c:2515
#26 g_main_context_dispatch (context=0x235ab00) at gmain.c:3052
#27 0x00007fa995e07c78 in g_main_context_iterate (context=0x235ab00, block=1, dispatch=1, self=<optimized out>) at gmain.c:3123
#28 0x00007fa995e07d34 in g_main_context_iteration (context=0x235ab00, may_block=1) at gmain.c:3184
#29 0x00007fa99c788f5b in QEventDispatcherGlib::processEvents (this=0x2325b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#30 0x00007fa99ba09afe in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007fa99c752720 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007fa99c7529d5 in QEventLoop::exec (this=0x7fff91910b80, flags=...) at kernel/qeventloop.cpp:204
#33 0x00007fa99c75811b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#34 0x000000000040c40b in main (argc=<optimized out>, argv=0x7fff00000000) at /var/tmp/portage/dev-util/kdevelop-4.3.1/work/kdevelop-4.3.1/app/main.cpp:479

Possible duplicates by query: bug 291818, bug 290433, bug 277946.

Reported using DrKonqi
Comment 1 Milian Wolff 2012-04-25 17:29:09 UTC
duplicate of 298676, if you can easily reproduce this, please do so when running kdevelop through valgrind

*** This bug has been marked as a duplicate of bug 298676 ***
Comment 2 Kevin Funk 2012-12-01 20:14:25 UTC
*** Bug 303644 has been marked as a duplicate of this bug. ***