Bug 291818 - KDevelop crashed when removing method
Summary: KDevelop crashed when removing method
Status: RESOLVED DUPLICATE of bug 298676
Alias: None
Product: kdevelop
Classification: Applications
Component: Language Support: CPP (old) (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: 4.2.3
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-18 00:13 UTC by Aleix Pol
Modified: 2012-04-25 17:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleix Pol 2012-01-18 00:13:20 UTC
Application: kdevelop (4.3.60)
KDE Platform Version: 4.7.98 (4.8 RC2+ (4.7.98) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.1.7-1-ARCH i686

-- Information about the crash:
- What I was doing when the application crashed:
On the review code area, I fully removed a method (a QDebug operator<< implementation).

-- Backtrace:
Application: KDevelop (kdevelop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb1f30740 (LWP 3266))]

Thread 10 (Thread 0xaef5cb40 (LWP 3268)):
#0  0xb76fe424 in __kernel_vsyscall ()
#1  0xb61c6cf3 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb623f02f in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb4d0dd3f in KDevelop::DUChainPrivate::CleanupThread::run (this=0x8c15388) at /home/kde-devel/kdevplatform/language/duchain/duchain.cpp:282
#4  0xb623eb30 in ?? () from /usr/lib/libQtCore.so.4
#5  0xb61c2d4c in start_thread () from /lib/libpthread.so.0
#6  0xb547303e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 9 (Thread 0xabe74b40 (LWP 3271)):
#0  0xb52f0dcd in clock_gettime () from /lib/librt.so.1
#1  0xb629c8e5 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6385016 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb63869eb in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timeval*) () from /usr/lib/libQtCore.so.4
#4  0xb6386f84 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb635070d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb63509a9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb623b69c in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0xb4e215f7 in KDevelop::CompletionWorkerThread::run (this=0x8da1988) at /home/kde-devel/kdevplatform/language/codecompletion/codecompletionmodel.cpp:84
#9  0xb623eb30 in ?? () from /usr/lib/libQtCore.so.4
#10 0xb61c2d4c in start_thread () from /lib/libpthread.so.0
#11 0xb547303e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 8 (Thread 0xab4ffb40 (LWP 3272)):
#0  0xb52f0dcd in clock_gettime () from /lib/librt.so.1
#1  0xb629c8e5 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6385016 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb63869eb in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timeval*) () from /usr/lib/libQtCore.so.4
#4  0xb6386f84 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb635070d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb63509a9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb623b69c in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0xb4e215f7 in KDevelop::CompletionWorkerThread::run (this=0x8da1f10) at /home/kde-devel/kdevplatform/language/codecompletion/codecompletionmodel.cpp:84
#9  0xb623eb30 in ?? () from /usr/lib/libQtCore.so.4
#10 0xb61c2d4c in start_thread () from /lib/libpthread.so.0
#11 0xb547303e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 7 (Thread 0xaa2ffb40 (LWP 3277)):
#0  0xb76fe424 in __kernel_vsyscall ()
#1  0xb61c694b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb51dcb39 in ?? () from /usr/lib/libQtScript.so.4
#3  0xb51dcb7f in ?? () from /usr/lib/libQtScript.so.4
#4  0xb61c2d4c in start_thread () from /lib/libpthread.so.0
#5  0xb547303e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 6 (Thread 0xa745db40 (LWP 3296)):
#0  0xb76fe424 in __kernel_vsyscall ()
#1  0xb61c694b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb38b9483 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0xb38b959f in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb61c2d4c in start_thread () from /lib/libpthread.so.0
#5  0xb547303e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 5 (Thread 0xa6c5cb40 (LWP 3308)):
#0  0xb52f0dcd in clock_gettime () from /lib/librt.so.1
#1  0xb629c8e5 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6385016 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb6386452 in ?? () from /usr/lib/libQtCore.so.4
#4  0xb6386f97 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb635070d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb63509a9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb623b69c in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0xb623b78b in QThread::run() () from /usr/lib/libQtCore.so.4
#9  0xb623eb30 in ?? () from /usr/lib/libQtCore.so.4
#10 0xb61c2d4c in start_thread () from /lib/libpthread.so.0
#11 0xb547303e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 4 (Thread 0xa47ffb40 (LWP 3507)):
#0  0xb76fe424 in __kernel_vsyscall ()
#1  0xb61c694b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb623f0a0 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb6e96be0 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8a784d8, th=0x9e4bd10) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0xb6e9acfc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x89e7850, th=0x9e4bd10) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:80
#5  0xb6e96b5f in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8a784d8, th=0x9e4bd10) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:356
#6  0xb6e9aca2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x89e7850, th=0x9e4bd10) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb6e96b38 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8a784d8, th=0x9e4bd10, previous=0x0) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb6e9acc8 in ThreadWeaver::WorkingHardState::applyForWork (this=0x89e7850, th=0x9e4bd10) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:74
#9  0xb6e96b38 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8a784d8, th=0x9e4bd10, previous=0x0) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb6e9acc8 in ThreadWeaver::WorkingHardState::applyForWork (this=0x89e7850, th=0x9e4bd10) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:74
#11 0xb6e96b38 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8a784d8, th=0x9e4bd10, previous=0xa149828) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#12 0xb6e986a7 in ThreadWeaver::ThreadRunHelper::run (this=0xa47ff2a4, parent=0x8a784d8, th=0x9e4bd10) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/Thread.cpp:87
#13 0xb6e9895d in ThreadWeaver::Thread::run (this=0x9e4bd10) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/Thread.cpp:142
#14 0xb623eb30 in ?? () from /usr/lib/libQtCore.so.4
#15 0xb61c2d4c in start_thread () from /lib/libpthread.so.0
#16 0xb547303e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xa3ffeb40 (LWP 3508)):
#0  0xb76fe424 in __kernel_vsyscall ()
#1  0xb61c694b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb623f0a0 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb6e96be0 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8a784d8, th=0x9f75a20) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0xb6e9acfc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x89e7850, th=0x9f75a20) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:80
#5  0xb6e96b5f in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8a784d8, th=0x9f75a20) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:356
#6  0xb6e9aca2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x89e7850, th=0x9f75a20) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb6e96b38 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8a784d8, th=0x9f75a20, previous=0xc75c7f8) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb6e986a7 in ThreadWeaver::ThreadRunHelper::run (this=0xa3ffe2a4, parent=0x8a784d8, th=0x9f75a20) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/Thread.cpp:87
#9  0xb6e9895d in ThreadWeaver::Thread::run (this=0x9f75a20) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/Thread.cpp:142
#10 0xb623eb30 in ?? () from /usr/lib/libQtCore.so.4
#11 0xb61c2d4c in start_thread () from /lib/libpthread.so.0
#12 0xb547303e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xa937eb40 (LWP 3819)):
#0  0xb52f0dcd in clock_gettime () from /lib/librt.so.1
#1  0xb629c8e5 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6385016 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb638536a in ?? () from /usr/lib/libQtCore.so.4
#4  0xb638700e in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb635070d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb63509a9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb623b69c in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0xb632dd4d in ?? () from /usr/lib/libQtCore.so.4
#9  0xb623eb30 in ?? () from /usr/lib/libQtCore.so.4
#10 0xb61c2d4c in start_thread () from /lib/libpthread.so.0
#11 0xb547303e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb1f30740 (LWP 3266)):
[KCrash Handler]
#7  0xac0fd7b1 in Cpp::AdaptDefinitionSignatureAssistant::parseJobFinished (this=0xb7e0178, job=0xcbc43d8) at /home/kde-devel/kdevelop/languages/cpp/codegen/signatureassistant.cpp:313
#8  0xac0fe5a4 in Cpp::AdaptDefinitionSignatureAssistant::qt_static_metacall (_o=0xb7e0178, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbffa6528) at /home/kde-devel/build-kdevelop/languages/cpp/signatureassistant.moc:50
#9  0xb63683d1 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#10 0xb4ce716e in KDevelop::BackgroundParser::parseJobFinished (this=0x8a5f8b0, _t1=0xcbc43d8) at /home/kde-devel/build-kdevplatform/language/backgroundparser.moc:241
#11 0xb4ce55f6 in KDevelop::BackgroundParser::parseComplete (this=0x8a5f8b0, job=0xcbc43d8) at /home/kde-devel/kdevplatform/language/backgroundparser/backgroundparser.cpp:524
#12 0xb4ce6dc8 in KDevelop::BackgroundParser::qt_static_metacall (_o=0x8a5f8b0, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbffa6758) at /home/kde-devel/build-kdevplatform/language/backgroundparser.moc:171
#13 0xb63683d1 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#14 0xb6e99ba0 in ThreadWeaver::Job::done (this=0xcbc43d8, _t1=0xcbc43d8) at /home/kde-devel/build-src/kdelibs/threadweaver/Weaver/Job.moc:111
#15 0xb6e9c377 in ThreadWeaver::JobCollection::jobRunnerDone (this=0xcbc43d8) at /home/kde-devel/src/kdelibs/threadweaver/Weaver/JobCollection.cpp:300
#16 0xb6e9c696 in ThreadWeaver::JobCollection::qt_static_metacall (_o=0xcbc43d8, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbffa6898) at /home/kde-devel/build-src/kdelibs/threadweaver/Weaver/JobCollection.moc:52
#17 0xb63683d1 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#18 0xb6e99ba0 in ThreadWeaver::Job::done (this=0xc75c7f8, _t1=0xc75c7f8) at /home/kde-devel/build-src/kdelibs/threadweaver/Weaver/Job.moc:111
#19 0xb6e999cd in ThreadWeaver::Job::qt_static_metacall (_o=0xc75c7f8, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xa25b9798) at /home/kde-devel/build-src/kdelibs/threadweaver/Weaver/Job.moc:54
#20 0xb6363921 in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#21 0xb636c99b in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#22 0xb582d914 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#23 0xb5832d43 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#24 0xb67409a2 in KApplication::notify (this=0xbffa71d8, receiver=0xc75c7f8, event=0xa506af68) at /home/kde-devel/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#25 0xb6351b7e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#26 0xb63557f8 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#27 0xb6386f0f in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0xb58e22ee in ?? () from /usr/lib/libQtGui.so.4
#29 0xb635070d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#30 0xb63509a9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0xb6355bda in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#32 0xb582b774 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#33 0x08052f3b in main (argc=3, argv=0xbffa7ae4) at /home/kde-devel/kdevelop/app/main.cpp:479

Reported using DrKonqi
Comment 1 Milian Wolff 2012-04-25 17:30:44 UTC
merging: if reproducible, please run kdevelop through valgrind and attach the info to bug 298676

*** This bug has been marked as a duplicate of bug 298676 ***