Bug 298809 - Crash on switching desktops with mouse wheel after suspend
Summary: Crash on switching desktops with mouse wheel after suspend
Status: RESOLVED DUPLICATE of bug 286353
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.7.4
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-25 13:50 UTC by BryanFRitt
Modified: 2012-05-26 17:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BryanFRitt 2012-04-25 13:50:32 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-17-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
After suspends, if I scroll with the mouse over the desktop (set to 'Switch Desktop'), this crash will occur.

- Custom settings of the application:
I have one 'Activity' set to a white background, another a black background, another set to 'Search and launch' and the 'Weather' wallpaper, and another 'Activity'  just the 'Weather' wallpaper.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f69a32f87c0 (LWP 13796))]

Thread 3 (Thread 0x7f6981683700 (LWP 13797)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f69816829f0 in ?? ()
#2  0x00007fff47dff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f6973fdb700 (LWP 13804)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f6973fda9f0 in ?? ()
#2  0x00007fff47dff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f69a32f87c0 (LWP 13796)):
[KCrash Handler]
#6  KWindowInfo::valid (this=0x4156252, withdrawn_is_valid=true) at ../../kdeui/windowmanagement/kwindowinfo_x11.cpp:133
#7  0x00007f697b76d4d6 in TaskManager::Task::isOnCurrentDesktop (this=0x4c75830) at ../../../libs/taskmanager/task.cpp:211
#8  0x00007f696ebf8c64 in TaskSource::updateDesktop (this=0x4cdb140, desktop=<optimized out>) at ../../../../../plasma/generic/dataengines/tasks/tasksource.cpp:161
#9  0x00007f696ebf8fc3 in TaskSource::qt_metacall (this=0x4cdb140, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff47d49990) at ./tasksource.moc:82
#10 0x00007f699fdc8eba in QMetaObject::activate (sender=0x14fa260, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff47d49990) at kernel/qobject.cpp:3278
#11 0x00007f697b7796f1 in TaskManager::TaskManager::desktopChanged (this=<optimized out>, _t1=2) at ./taskmanager.moc:200
#12 0x00007f697b77b237 in TaskManager::TaskManager::qt_metacall (this=0x14fa260, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0x7fff47d49b60) at ./taskmanager.moc:127
#13 0x00007f699fdc8eba in QMetaObject::activate (sender=0xa83610, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff47d49b60) at kernel/qobject.cpp:3278
#14 0x00007f69a0b9b76e in KWindowSystem::currentDesktopChanged (this=<optimized out>, _t1=2) at ./kwindowsystem.moc:122
#15 0x00007f69a0b9dc63 in KWindowSystemPrivate::x11Event (this=0xad3900, ev=0x7fff47d49c70) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:175
#16 0x00007f69a0a8d3e6 in publicX11Event (e=0x7fff47d49c70, this=<optimized out>) at ../../kdeui/kernel/ksystemeventfilter.cpp:43
#17 KSystemEventFilterPrivate::filterEvent (this=0xad6370, message=0x7fff47d49c70) at ../../kdeui/kernel/ksystemeventfilter.cpp:102
#18 0x00007f699f20d418 in x11EventSourceDispatch (s=0x8e2870, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:143
#19 0x00007f6996f38a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f6996f39258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f6996f39429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f699fde0ed6 in QEventDispatcherGlib::processEvents (this=0x80ff40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#23 0x00007f699f20d10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007f699fdb4cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007f699fdb4ef7 in QEventLoop::exec (this=0x7fff47d4a040, flags=...) at kernel/qeventloop.cpp:201
#26 0x00007f699fdb9789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#27 0x00007f69a2f011a3 in kdemain (argc=1, argv=0x7fff47d4a428) at ../../../../plasma/desktop/shell/main.cpp:120
#28 0x00007f69a2b4030d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff47d4a428, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff47d4a418) at libc-start.c:226
#29 0x0000000000400671 in _start ()

Possible duplicates by query: bug 297093, bug 295116, bug 291700, bug 290829, bug 290024.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-26 17:50:27 UTC

*** This bug has been marked as a duplicate of bug 286353 ***